Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Default language

  • 4 replies
  • 1 has this problem
  • 3 views
  • آخر ردّ كتبه McCoy

more options

My default language set to English. However, when I open a logon window, my account and browser settings the language switches to Vietnamese. Firefox version is 77 running on Windows 10.

Where do I check the settings to switch back to English? I have only English set in General -> Language. Any other settings that may affects the language I want to use?

Thanks, H Doan

Attached screenshots

Chosen solution

I live in the US and download Firefox from Firefox so I assume it's Firefox in English. I uninstalled Firefox from my computer, downloaded Firefox (78.0.1 version) from the link you sent and installed Firefox. Launch Firefox from the new installation, I got a suggestion to refresh Firefox that seems to remove old settings, cache data from my profile. After the refresh now Firefox shows everything in English. I verify the default language is English (United State) just like I had before. I believe somewhere in my profile (cache data) it retained Vietnamese and now it's gone after a refresh.

Many thanks for your help. H Doan

Read this answer in context 👍 0

All Replies (4)

more options

Hi,

In the Firefox Options-> General -> Language there is: -"Choose your preferred language for displaying pages". Click on "Choose" and I believe by removing the language which you do not wish to have, in this case Vietnamese, the browser will display in the language you desire. Tell me if that solves your problem. Thank you.

Helpful?

more options

Hello hdoanz,

Looking at your screenshot, it looks like this applies to menus only (?)

Did you download Firefox in English from here (?) :

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

If so, please try to start Firefox with the -purgecaches command line switch - see the last comment in this bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=1564998

Try to add the full path to the Firefox installation folder.

• "C:\Program Files\Mozilla Firefox\firefox.exe" -purgecaches
• (64-bit Firefox) "C:\Program Files\Mozilla Firefox\"
• (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\"

Also see : https://developer.mozilla.org/en-US/Command_Line_Options

Helpful?

more options

Chosen Solution

I live in the US and download Firefox from Firefox so I assume it's Firefox in English. I uninstalled Firefox from my computer, downloaded Firefox (78.0.1 version) from the link you sent and installed Firefox. Launch Firefox from the new installation, I got a suggestion to refresh Firefox that seems to remove old settings, cache data from my profile. After the refresh now Firefox shows everything in English. I verify the default language is English (United State) just like I had before. I believe somewhere in my profile (cache data) it retained Vietnamese and now it's gone after a refresh.

Many thanks for your help. H Doan

Helpful?

more options

hdoanz said

Many thanks for your help.

My pleasure   -   I'm really glad that you've got things back to normal !

Would you be so kind as to remove the Chosen Solution mark from my post and mark your own (last) post instead ?
After all :   you did way more than I suggested   -   well done !

(edit: typo)

Modified by McCoy

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.