Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to stop URL bar from enlarging on click onf firefox 77?

  • 24 replies
  • 4 have this problem
  • 2124 views
  • آخر ردّ كتبه jscher2000

more options

I hate it when I click on the url-field and its size change.

It wasn't there in former firefox versions and I did not miss it. It changed some time ago. Any decent software development would have introduced his new feature and provided a "classic" option to turn it off. Not so firefox. Mozilla introduced it and I had to google how to get the old behaviour back. No option.. I have to go to about:config, ignore teh warnings, find some weird options and set them to false and the mozilla turned that off too. Now the was to change it is to set up a css-file, got to about:config again to make firefox actually read that file, place some mystery css-code in there and it still does not work!

Very annoying, an outstanding example of bad practice how to introduce new features and take away users choices.

So: How to stop URL bar from enlarging on click?

All Replies (20)

more options

For Firefox 78, you have a new option. More details below the second line.


Hi joe80, I'm not sure which steps you followed, but please try it this way:

(For anyone who already has a working userChrome.css file set up, you just need to add the rules you downloaded under (A) to your file.)

(A) Download a rules file

https://www.userchrome.org/samples/userChrome-ZeroEnlargement.css

Use the downloads list on the toolbar to open the downloads folder directly to the new userChrome.css file. (See attached screenshot)

Minimize that file browser window for later reference.

(B) Create a new chrome folder in your profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)

https://www.userchrome.org/how-create-userchrome-css.html

I have videos for both Windows and Mac in case the text is not clear.

(C) Move the userChrome-ZeroEnlargement.css file you downloaded in Step A into the chrome folder you created in Step B

(D) If you do not already have a userChrome.css file, Rename the userChrome-ZeroEnlargement.css file

Highlight userChrome-ZeroEnlargement.css and choose Rename (using whatever method Finder offers). Carefully remove -ZeroEnlargement and press Enter to save your change. The final file name needs to be userChrome.css or Firefox will never find it.

(E) Set Firefox to look for userChrome.css at startup -- see step #6 in the above article.

The next time you exit Firefox and start it up again, it should discover that file and apply the rules.

Success?

Once you start tweaking the interface this way, you'll probably find more and more things you want to do. I suggest bookmarking the pages where you get the code for future reference because changes to Firefox may break them and it's easier to request an update if you can find the source.


Firefox 78 will not initially animate/enlarge when the cursor enters the box *if* you have a system-level preference for reduced animations. You also can create a new preference in about:config if you do not have the option to set it at the system level. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste the new preference name

ui.prefersReducedMotion

If this preference was already created and shows a value of 0, skip to step (4).

(3) On the bar with the preference name, click the radio button next to Number and click the + button to add the preference. Then Firefox should display the new value.

(4) Set the value to 1 (double-click to edit if necessary) and click the blue checkmark button or press Enter to save the change.

Screenshot sequence attached for reference.

Modified by jscher2000

Helpful?

more options

hello joe,

UPDATE

The original solution was for Firefox 75. Due to changes in Firefox 77, the original solution is obsolete and there are new options.

Firefox supports an optional style sheet file named userChrome.css that we can use to modify the toolbar area, including taming the expanding address bar. Setting up your first userChrome.css file is about a 10 minute project, so when you have time to dive in, here are some threads to check out:

More background on userChrome.css files: [https://www.userchrome.org/]

Original Solution (Firefox 75-76)

In Nightly, there is a specific preference for this in about:config called browser.urlbar.update1 (previously known as browser.urlbar.megabar).

Setting that to false will revert the bar to its more typical behavior in new windows (the windows that are already open seem to keep the megabar behavior until the next session).

For anyone unfamiliar:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) Double-click the browser.urlbar.update1 preference to switch the value from true to false

Note: This preference does not exist in Firefox 71-72.

tell me when fixed you problem.

thank you!

Helpful?

more options

@jscher I tried the steps you provided in another thread.

I found a file named userContent.css in the chrome directory and though this is it, so I added the content of your file there. It did not help.

So I downloaded the file and placed it as "userChrome.css" in my chrome directory. That worked.

Thanks a lot.


However: I had a nice running firefox and had a lot of trouble today just because of a poorly introduced new feature. I'm very pissed. I mean, I accept it if there are security reasons that require some modification, but this is just afield enlargement, a cosmetic change that is not at all necessary and mozilla forced me into changing it TWO TIMES! And still I really don't exactly know what I did and why I had to to it and I JUST DON'T WANT TO KNOW, I don't even want to have to do this at all.

This is a example of how not to make changes in a software.

Helpful?

more options

You are right .Mozilla do a lot of stuff as change color in padlock SSL and another what really is not necessary for as. All of this I had to turn back All. I reported some mistake in Firefox in bugzilla.mozilla.org .They have time the do nor rush . Before few years ago reaction was fast now disaster. Firefox will be loose client .

Generally said I fuc-- off they enlarging bar .and other not necessary fix.

I understand you totally.

Helpful?

more options

Yes, I'm also on alert to look for an alternative browser. Wouldn't be the first time I used something else (it was chrome back then when FF was so extremely slow).

I will observe the development now and then decide

Helpful?

more options

I like Firefox and use all my life .But now the are very slow do reason.Spend time to fix put new feature even old was good . I understand fix some important vulnerable issue.But powdering face it is waste time. Look Firefox has about 100 click buttons .I personally use maybe about 4 .I do not need more. Read website with secure browser .

Firefox now do hundred connection for some server if you start opening some website . Telemetry why .why they spy me . I do not understand this behavior .Polish people also do not understand this business plan.?

Helpful?

more options

I have grudgingly changed the setting in about:config the last few versions to get rid of this behavior. Now the FF team wants users to start editing CSS !?! I feel truly sorry for the average user who just wants this irritating behavior gone.

Helpful?

more options

Hi Lapyx, "hacking" the user interface by setting up a userChrome.css file is not an official recommendation, it's a workaround developed by the user community. Sorry if that wasn't clear.

Helpful?

more options

Grab Firefox 76.0.1 and stick with it as long as you can since it has an official way to disable the ugliness of enlarging address bar. It might require you to add --allow-downgrade next to firefox.exe to make 77’s profile work again after rolling back to 76. Also, keep expressing your disapproval of this unwanted and irreversible interface arm-twisting to shame those collaborators who helped to mess things up.

Modified by Aleksandr

Helpful?

more options

Since 77 it is not possible anymore to revert to the old toolbar. I recommend using 76. This is one of the reasons I moved away from chrome actually: Forcing users into features they don't like. Now Firefox starts with it as well. The new toolbar is missing functionality from the old one that was helpful.

Helpful?

more options

Hi ChrisB, you are correct that you cannot revert Firefox 77 to the Firefox 74 address bar. When you say --

The new toolbar is missing functionality from the old one that was helpful.

-- what are you referring to?

Helpful?

more options

Hi,

the most important one is the fact, that on the right I cannot open anymore the list with recent websites. That forces me to use the keyboard what was not needed before.

Best, Chris

Helpful?

more options

ChrisB said

the most important one is the fact, that on the right I cannot open anymore the list with recent websites. That forces me to use the keyboard what was not needed before.

Hi Chris, by default, a list opens automatically when you click the bar, but if you changed browser.urlbar.openViewOnFocus to false, then you definitely need to type a space or use another method to open a list, especially if you want the classic list rather than seeing your first 8 Top Sites on the new tab page.

As another possible workaround, I created an extension to show a similar frequently visited URLs list (in a separate drop-down). You can read more about its features and limitations on the Add-ons site if you're interested: https://addons.mozilla.org/firefox/addon/show-history-top-sites-button/

Helpful?

more options

I don't understand why this new design doesn't have an easy option to disable it? It is a terrible design. Did Firefox test this new design on anyone? Did they bother to ask people who have different abilities and are not neurotypical if this visual misalignment was acceptable? It is really irritating and makes using the browser uncomfortable for me. I switched to Firefox for privacy. I guess I will be using a different browser.

Helpful?

more options

SanFrancisco49er said

Did they bother to ask people who have different abilities and are not neurotypical if this visual misalignment was acceptable? It is really irritating and makes using the browser uncomfortable for me.

There will be an adjustment in Firefox 78 (releasing in a few days) in response to requests by people who can't tolerate animations well. More info:

https://www.userchrome.org/megabar-styling-firefox-address-bar.html#enlargement

Helpful?

more options

I've been paying AU$3 per month since July 2017 to support Mozilla keep Firefox alive - but this type of development practices have twisted my arm and I'm now going to kill my subscription.

I'm voting with my hard earned $$$.

Helpful?

more options

@jscher2000 There will be an adjustment in Firefox 78 (releasing in a few days) in response to requests by people who can't tolerate animations well. More info:

https://www.userchrome.org/megabar-styling-firefox-address-bar.html#enlargement

I read this and even if it would solve the problem, that's not an easy solution. Especially not if you keep in mind, that the problem should not exist: there was no reason to enlarge the URL-field.

I'm totally with ak.mozilla.

Helpful?

more options

Note that creating this ui.prefersReducedMotion pref effects more than just this case.

Helpful?

more options

Hi all,

glad to hear I am not the only one having an issue here. For me this is actually a showstopper now. I will go back to Firefox 63. Not 76, because it always updates to the newest and it's very hard to stop it from doing so. Firefox 63 has everything I need and I can completely turn off updates.

However, staying with an old Browser is not the solution. I have to think about what to do. Maybe I go back to Chrome or try the new Edge. Because this stuff was the reason to go to Firefox. But since FF is treating users similar now, why should I actually continue with FF...?

Best, Chris

Helpful?

more options

You can easily create a new Number pref ui.prefersReducedMotion = 1 on the about:config page to disable this break out feature and other animations.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Helpful?

  1. 1
  2. 2
اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.