ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Reader view with CMS site is never available

  • 10 ردود
  • 1 has this problem
  • 8 views
  • آخر ردّ كتبه petearmitage

more options

The website I am working on uses Quick.cms. Reader view is not offered for any page on the site. If I cut and paste the generated html from the home page into a new file (test.html) and copy it to the server, the reader view is available for test.html. Is this a bug, a feature or something that I am doing wrong?

الحل المُختار

I found the readermode code and it would appear that unless the web address is followed by 'something' the readermode code does an arbitary discard and does not perform any text checks. The site can also be accessed using http://www.freckletonparishcouncil.org.uk/index.php and lo and behold the reader appears! All I need to do now is work out how to ensure the addional index.php is always used. Website configuration perhaps?

Pete

Read this answer in context 👍 0

All Replies (10)

more options

hello petearmitage,

Try clearing cache,

1. Click the menu button (3 horizontal lines on the top right of your screen)

2. Then click "Options". Once your there, Select "Privacy and Security"

3. In the section, Cookies and site data, click clear data.

4. Click clear if you want to clear cookies as well as cache. If not, uncheck the first box. Hit clear.

5.goto safe mode: ctrl+shift+N

  • more infomation visit link:

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-sa...]


Tell me if that helped ,

Thank you!

more options

Thanks for the quick response but unfortunately it makes no difference. The site is here 'http://www.freckletonparishcouncil.org.uk/' if you want to have a look. I have not copied the test.html file onto the live server so you can't access it.

Pete Armitage

more options

It is probably easier if you also have access to the test.html file so I have copied to the server. You can access it at 'http://www.freckletonparishcouncil.org.uk/test.html'

Pete

more options

hello again petearmitage,

please visit link:

[https://freeola.com/offers/]

thank you!

more options

I don't understand what the purpose of the llink is, unless you are suggesting that I throw away the current site and rebuild it using something else? Wordpress perhaps?

more options

الحل المُختار

I found the readermode code and it would appear that unless the web address is followed by 'something' the readermode code does an arbitary discard and does not perform any text checks. The site can also be accessed using http://www.freckletonparishcouncil.org.uk/index.php and lo and behold the reader appears! All I need to do now is work out how to ensure the addional index.php is always used. Website configuration perhaps?

Pete

more options

Hi Pete, that must be something new because most blogs use "clean URLs" and Reader Mode was working fine with them for many years.

Do you still have a link to where in the code it stops parsing?

Hopefully it can get fixed quickly.

more options

Maybe the blog comparison is a poor one because links to posts usually are long paths with dates in them, even if they end with a / character instead of .php, etc.

more options

I didn't get as far as debugging the code I found at https://dxr.mozilla.org/mozilla-release/source/toolkit/components/reader/ReaderMode.jsm I just noticed that there are a lot of url checks and wondered if it was a problem with other CMS's. When I looked at a Wordpress site I noticed that where my CMS adds a ?pagename to the domain name, Wordpress adds a directory name /pagename/, which works fine. My thought was that the ? may be a special character and if it immediately follows the domain name then the url is discarded. In my case I found that http://www.freckletonparishcouncil.org.uk/index.php?home works but the default http://www.freckletonparishcouncil.org.uk/?home doesn't. Sorry I can't be more helpful.

more options

A full description of the work-around I am now using; Move all files from the website root into a new diirectory /site Create a new root index.php containing the following;

header( 'Location: /site/index.php' ); exit;

?>

The links now appear as http://www.freckletonparishcouncil.org.uk/site/?pagename

Reader now recognises the text on the page and displays the reader view option.