Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Only get empty pages when opening pdf file. It works with Microsoft Edge.

  • 3 replies
  • 1 has this problem
  • آخر ردّ كتبه cor-el

more options

Got a new pc (Lenovo AIO 540) 2 days ago. Wanted to open a pdf webfile with my standard browser firefox. I only got an empty page. It worked with my former pc (HP). Changed the opening for a pdf file to Acrobat in the settings, but the result was the same. Tried the same with Microsoft Edge and it worked surprisingly. I don´t wanna change my standard browser from firefox in any othe one. Has anybody an idea what to change in the settings of firefox or adobe to get a correct result?

Thx in advance. Michael

All Replies (3)

more options

Hi Michael, it's puzzling.

Firefox uses an internal JavaScript converter to render PDFs as HTML pages using an HTML canvas. This is generally successful, although PDFs with layers may not be rendered correctly.

But maybe there is a redirect that Firefox isn't following so you never even get the PDF? If you call up the Page Info dialog on the empty page, what type of page does Firefox say it is? You can do that using either:

  • Ctrl+i
  • right-click > View Page Info
  • (menu bar) Tools > Page Info

For a PDF, you would normally expect

Type: application/pdf

- - - -

Also, please make sure the redirect block is turned off:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste access and pause while the list is filtered

(3) If the accessibility.blockautorefresh preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false


more options

Thank you very much for your reply,

the type ist text/html. The redirection block is turned off but my pdf web page stays empty as can be. I tried it also with Chrome and it worked the same as with Edge.

But again, thank you for your support.


more options

You can check in the Web Console for related messages.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window


اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.