Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No audio from Firefox only in Win 10

  • 1 reply
  • 1 has this problem
  • 19 views
  • آخر ردّ كتبه shehan

more options

For some time now I have had no audio when playing media on Firefox. I'm on a Dell laptop using WIN 10 and system sounds, iTunes etc all work fine.

I tried the Audio mixer and when it starts there is a speaker with a little x beside it showing even though the number shows 100. Tried with 2 tabs - one plays a video from BBC iPlayer and the other Youtube. Playig with Audio Mixer settings I got the sound to come from BBC video - Youtube nothing. Of course resarting FF set the Audio Mixer back to normal settings again so that isn't a fix at all.

All drivers and Win system updates are in force and my Firefox updates automatically. I use the Sync settings in FF to work between Mac and PC so not being able to use it any more would be a major problem. Any ideas?

Chosen solution

Hii

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux). Select the Advanced panel and the General tab. Uncheck Use hardware acceleration when available. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above: Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux). Select the General panel. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.

Uncheck Use hardware acceleration when available. Close Firefox completely and then restart Firefox to see if the problem persists.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Hii

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux). Select the Advanced panel and the General tab. Uncheck Use hardware acceleration when available. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above: Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux). Select the General panel. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.

Uncheck Use hardware acceleration when available. Close Firefox completely and then restart Firefox to see if the problem persists.