Search Support

Firefox timing out on site access

  • 5 replies
  • 1 has this problem
  • 7 views
  • آخر ردّ كتبه FredMcD

more options

I have an issue with Firefox timing out when attempting to access sites.

My internet service, CenturyClink is 100mb+. I've contacted them and their "technicians" my router (Linksys C3000A) is up to date and functioning fine.

When attempting to access sites with Firefox a "dot" appears in the tab moving back and forth like a metronome for ever before timing out. This has been happening for several weeks.

IE, Chrome are slow but don't time out.

Running Windows 10 Home Edition, Firefox v 74.0 All updates, patches have been installed as of this AM.

Idea? Is it Firefox or a Windows 10 problem?

All Replies (5)

more options

Let's try a refresh:


The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Helpful?

more options

After the above, Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop

Helpful?

more options

Responding to this email took 2+ minutes for mozilla.org to load.


Tried three approaches:

Simply Refresh - no noticeable performance improvement

Launched Firefox in Safe mode still sluggish.

Third method tried, Start in Safe mode, then do Refresh while in Safe mode. A little better.

Will have to simply monitor its performance to see if it times out on important sites i.e. banks, personal, online merchants.

Thanks, Stay tuned.

Helpful?

more options

Responding to this email took 2+ minutes for mozilla.org to load.


Tried three approaches:

Simply Refresh - no noticeable performance improvement

Launched Firefox in Safe mode still sluggish.

Third method tried, Start in Safe mode, then do Refresh while in Safe mode. A little better.

Will have to simply monitor its performance to see if it times out on important sites i.e. banks, personal, online merchants.

Thanks, Stay tuned.

Helpful?

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.