X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

منتدى الدعم

When using passwords containing the dollar sign "$" Firefox won't autofill or login correctly

Posted

I'm encountering this problem: I have a few passwords which contain "$" and Lockwise refuses to save the entire password after the symbol (i.e.: "123456$abc" will be saved as "123456$"). Additionally, when I manually correct this by editing the password in Lockwise, then go back to the website to log in, autofill won't fill the password in automatically. After filling in the password and clicking "enter", Firefox asks if I want to save the updated password; when I unhide the password in this popup it has once again removed all characters following the $ (again the password appears as "123456$" instead of "123456$abc"). I'm stuck in a loop attempting to login to a few sites where this continually happens. Going to these sites in Chrome or Safari does not recreate the problem, so I assume it's not the actual websites but how Firefox handles "$" in passwords?

I'm encountering this problem: I have a few passwords which contain "$" and Lockwise refuses to save the entire password after the symbol (i.e.: "123456$abc" will be saved as "123456$"). Additionally, when I manually correct this by editing the password in Lockwise, then go back to the website to log in, autofill won't fill the password in automatically. After filling in the password and clicking "enter", Firefox asks if I want to save the updated password; when I unhide the password in this popup it has once again removed all characters following the $ (again the password appears as "123456$" instead of "123456$abc"). I'm stuck in a loop attempting to login to a few sites where this continually happens. Going to these sites in Chrome or Safari does not recreate the problem, so I assume it's not the actual websites but how Firefox handles "$" in passwords?

Modified by porkpie

Chosen solution

Hello,

porkpie said

Going to these sites in Chrome or Safari does not recreate the problem, so I assume it's not the actual websites but how Firefox handles "$" in passwords?

No, the problem is probably site-specific because I can save the password "123456$abc" just fine in Firefox on any website I test on. Can you please share the URL?

Does setting the preference signon.formlessCapture.enabled to false in about:config solve the problem for you?

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

Facebook Container, 1Password, Feedly Mini, Privacy Badger, Adblock Plus, Disconnect, uBlock Origin, Multi-Account Containers, HTTPS Everywhere

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:74.0) Gecko/20100101 Firefox/74.0

More Information

Eve
  • Top 25 Contributor
  • Administrator
56 solutions 362 answers

ردّ مُفيد

It sounds like a bug. I couldn't find any bugs related to this on bugzilla, but I'm going to reach out to engineers to see what they think.

It sounds like a bug. I couldn't find any bugs related to this on bugzilla, but I'm going to reach out to engineers to see what they think.
هل وجدت هذا مفيدًا؟ 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17846 solutions 161524 answers

What if you do not update the password and possibly create a password block exception for this domain to prevent Firefox from asking to update ?

What if you do not update the password and possibly create a password block exception for this domain to prevent Firefox from asking to update ?
هل وجدت هذا مفيدًا؟
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17846 solutions 161524 answers

Your System Details list shows the 1Password extension.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Your System Details list shows the 1Password extension. Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
هل وجدت هذا مفيدًا؟
Quote
Matthew N. 1 solutions 1 answers

Chosen Solution

Hello,

porkpie said

Going to these sites in Chrome or Safari does not recreate the problem, so I assume it's not the actual websites but how Firefox handles "$" in passwords?

No, the problem is probably site-specific because I can save the password "123456$abc" just fine in Firefox on any website I test on. Can you please share the URL?

Does setting the preference signon.formlessCapture.enabled to false in about:config solve the problem for you?

Hello, ''porkpie [[#question-1282436|said]]'' <blockquote> Going to these sites in Chrome or Safari does not recreate the problem, so I assume it's not the actual websites but how Firefox handles "$" in passwords? </blockquote> No, the problem is probably site-specific because I can save the password "123456$abc" just fine in Firefox on any website I test on. Can you please share the URL? Does setting the preference <code>signon.formlessCapture.enabled</code> to false in about:config solve the problem for you?
هل وجدت هذا مفيدًا؟ 1
Quote

صاحب السؤال

Matthew N. said

Does setting the preference signon.formlessCapture.enabled to false in about:config solve the problem for you?

That seemed to do it thanks

''Matthew N. [[#answer-1300048|said]]'' <blockquote> Does setting the preference <code>signon.formlessCapture.enabled</code> to false in about:config solve the problem for you? </blockquote> That seemed to do it thanks
هل وجدت هذا مفيدًا؟
Quote
اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.