ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Added single pane extension - Firefox now unusable.

  • 13 ردًا
  • 1 has this problem
  • 6 views
  • آخر ردّ كتبه jscher2000

more options

At Firefox' recommendation, I added an extension/addon called 'single pane extension' where I think the idea was that Firefox could be save better. But since the install Firefox has become unusable. I can only use it in safe mode. Here is a screenshot. Sorry, but I can't figure out how to fix this.

Attached screenshots

All Replies (13)

more options

Was it SinglePage, an add-on to save web pages in one file? You can disable or remove extensions on the Add-ons page. (I'll list the steps at the end if needed.)

If I'm reading your screenshot correctly, the page isn't loading fully (there's a blue dot moving on the tab still).

Does it work any better if you use an HTTPS (secure) address:

https://my.earthlink.net/

The toolbar shows some "blockers" are installed, maybe Adblock Plus and Avast. So if problems continue, try clicking each button and see whether something needs to be unblocked.

Are other sites having similar partial loading or failed loading issues?


You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

Modified by jscher2000

more options

jsher2000, I'm only able to communicate with you once I'm in safemode, where none of the extensions and addons show up. I did add "SingleFile | Save a page as a single HTML file" and "Facebook Container", but they don't show up as installed when viewing in safemode. Adblock Ultimate and Adblock Plus are installed.

I can't tell if the page isn't loading fully or if parts are hidden. Regardless, I can't disable any addons or extensions in regular mode because even using Ctrl+Shift+a I have the same screenshot.

more options

PS All sites load this way. Here's another screenshot.

more options

PSS I can't tell if Adblock has anything to do with this because it doesn't show up (disabled) in safemode.

more options

Hmm, I have a guess. Did you put rules in a userChrome.css file to create a multi-line bookmarks toolbar? The old rules don't work properly in Firefox 74, they create a bookmarks toolbar that takes up the entire height of the browser.

As a quick test, turn off the Bookmarks Toolbar using:

View > Toolbars > Bookmarks Toolbar

If you can see the page now, there's your trouble. Possible solution in the following thread:

https://www.reddit.com/r/firefox/comments/fgozre/multiple_bookmark_toolbar_rows_in_ff_74/

Any luck?

more options

Could this have anything to do with what I'm viewing:

"firefox 35 has bookmarks and url combined on one line - Google Search"

more options

webnick said

Could this have anything to do with what I'm viewing: "firefox 35 has bookmarks and url combined on one line - Google Search"

It's possible to move the Bookmarks Toolbar Items from the Bookmarks Toolbar to the Main Toolbar, but it's messy because each bar has an "overflow" menu and what overflows is not very predictable. I don't recommend it.

more options

Are you possibly using code in userChrome.css for a multi-row Bookmarks Toolbar ?

The code in userChrome.css for the multi-row bookmarks toolbar that worked in Firefox 73 seems to be broken in Firefox 74 and needs an update.

more options

While you are in Safe Mode, go to Menu -> Add-ons and disable the extensions Multirow Bookmarks Toolbar Plus and Tabs on Bottom. They will say that they are disabled in parentheses, but, move the button to the left anyway. Then, restart Firefox.

more options

OK, so I've replaced the userChrome.css file I had that allowed for multi-row bookmarks with a replacement from above, but I seem to be limited to just 2 rows. Call me greedy, but I'd like to have more than 2!

So my question is which of the rules or codes in the .css file control how many rows are allowed?

more options

webnick said

OK, so I've replaced the userChrome.css file I had that allowed for multi-row bookmarks with a replacement from above, but I seem to be limited to just 2 rows. Call me greedy, but I'd like to have more than 2! So my question is which of the rules or codes in the .css file control how many rows are allowed?

Some rules sets have a CSS variable for the number of rows. Did you pick one that has that option?

more options

No, J, I didn't see one that had a number of rows rule.

more options