ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The new update has color functionality that I need to turn off. How do I disable the new color functionality?

  • 6 ردود
  • 1 has this problem
  • 67 views
  • آخر ردّ كتبه cor-el

more options

With the new firefox browser update they included color functionality that was supposed to "help" those of us with color vision issues. It doesn't help at all, in fact it actually makes it even harder for some of us to utilize the browser. Now with web sites like yahoo email and ebay, just to name two, there are color accents that are forced upon the user. I utilize a high contrast setting on my computer with the black background and white text. The web browser now ignores that and visiting some web sites it is like looking into a bright flashlight. Is there any way to disable or turn off the new color functionality?

I have also found that trying to use browser themes no longer stays. What I mean is that after setting a "theme" it works until you open a new tab or window and then it goes back to the firefox defaul theme. When checking the add on theme it still says that the theme I wanted is selected and enabled but in truth it isn't.

The first screen shot shows what the theme should be but you can see that it is not working and that happens with any selected and enabled theme.

The second screen shot shows the bright blue bar at the top of the yahoo email page. It used to be black until the 2-11-2020 update of firefox.

The third screen shot is of an ebay page after the update.

I know it seems trivial to those of you with normal color vision but when you cannot work with the color nor change what you are seeing, it is more than just frustrating.

Attached screenshots

All Replies (6)

more options

This is how the theme shopuld look but it will not stay for long.

more options

Regarding the theme issue:

Could you try disabling the Firefox Color extension? I think that could be conflicting with the theme selection on the Add-ons page.

Regarding the in-page color issue:

I haven't followed changes related to High Contrast themes, which used to obliterate all background colors. Did you see an article or blog post about these changes somewhere?

more options

jscher2000 said

Did you see an article or blog post about these changes somewhere?

I see, it's mentioned in the release notes. I'll research it.

more options

Could you test this change?

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste backp and pause while the list is filtered

(3) Double-click the browser.display.permit_backplate preference to switch the value from true to false

I don't know whether that will have any immediate effect or will be applied the next time you exit out and restart Firefox.

Please let me know what happens.

more options

So far it appears to have worked with the color issues for viewing web sites. But I am still having issues with the browser theme not staying as it is set. I set it to a theme and it works for a short time and then reverts to the firefox default. Then I have to go back and set it to a black theme. It is a pain but for now it is all I can do.

more options

See also this question and this bug report,

  • /questions/1279681 The most recent "upgrade" makes unreadable many web pages. How to undo this "upgrade"?
  • Bug 1614921 - Readability backplate makes most of eBay white in High Contrast mode when the background should be black

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)