X
Tap here to go to the mobile version of the site.

منتدى الدعم

Firefox can't handle website realtor.ca.

Posted

Searching doesn't work on this website. Selecting areas, prices, rooms etc work but then clicking on search does nothing. In addition there is text/images smeared across the top of the website..see the attached image. I have tried disabling add-ons, safe mode, clearing the cache etc etc to no avail. By the way, the automatically add button below this page doesn't work. Takes you to an unknown page!!

Searching doesn't work on this website. Selecting areas, prices, rooms etc work but then clicking on search does nothing. In addition there is text/images smeared across the top of the website..see the attached image. I have tried disabling add-ons, safe mode, clearing the cache etc etc to no avail. By the way, the automatically add button below this page doesn't work. Takes you to an unknown page!!
Attached screenshots

Chosen solution

Well, I did all that...and there was no change. What did work? Well I created a new profile and now the site loads properly. I don't know what the problem was, or why is affected only that site but at least it's fixed. Thanks to everyone for suggestions. Luckily I could re-log into my Firefox sync account and because everything had been saved there, the new profile looks like the old one :) Luckily it doesn't act like the old one.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:72.0) Gecko/20100101 Firefox/72.0

More Information

Luna Jernberg 3 solutions 15 answers

Thats wierd, it works for me in Firefox 72.0.2 on Arch Linux

Thats wierd, it works for me in Firefox 72.0.2 on Arch Linux
Was this helpful to you? 0
Quote

Question owner

Yes, that is strange. This started happening a few days ago. Until then Firefox worked perfectly on 99.9% of the sites I visit. I'm in Chrome now because it's still my default browser.

Yes, that is strange. This started happening a few days ago. Until then Firefox worked perfectly on 99.9% of the sites I visit. I'm in Chrome now because it's still my default browser.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17763 solutions 160641 answers

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check in the Web Console what content is blocked.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. *click the shield icon for more details and possibly disable the protection You can check in the Web Console what content is blocked. *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop
Was this helpful to you?
Quote

Question owner

From my original post:

I have tried disabling add-ons, safe mode, clearing the cache etc etc to no avail.

From my original post: I have tried disabling add-ons, safe mode, clearing the cache etc etc to no avail.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8876 solutions 72625 answers

Helpful Reply

mccfrank said

In addition there is text/images smeared across the top of the website..see the attached image.

This usually indicates that a font used to render icons is not loading. This can occur when web font downloads are blocked, or when Firefox is set to disregard page style rules and use a standard set of fonts. Here are a couple things to check, the details follow:

(1) Font setting -- are pages allowed to specify fonts to use? (2) Is a setting or add-on blocking downloadable fonts?

For #1, go to the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the "Fonts & Colors" section and click the "Advanced" button.

Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above":

Any difference (you would need to reload the problem page, Ctrl+r or the circling arrow button, to see any difference)?

For #2, some add-ons have a feature to globally block downloadable fonts unless you specially allow them. Do you run uBlock Origin or NoScript, for example? In uBlock Origin, the setting is called "Block remote fonts". Since you already tested in Firefox's Safe Mode, that shouldn't be the explanation.

There's also a general setting to block downloadable fonts in about:config, if you think you might ever have changed that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste gfx.down and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference is bolded and "modified" to false, double-click it to restore the default value of true

Was it any of those things?

By the way, the automatically add button below this page doesn't work. Takes you to an unknown page!!

Sorry about that, you are supposed to get the newer Share Data button, but for reasons that the developers are trying to track down, some users see that older (disconnected) button.

''mccfrank [[#question-1279637|said]]'' <blockquote> In addition there is text/images smeared across the top of the website..see the attached image.</blockquote> This usually indicates that a font used to render icons is not loading. This can occur when web font downloads are blocked, or when Firefox is set to disregard page style rules and use a standard set of fonts. Here are a couple things to check, the details follow: (1) Font setting -- are pages allowed to specify fonts to use? (2) Is a setting or add-on blocking downloadable fonts? For #1, go to the Options page: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it Scroll down to the "Fonts & Colors" section and click the "Advanced" button. Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above": <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2020-02-12-11-27-10-40ffbb.png" width="500"> Any difference (you would need to reload the problem page, Ctrl+r or the circling arrow button, to see any difference)? For #2, some add-ons have a feature to globally block downloadable fonts unless you specially allow them. Do you run uBlock Origin or NoScript, for example? In uBlock Origin, the setting is called "Block remote fonts". Since you already tested in Firefox's Safe Mode, that shouldn't be the explanation. There's also a general setting to block downloadable fonts in about:config, if you think you might ever have changed that: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''gfx.down''' and pause while the list is filtered (3) If the '''gfx.downloadable_fonts.enabled''' preference is bolded and "modified" to false, double-click it to restore the default value of true Was it any of those things? <blockquote>By the way, the automatically add button below this page doesn't work. Takes you to an unknown page!! </blockquote> Sorry about that, you are supposed to get the newer Share Data button, but for reasons that the developers are trying to track down, some users see that older (disconnected) button.
Was this helpful to you? 1
Quote

Chosen Solution

Well, I did all that...and there was no change. What did work? Well I created a new profile and now the site loads properly. I don't know what the problem was, or why is affected only that site but at least it's fixed. Thanks to everyone for suggestions. Luckily I could re-log into my Firefox sync account and because everything had been saved there, the new profile looks like the old one :) Luckily it doesn't act like the old one.

Well, I did all that...and there was no change. What did work? Well I created a new profile and now the site loads properly. I don't know what the problem was, or why is affected only that site but at least it's fixed. Thanks to everyone for suggestions. Luckily I could re-log into my Firefox sync account and because everything had been saved there, the new profile looks like the old one :) Luckily it doesn't act like the old one.
Was this helpful to you?
Quote
اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.