ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Refreshed EN-US and the rebuit copy is EN-CA and EN-GB

  • 13 ردًا
  • 1 has this problem
  • 15 views
  • آخر ردّ كتبه ineuw

more options

Always use the EN-US version in both Windows and Linux. Refreshed the profile in Linux and ended up the EN-CA with EN-GB. WHat d I need to do to restore the US version?

الحل المُختار

Well, the entire folder hierarchy belongs as one unit, in its top-level directory folder firefox. You can permanently or temporarily rename the folder (e.g., firefox_moz) to keep it separate from a concurrent distribution from Mint. If you plan on not using the Mint distribution of Firefox, you can uninstall it before placing new Firefox in the default folder with $ sudo apt-get remove firefox. This does not affect profiles.

In whichever order suits you: Open the archive and extract the firefox folder. Open your file manager as root so you can move or copy/paste the firefox folder to /usr/lib/. Optionally rename if you like. Copy the path to the executable for /usr/lib/firefox/firefox.

- You can start this copy of Firefox, let it make profiles if it is going to, then use about:profiles to select your original profile and set it as default, if you want. You can delete any others you do not want.

Launcher:

Warning: Wordy, but trying to cover anything i can think of.

Create a launcher wherever you like, then you can add it wherever else you care to if you want more than one (desktop, launcher on panel, in applications menu, in a dock, etc.).

Not sure which DE you are using with Mint, and i have not used Cinnamon or MATE but i used Gnome way back and all of these follow the same sort of convention. E.g., you should be able to right-click the desktop and Create Launcher, or right click a panel and Add Item.

For the launcher itself, give it a Name you like. If you are only planning to keep one installation of firefox, then firefox will do. If you add text to the Comment section, this will be included in any mouse-over text. Add the full path to the executable for your Command. /usr/lib/firefox/firefox %u (The exec argument %u is for passing a url to the program, e.g., clicking a link in a document which is open in a different program.) Icon: I don't know how you will be offered icons, but generally you get a list of standard icon types. If you like the usual icon theme you have, it would be in the Application Icons (or similar name) list. If you like the native FF icons, select Image Files (or a similarly named entry) and go to /usr/lib/firefox/browser/chrome/icons/default/default48.png (Up to you and your screen, etc., but 48 will likely work out well in most uses.) Click Create and you are all set.

Read this answer in context 👍 1

All Replies (13)

more options

You appear to be using the Firefox version from the Ubuntu repositories, so you would have to check there for support.

In case you want to use Firefox from the Mozilla server:

more options

Firefox came with Linux Mint and this installation was always en-US because Linux was also installed as en-US. This change only happened when I reset Firefox.

Before starting this thread, I already downloaded the en-US but to my ongoing chagrin, it's a tarball and for the past 11 years of using Linux, I never managed to make an installation from a tarball. There's always a script error somewhere and got tired of it. Perhaps Firefox will someday be merciful and release a .deb format.

The extracted files of FF can run from anywhere but then I end up with two Firefoxes. One in the path and one is not. I've been there and done that.

more options

You only need to extract the files in the tar.bz2 archive to a folder to install Firefox. A lot of file managers on Linux support opening such archives, so you only need to select all folders and files to copy and paste them in another folder. If you install Firefox in a folder in your home directory then there shouldn't be permission issues.

more options

Unfortunately, the unpacked firefox-72.0.2.tar.bz2 no longer works from the home or /opt folder. :-(

more options

I have run it straight from the desktop. Are you double-clicking the firefox executable in the folder? Is it even asking for permissions? You might right-click the executable and make sure that the tick-box is set to Allow this file to run as a program.

If you are making a launcher, ensure you have the correct path for the command, and again the executable permission checked.

(And yes, Mint and probably upstream have set English as CA and GB instead of US. It may even be the mirror you used, i have no idea. Oddly, if you use a non-US spelling (e.g., colour), it will mark it as misspelt, and decimal points and date formats seem correct.)

Also, Firefox doesn't package for the 67 different package managers, they merely release a standard Linux compressed install, as the distros generally tweak and poke and insert their own junk into their own package types for their repositories and send the update notifications to you. (Unless you are running Slackware, as they don't like modifying upstream application sources.)

more options

I used Firefox both in Windows and Linux ever since Netscape died.

I strongly recommend you read my opening post.

There is no Slackware. This is a straight forward installation in Linux Mint and both the OS and FF are en-US. Please look at the attached image. I get the same error message when I downloaded another copy directly from /pub repository. . . . and I can go on and on.

Purged the installed version and replaced the software sources to US mirrors. But even when the 'bionic' mirror was a Canadian mirror, the software was always en-US. Refreshing the profile is what caused the change.

Now, after purging, installed it again with apt install and now it is the right language but still 72.0.1.

Modified by ineuw

more options

There is no Slackware. My point was that distros roll their own Firefox, with changes, unless one is running Slackware Linux, as they philosophically do not like to alter application code for the distro.

I understand that you have EN_US but got GB & CA. This is something Mint did, unless it was upstream at Ubuntu. For any Firefox from the Software Manager or update via the Update Manager, this is entirely on the package maintainers at Mint. Usually it is just added dictionaries, but for some reason not the US ... but that is sort of a default anyway. You can always check in about:config for intl.accept_languages.

You can get language packs and dictionaries here if ever necessary: https://addons.mozilla.org/en-US/firefox/language-tools/

You hadn't mentioned a crash, you said "no longer works". https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help?redirectlocale=en-US&redirectslug=Firefox+crashes#w_get-help-fixing-this-crash

Now, after purging, installed it again with apt install and now it is the right language but still 72.0.1.

That's because Mint lags way behind the current version of nearly any software. Things like browsers they generally catch up in a couple weeks to a month. Maybe. You can check your repos in synaptic, but FF in Mint is Mint branded.

more options

Thanks for the reply. I will keep using 72.0.1 until it's updated. It was the missing en-US that got me because it is essential to my work. In Linux, the language list in spellcheck lists all languages, as opposed to Windows version which only shows the installed dictionaries. This is another irritation, the unnecessary differences between OS. To me, it means that the right hand does not want to know what the left hand is doing.

But now this is resolved.

About "not working anymore." please refer to the attached image. This was the extracted tarball. Firefox could not even start. Whatever crash report this failure generated, I forward it to Mozilla.

The newly installed 72.0.1 also had issues. It created 5 additional profiles and there were crash reports which I forwarded to mozilla as well.

Please don't waste more of your time with it, and thanks for the help.

more options

The extra profiles are likely from 1) starting the tarball copy then 2) installing from repo again. FF will create profiles every time you switch an install/update "channel".

It just happened to me when in an already installed tarball (dev channel) after i opened a regular channel tarball. Go figure. :D

more options

If I want to properly install the standard FF 72.0.2 tarball which is offered by Mozilla, and replace 72.0.1, how would I go about it? Although I am still looking for a tarball to .deb converter app. Is alien still a valid program?

more options

In addition there is an error with the tarball packaging. It should create a Firefox folder and extract the files into this folder - but it doesn't. Now,, it dumps everything in the applications storage folder where the tarball is stored, and must clean up the mess.

Modified by ineuw

more options

الحل المُختار

Well, the entire folder hierarchy belongs as one unit, in its top-level directory folder firefox. You can permanently or temporarily rename the folder (e.g., firefox_moz) to keep it separate from a concurrent distribution from Mint. If you plan on not using the Mint distribution of Firefox, you can uninstall it before placing new Firefox in the default folder with $ sudo apt-get remove firefox. This does not affect profiles.

In whichever order suits you: Open the archive and extract the firefox folder. Open your file manager as root so you can move or copy/paste the firefox folder to /usr/lib/. Optionally rename if you like. Copy the path to the executable for /usr/lib/firefox/firefox.

- You can start this copy of Firefox, let it make profiles if it is going to, then use about:profiles to select your original profile and set it as default, if you want. You can delete any others you do not want.

Launcher:

Warning: Wordy, but trying to cover anything i can think of.

Create a launcher wherever you like, then you can add it wherever else you care to if you want more than one (desktop, launcher on panel, in applications menu, in a dock, etc.).

Not sure which DE you are using with Mint, and i have not used Cinnamon or MATE but i used Gnome way back and all of these follow the same sort of convention. E.g., you should be able to right-click the desktop and Create Launcher, or right click a panel and Add Item.

For the launcher itself, give it a Name you like. If you are only planning to keep one installation of firefox, then firefox will do. If you add text to the Comment section, this will be included in any mouse-over text. Add the full path to the executable for your Command. /usr/lib/firefox/firefox %u (The exec argument %u is for passing a url to the program, e.g., clicking a link in a document which is open in a different program.) Icon: I don't know how you will be offered icons, but generally you get a list of standard icon types. If you like the usual icon theme you have, it would be in the Application Icons (or similar name) list. If you like the native FF icons, select Image Files (or a similarly named entry) and go to /usr/lib/firefox/browser/chrome/icons/default/default48.png (Up to you and your screen, etc., but 48 will likely work out well in most uses.) Click Create and you are all set.

more options

Thanks to all for the valuable info. Everything is resolved. I now have two working installations of FF 72.0.2 in Linux Mint.

Both the 1st and 2nd downloads the 72.0.2 tarball for local installation were corrupted somehow or there was a conflict between the 72.0.2 local and the 72.0.1 system wide installation.

Uninstalled the system wide 72.0.1 and when tried 72.0.2 locally for the 3rd time, it worked like a charm. Then, about 10 minutes later, the Linux update manager also popped up, offering the same verson for system wide installation.