X
Tap here to go to the mobile version of the site.

منتدى الدعم

Adobe PDF downloads opening multiple tabs

Posted

When attempting to download a PDF, Firefox won't stop opening multiple tabs.... not a problem with Microsoft Edge. Thanks for your help!

When attempting to download a PDF, Firefox won't stop opening multiple tabs.... not a problem with Microsoft Edge. Thanks for your help!

Chosen solution

In Firefox. The 3-bar Menu button at the right end of the toolbar.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0

More Information

RobertJ
  • Top 10 Contributor
141 solutions 1453 answers

ردّ مُفيد

Hi edhoch12, Does the file name have spaces?

This was a bug which was fixed in the 72.0.2 update: https://www.mozilla.org/en-US/firefox/72.0.2/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=whatsnew

Hi edhoch12, Does the file name have spaces? This was a bug which was fixed in the 72.0.2 update: https://www.mozilla.org/en-US/firefox/72.0.2/releasenotes/?utm_source=firefox-browser&utm_medium=firefox-browser&utm_campaign=whatsnew
هل وجدت هذا مفيدًا؟ 1
Quote

صاحب السؤال

It appears so...

It appears so...
هل وجدت هذا مفيدًا؟
Quote

صاحب السؤال

and... I do have the latest version of Firefox

and... I do have the latest version of Firefox
هل وجدت هذا مفيدًا؟
Quote
RobertJ
  • Top 10 Contributor
141 solutions 1453 answers

ردّ مُفيد

Try this: Menu -> Options -> General page scroll down to Applications adjacent to Portable Document Format (PDF) change Preview In Firefox to another method - (Always Ask, Save File, Use Adobe)

Download the PDF file again. It should be handled appropriate to the change.

Go back to Applications and change it back to Preview In Firefox.

Download the PDF file again. It should be handled appropriate to the change. _______________________________________________________________________

If it isn't handled appropriately, you can Reset your Applications handler:

Type (or paste) about:support in the address bar and press Enter under Application Basics next to Profile Folder click the Open Folder button Close Firefox.

In your Profile Folder rename handlers.json to something like handlersOLD.json If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf

Close the folder window and launch Firefox. Your Applications handler will be reset to the default. You can set how to handle PDF's and set how to handle other file types as you encounter them.

Try this: Menu -> Options -> General page scroll down to Applications adjacent to Portable Document Format (PDF) change Preview In Firefox to another method - (Always Ask, Save File, Use Adobe) Download the PDF file again. It should be handled appropriate to the change. Go back to Applications and change it back to Preview In Firefox. Download the PDF file again. It should be handled appropriate to the change. _______________________________________________________________________ If it isn't handled appropriately, you can Reset your Applications handler: Type (or paste) about:support in the address bar and press Enter under Application Basics next to Profile Folder click the Open Folder button Close Firefox. In your Profile Folder rename handlers.json to something like handlersOLD.json If you see a file named mimeTypes.rdf, rename that one to mimeTypesOLD.rdf Close the folder window and launch Firefox. Your Applications handler will be reset to the default. You can set how to handle PDF's and set how to handle other file types as you encounter them.
هل وجدت هذا مفيدًا؟ 1
Quote

صاحب السؤال

Wow... pretty complicated, but I'll try it. I'm not a novice at this, but where is "Menu -> Options -> General page"  ? Is it the Start Menu? Thanks for your time...

Wow... pretty complicated, but I'll try it. I'm not a novice at this, but where is "Menu -> Options -> General page" ? Is it the Start Menu? Thanks for your time...
هل وجدت هذا مفيدًا؟
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17777 solutions 160817 answers

See also:

You get tabs opening endlessly if you select Firefox as the application to handle a file when you get an "Open with" dialog.

See also: *https://support.mozilla.org/en-US/kb/Firefox+keeps+opening+many+tabs+or+windows You get tabs opening endlessly if you select Firefox as the application to handle a file when you get an "Open with" dialog.

Modified by cor-el

هل وجدت هذا مفيدًا؟ 1
Quote
RobertJ
  • Top 10 Contributor
141 solutions 1453 answers

Chosen Solution

In Firefox. The 3-bar Menu button at the right end of the toolbar.

In Firefox. The 3-bar Menu button at the right end of the toolbar.
هل وجدت هذا مفيدًا؟ 1
Quote

صاحب السؤال

cor-el: I think that's what happened... but how can I get back to that selection window? I'm attempting to download automatically now since I probably selected "do this every time for this type of file."

Thanks

cor-el: I think that's what happened... but how can I get back to that selection window? I'm attempting to download automatically now since I probably selected "do this every time for this type of file." Thanks
هل وجدت هذا مفيدًا؟
Quote
RobertJ
  • Top 10 Contributor
141 solutions 1453 answers

I wouldn't use "do this every time for this type of file" until the Applications handler is working according to the settings there.

I wouldn't use "do this every time for this type of file" until the Applications handler is working according to the settings there.

Modified by RobertJ

هل وجدت هذا مفيدًا؟ 1
Quote

صاحب السؤال

I'll give it a shot and let you know later! Thanks for your help.

I'll give it a shot and let you know later! Thanks for your help.
هل وجدت هذا مفيدًا؟
Quote
اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.