X
Tap here to go to the mobile version of the site.

منتدى الدعم

I just installed windows 10 and now firefox doesn't work right = very slow, it was fine before

Posted

I just upgraded my computer to a 1 tb hard drive and installed windows 10. Now firefox doesn't work right, example: I go on Facebook or another site and when I try to type a post I have to type 2 or 3 letters, then wait several seconds for them to appear. I have re-position my cursor and type 2 or 4 more letters and wait again. Can this be fixed?

I just upgraded my computer to a 1 tb hard drive and installed windows 10. Now firefox doesn't work right, example: I go on Facebook or another site and when I try to type a post I have to type 2 or 3 letters, then wait several seconds for them to appear. I have re-position my cursor and type 2 or 4 more letters and wait again. Can this be fixed?
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/70.0.3538.102 Safari/537.36 Edge/18.18363

More Information

FredMcD
  • Top 10 Contributor
4396 solutions 61665 answers
Is this with all websites/pages, some, a few? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-ram https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding https://support.mozilla.org/en-US/kb/firefox-takes-long-time-start-up
هل وجدت هذا مفيدًا؟ 0
Quote

صاحب السؤال

I tried that earlier, it didn't help any. All websites are the same. Also when scrolling up or down, I can scroll a short distance, then have to wait for a few seconds before I scroll further. I did a speed test and found that my internet speed is just what it's supposed to be. BTW: I'm using Edge to post on this help forum.

I tried that earlier, it didn't help any. All websites are the same. Also when scrolling up or down, I can scroll a short distance, then have to wait for a few seconds before I scroll further. I did a speed test and found that my internet speed is just what it's supposed to be. BTW: I'm using Edge to post on this help forum.
هل وجدت هذا مفيدًا؟
Quote
FredMcD
  • Top 10 Contributor
4396 solutions 61665 answers

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Secure''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia
هل وجدت هذا مفيدًا؟
Quote

صاحب السؤال

Did that and it appeared to solve the problem, but then I restarted the computer, not in safe mode, and the problem was about 50% better, but not completely resolved.

Did that and it appeared to solve the problem, but then I restarted the computer, not in safe mode, and the problem was about 50% better, but not completely resolved.
هل وجدت هذا مفيدًا؟
Quote
crankygoat
  • Top 10 Contributor
40 solutions 471 answers

Go to ☰Menu → Preferences → scroll down to Performance → Un-tick the box for Use recommended performance settings → disable Hardware Acceleration

See if this helps.

If not: If Firefox was already on the machine when you upgraded, an uninstall of Firefox and reinstall might help. You can keep your user settings, or back them up and delete them. https://support.mozilla.org/en-US/kb/uninstall-firefox-from-your-computer

Go to ☰Menu → Preferences → scroll down to Performance → Un-tick the box for Use recommended performance settings → disable Hardware Acceleration See if this helps. If not: If Firefox was already on the machine when you upgraded, an uninstall of Firefox and reinstall might help. You can keep your user settings, or back them up and delete them. https://support.mozilla.org/en-US/kb/uninstall-firefox-from-your-computer
هل وجدت هذا مفيدًا؟
Quote

صاحب السؤال

Thanks for the response, but I've tried all of those to no avail. I'm still fighting with it.

Thanks for the response, but I've tried all of those to no avail. I'm still fighting with it.
هل وجدت هذا مفيدًا؟
Quote
FredMcD
  • Top 10 Contributor
4396 solutions 61665 answers

FredMcD said

Start your Computer in safe mode with network support.

paul160 said

Did that and it appeared to solve the problem, but then I restarted the computer, not in safe mode, and the problem was about 50% better, but not completely resolved.

That means something else on the computer is causing issues. As a test, disable your protection programs.

''FredMcD [[#answer-1282403|said]]'' <blockquote> Start your '''Computer''' in safe mode with network support. </blockquote> ''paul160 [[#answer-1282448|said]]'' <blockquote> Did that and it appeared to solve the problem, but then I restarted the computer, not in safe mode, and the problem was about 50% better, but not completely resolved. </blockquote> That means something else on the computer is causing issues. As a test, disable your protection programs.
هل وجدت هذا مفيدًا؟
Quote
Ken Fowler 0 solutions 5 answers

I have been experiencing extremely slow page loads by Firefox for two weeks. I tried various versions of the suggestions above with no success. Yesterday I uninstalled FF and reinstalled the latest version. Speed was back to normal, very responsive. Today it has slowed down again. Pages from sites that have been frequently visited take over three minutes to appear. I think there is something wrong.

I have been experiencing extremely slow page loads by Firefox for two weeks. I tried various versions of the suggestions above with no success. Yesterday I uninstalled FF and reinstalled the latest version. Speed was back to normal, very responsive. Today it has slowed down again. Pages from sites that have been frequently visited take over three minutes to appear. I think there is something wrong.

Modified by Ken Fowler

هل وجدت هذا مفيدًا؟
Quote
FredMcD
  • Top 10 Contributor
4396 solutions 61665 answers

I called for more help.


Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Now in the Reply Box on the forum page, do a right-click in the box and select Paste.

If the data is too big, do not worry. It's the top part we need to look at.

This will show us your system details. No Personal Information Is Collected.

I called for more help. Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Now in the Reply Box on the forum page, do a right-click in the box and select '''Paste.''' If the data is too big, do not worry. It's the top part we need to look at. This will show us your system details. '''No Personal Information Is Collected.'''
هل وجدت هذا مفيدًا؟
Quote
Ken Fowler 0 solutions 5 answers

Application Basics


Name: Firefox Version: 72.0.2 Build ID: 20200117190643 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0 OS: Windows_NT 10.0 Launcher Process: Enabled Multiprocess Windows: 1/1 Enabled by default Remote Processes: 5 Enterprise Policies: Inactive Google Location Service Key: Found Google Safebrowsing Key: Found Mozilla Location Service Key: Found Safe Mode: false

Crash Reports for the Last 3 Days


Firefox Features


Name: DoH Roll-Out Version: 1.3.0 ID: doh-rollout@mozilla.org

Name: Firefox Screenshots Version: 39.0.0 ID: screenshots@mozilla.org

Name: Form Autofill Version: 1.0 ID: formautofill@mozilla.org

Name: Web Compat Version: 6.4.0 ID: webcompat@mozilla.org

Name: WebCompat Reporter Version: 1.1.0 ID: webcompat-reporter@mozilla.org

Remote Processes


Type: Web Content Count: 3 / 8

Type: Extension Count: 1

Type: GPU Count: 1

Extensions


Name: Amazon.com Version: 1.1 Enabled: true ID: amazondotcom@search.mozilla.org

Name: Bing Version: 1.0 Enabled: true ID: bing@search.mozilla.org

Name: Dashlane Version: 6.2004.1 Enabled: true ID: jetpack-extension@dashlane.com

Name: DuckDuckGo Version: 1.0 Enabled: true ID: ddg@search.mozilla.org

Name: eBay Version: 1.0 Enabled: true ID: ebay@search.mozilla.org

Name: Firefox Pioneer Version: 1.0 Enabled: true ID: pioneer-opt-in@mozilla.org

Name: Google Version: 1.0 Enabled: true ID: google@search.mozilla.org

Name: IP Address and Domain Information Version: 4.0.1.1 Enabled: true ID: jid0-jJRRRBMgoShUhb07IvnxTBAl29w@jetpack

Name: Twitter Version: 1.0 Enabled: true ID: twitter@search.mozilla.org

Name: uBlock Origin Version: 1.24.4 Enabled: true ID: uBlock0@raymondhill.net

Name: Wikipedia (en) Version: 1.0 Enabled: true ID: wikipedia@search.mozilla.org

Security Software


Type: Malwarebytes

Type:

Type: Windows Firewall

Graphics


.... <snip>.... mpressed_ETC2_RGB8_texture

Application Basics ------------------ Name: Firefox Version: 72.0.2 Build ID: 20200117190643 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:72.0) Gecko/20100101 Firefox/72.0 OS: Windows_NT 10.0 Launcher Process: Enabled Multiprocess Windows: 1/1 Enabled by default Remote Processes: 5 Enterprise Policies: Inactive Google Location Service Key: Found Google Safebrowsing Key: Found Mozilla Location Service Key: Found Safe Mode: false Crash Reports for the Last 3 Days --------------------------------- Firefox Features ---------------- Name: DoH Roll-Out Version: 1.3.0 ID: doh-rollout@mozilla.org Name: Firefox Screenshots Version: 39.0.0 ID: screenshots@mozilla.org Name: Form Autofill Version: 1.0 ID: formautofill@mozilla.org Name: Web Compat Version: 6.4.0 ID: webcompat@mozilla.org Name: WebCompat Reporter Version: 1.1.0 ID: webcompat-reporter@mozilla.org Remote Processes ---------------- Type: Web Content Count: 3 / 8 Type: Extension Count: 1 Type: GPU Count: 1 Extensions ---------- Name: Amazon.com Version: 1.1 Enabled: true ID: amazondotcom@search.mozilla.org Name: Bing Version: 1.0 Enabled: true ID: bing@search.mozilla.org Name: Dashlane Version: 6.2004.1 Enabled: true ID: jetpack-extension@dashlane.com Name: DuckDuckGo Version: 1.0 Enabled: true ID: ddg@search.mozilla.org Name: eBay Version: 1.0 Enabled: true ID: ebay@search.mozilla.org Name: Firefox Pioneer Version: 1.0 Enabled: true ID: pioneer-opt-in@mozilla.org Name: Google Version: 1.0 Enabled: true ID: google@search.mozilla.org Name: IP Address and Domain Information Version: 4.0.1.1 Enabled: true ID: jid0-jJRRRBMgoShUhb07IvnxTBAl29w@jetpack Name: Twitter Version: 1.0 Enabled: true ID: twitter@search.mozilla.org Name: uBlock Origin Version: 1.24.4 Enabled: true ID: uBlock0@raymondhill.net Name: Wikipedia (en) Version: 1.0 Enabled: true ID: wikipedia@search.mozilla.org Security Software ----------------- Type: Malwarebytes Type: Type: Windows Firewall Graphics -------- .... <snip>.... mpressed_ETC2_RGB8_texture
هل وجدت هذا مفيدًا؟
Quote
Ken Fowler 0 solutions 5 answers

After posting the problem, I restarted my computer and Firefox is now back to normal.

After posting the problem, I restarted my computer and Firefox is now back to normal.
هل وجدت هذا مفيدًا؟
Quote
FredMcD
  • Top 10 Contributor
4396 solutions 61665 answers

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

That was very good work. Well Done. Please flag your last post as '''Solved Problem''' as this can help others with similar problems.
هل وجدت هذا مفيدًا؟
Quote
Ken Fowler 0 solutions 5 answers

I was not the original poster and my problem wasn't connected to Windows 10 installation. I don't see the method to flag it as Solved Problem but FireFox is still working at normal speed today. Thanks.

I was not the original poster and my problem wasn't connected to Windows 10 installation. I don't see the method to flag it as Solved Problem but FireFox is still working at normal speed today. Thanks.
هل وجدت هذا مفيدًا؟
Quote

صاحب السؤال

I don' t know what the problem is, but I've done everything that has been suggested, but Firefox is still very, very slow since I installed Win 10! I hate Win 10 and love Firefox but have had to switch to Edge to be able to have a browser that works. Hate Edge also! It seems like Microsoft has sabotaged Ff!

I don' t know what the problem is, but I've done everything that has been suggested, but Firefox is still very, very slow since I installed Win 10! I hate Win 10 and love Firefox but have had to switch to Edge to be able to have a browser that works. Hate Edge also! It seems like Microsoft has sabotaged Ff!
هل وجدت هذا مفيدًا؟
Quote
FredMcD
  • Top 10 Contributor
4396 solutions 61665 answers

For all others; not paul160

Please go to the top of any support.mozilla.org web page and use the Get Community Support link: https://support.mozilla.org/en-US/questions/new

Select the product for what the problem is (Firefox or whatever). Now select the category for the problem. At the bottom is Other.

Describe the problem in brief (one line). Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; None Of These Solve My Problem.

Now enter all the relative information on the problem. At the bottom of this, you can Add Images.

Under this is Troubleshooting Information. Please press the Share Data button. This will let us look at your system details. No Personal Information Is Collected.

For all others; not '''paul160''' Please go to the top of any '''support.mozilla.org''' web page and use the '''Get Community Support''' link: https://support.mozilla.org/en-US/questions/new Select the product for what the problem is (Firefox or whatever). Now select the category for the problem. At the bottom is Other. Describe the problem in brief (one line). Then press <enter>. The website will display any prior posts that might help you. If nothing on the list can help, at the bottom press the button; '''None Of These Solve My Problem.''' Now enter all the relative information on the problem. At the bottom of this, you can Add Images. Under this is '''Troubleshooting Information.''' Please press the '''Share Data button.''' This will let us look at your system details. '''No Personal Information Is Collected.'''
هل وجدت هذا مفيدًا؟
Quote
FredMcD
  • Top 10 Contributor
4396 solutions 61665 answers

paul160 said

. . . I hate Win 10 . . .

Me too.

FredMcD said

Start your Computer in safe mode with network support.

paul160 said

Did that and it appeared to solve the problem, but then I restarted the computer, not in safe mode, and the problem was about 50% better, but not completely resolved.

FredMcD said

That means something else on the computer is causing issues. As a test, disable your protection programs.
''paul160 [[#answer-1288338|said]]'' <blockquote> . . . I hate Win 10 . . . </blockquote> Me too. ''FredMcD [[#answer-1282403|said]]'' <blockquote> Start your '''Computer''' in safe mode with network support. </blockquote> ''paul160 [[#answer-1282448|said]]'' <blockquote> Did that and it appeared to solve the problem, but then I restarted the computer, not in safe mode, and the problem was about 50% better, but not completely resolved. </blockquote> ''FredMcD [[#answer-1282732|said]]'' <blockquote>That means something else on the computer is causing issues. As a test, disable your protection programs. </blockquote>
هل وجدت هذا مفيدًا؟
Quote
Abdul0012 0 solutions 1 answers

Actually i have also the same Issue Before previous windows its working fine and now in window 10 its slow process whats the reason whenever i load my website https://10hunts.com it processes it very slowly but when i try that in chrome its okay and normal Please Any clue?

Actually i have also the same Issue Before previous windows its working fine and now in window 10 its slow process whats the reason whenever i load my website [http://example.com https://10hunts.com] it processes it very slowly but when i try that in chrome its okay and normal Please Any clue?
هل وجدت هذا مفيدًا؟
Quote
FredMcD
  • Top 10 Contributor
4396 solutions 61665 answers

I had no problem with https://10hunts.com

Is this with all websites/pages, some, a few?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

I had no problem with https://10hunts.com Is this with all websites/pages, some, a few? Many site issues can be caused by corrupt cookies or cache. '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
هل وجدت هذا مفيدًا؟
Quote
Ken Fowler 0 solutions 5 answers

I had all the same slow page loading problems as described above for several weeks. None of the suggestions helped. FireFox has been back to normal for two weeks but I did notice problems when Windows 10 was waiting to install updates and also after MalwareBytes had completed a scan. In those cases, re-starting Windows seemed to return FireFox to normal.

Refresh did not help!

Re-installing FireFox did not fix the problem.

I did not try disabling graphics hardware acceleration.

My problems started long after installing Windows 10 and after many updates to FireFox and Windows 10.

-ken-

I had all the same slow page loading problems as described above for several weeks. None of the suggestions helped. FireFox has been back to normal for two weeks but I did notice problems when Windows 10 was waiting to install updates and also after MalwareBytes had completed a scan. In those cases, re-starting Windows seemed to return FireFox to normal. Refresh did not help! Re-installing FireFox did not fix the problem. I did not try disabling graphics hardware acceleration. My problems started long after installing Windows 10 and after many updates to FireFox and Windows 10. -ken-
هل وجدت هذا مفيدًا؟
Quote
FredMcD
  • Top 10 Contributor
4396 solutions 61665 answers

There was a problem with a Windows update not long ago. It was withdrawn by Microsoft. Run the Windows updater.

There was a problem with a Windows update not long ago. It was withdrawn by Microsoft. Run the Windows updater.
هل وجدت هذا مفيدًا؟
Quote
اطرح سؤالا

عليك الولوج إلى حسابك للردّ على المشاركات. من فضلك اطرح سؤالًا جديدًا لو لم يكن لديك حساب بعد.