Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not play sound on youtube videos

  • 18 replies
  • 12 have this problem
  • 614 views
  • آخر ردّ كتبه rhiannon05

more options

Since yesterday, Firefox will not play sound on youtube videos and some other embedded videos (eg Newsflare). IE and Chrome will play the sound. Have checked the sound system and everything seems OK as music still plays and websites with sound still work. Someone suggested it could be a flash player problem, but have checked Adobe flash and it is the latest version. I really don't know what the problem is. As an aside, my Train Simulator (which is run through Steam) also has no sound and it did 2 days ago!, but my Flight Simulator (also on Steam) has sound! Just can't get my head round it!! Help!!

All Replies (18)

more options

I would suggest to reinstall sound drivers or update previous one to latest. Try to check again after a quick system restart

more options

Apparently I have the latest drivers (though dating from 2016). Should have said, I'm using W10 and the audio is Realtek High Definition Audio. I found what is apparently a newer version and downloaded the new drivers, but I've got no idea where to put them! Can't find a Realtek folder or something.

more options

Hello. Same problem here too. video with no sound

My soundcard is U-Phoria UMC1820. I am using LInux Mint 19.3 all drivers are latest possible. Is that problem an error, or special feature from MPAA?

When I download that video, Then this have sound. VLC plays it with sound.

Thanks

more options

This is how I solved the problem.

1. Make sure you have unmuted the sound with the button on your keyboard.

2. On your taskbar, right click the loudspeaker icon, then left click 'open volume mixer'.

3. You should have a volume slider for your main device (speakers) and one for each of the apps that are running (eg Firefox). This is where I found the volume to be muted at the bottom of the Firefox column. Simply unmute it and away you go!

4. This only works for apps that are running! The sound on my Train Simulator had gone too, so I had to start the app. It then appears in the 'volume mixer' and that was muted too. So if you have any apps whose sound has gone, run them and check the mute in the volume mixer.

Hope this works for you.

more options

sddsddean,

That isn't solution. I've tried everything, just some youtube videos have no sound.

more options

Sorry, can't help then. Thats the solution that worked for me.

more options

It is more complicated than it initially seems. The above linked video , has mulitiple tracks:

 3  video + audio tracks,

12 video-only tracks,

 4  audio-only  tracks.

Why firefox sometimes play video-only tracks and not play the audio tracks???

This video plays correctly.

more options

My drivers are up to date as well. I have never had this problem. I have reinstalled firefox and nothing seems to be working.

more options

I have this problem too. updated all sound software, mixer Ok Sound works fine if I paly through Chrome browser so clearly not my computer ongoing for maybe 2-3weeks. a bit intermittent at start- no sound on facebook video but youtube OK but now nothing I really don't want to be forced to another browser

more options

THE PROBLEM II FROM PC SOUND SETINGS

more options

Hmm... had the same issue, and the fix was veeery weird. For me, it was the %TEMP% folder that had its permissions removed. (Possible that it was unable to load codex from there?)

Check the security tab of the %TEMP% properties, and if the checkboxes are empty, you need to add them to all the relevant user profiles again.

Hoping this helps your case.

more options

I solved the problem by going to Settings -> Sounds -> App volume device preferences and changing the You Tube and Firefox output preferences from default to speakers. I have no idea why this was necessary as videos previously played with no problem! Was the update of Firefox to version 76.0.1 the culprit?

more options

Guys, I tried everything but, nothing seems to work. I even tried the TEMP thing and I thought this will solve it but it didn't. the sound is working in every other wesite or app but I don't know what is with Firefox?! any help or suggestions will help please I need a solution for this problem ASAP.

more options

I went over to Chrome when I needed sound....but then it just resolved after about 6weeks!!??

more options

you know what that could do it, because I tried almost every solution.

more options

I'm about to go back to Chrome as well. This thread goes back to December of 2019 and noone has yet come up with a reasonable solution! In my case the YouTube problem began about a week ago.

Firefox Quantum 68.8.0 ESR. iTunes audio is fine. Videos in Facebook and other sites play audio at a reasonable level. Waterfox plays YouTube audio at a reasonable level. The problem is only with Firefox! Bringing Firefox up in the safe mode doesn't help. Changing the app volume preferences from default to Realtec doesn't help.

Now here's a possible cause! Possibly about the same time, I received a message about a new Codec being available. I ignored it for awhile. Could it have installed itself? When I discovered the problem with YouTube, I decided to install the default Codec. That didn't help.

I am not familiar with Codec operation and the web is of little help to me here. Do I need Codecs and if so, can I go back to a previous one? Also if the Codec is the problem, why does it only affect the YouTube/Firefox combination?

Gerry

more options

Solved! Windows 10 - Go into settings: then go into Sound: scroll down to the bottom: Advanced sound options: click on it and you should find yourself in: App volume device preferences. Look for Firefox and where it says: output make sure it is on: default - and not whatever speakers you might have, for example mine are Realtek High Definition Audio.

Modified by RedBird

more options

RedBird said

Solved! Windows 10 - Go into settings: then go into Sound: scroll down to the bottom: Advanced sound options: click on it and you should find yourself in: App volume device preferences. Look for Firefox and where it says: output make sure it is on: default - and not whatever speakers you might have, for example mine are Realtek High Definition Audio.

thank you so much, it worked and it had been driving me crazy for days