X
Tap here to go to the mobile version of the site.

منتدى الدعم

Can't log in except in private mode

Posted

Using Firefox 70.0.1 on macOS 10.14.6. I'm running into two issues that seem related and which I haven't solved. Firstly, there are some websites that refuse to let me log in (notably Flickr) except in a private window. There are others, such as a Leica camera forum, that let me log in but only show images if I do so in a private window. What I've done so far: -turned off extensions for those sites (uBlock Origin and Malwarebytes Browser Guard) -turned off Firefox tracking protection -tried in safe mode -cleared cookies and cache -(in response to a recent thread about a similar issue) ensured dom.webnotications.enabled is set to 'true'

This issue seems to have arisen with the update to v.70. Any thoughts?

Using Firefox 70.0.1 on macOS 10.14.6. I'm running into two issues that seem related and which I haven't solved. Firstly, there are some websites that refuse to let me log in (notably Flickr) except in a private window. There are others, such as a Leica camera forum, that let me log in but only show images if I do so in a private window. What I've done so far: -turned off extensions for those sites (uBlock Origin and Malwarebytes Browser Guard) -turned off Firefox tracking protection -tried in safe mode -cleared cookies and cache -(in response to a recent thread about a similar issue) ensured dom.webnotications.enabled is set to 'true' This issue seems to have arisen with the update to v.70. Any thoughts?

Chosen solution

I'm sure you must be right. Installed extensions are: uBlock Origin Malwarebytes Browser Guard 1Password X Enhancer for YouTube Disable HTML5 Autoplay

Only the first two ought to interfere with page elements, but even if disabled for Flickr and the Leica forum, I have problems. Oddly, I can get logged in and see pages normally in a Private window with those extensions active, yet I cannot in safe mode when they ought to be disabled entirely. I made a third profile and this time kept uBlock Origin in non-advanced mode, and did not import all my settings from the other profile's installation. Currently I can log in to Flickr and see images on the Leica forum with all extensions active, and this has survived two quits and restarts. Fingers crossed it lasts! Maybe uBlock Origin is still affecting page content in some way even when disabled for a site.

Read this answer in context 0
Quote

Additional System Details

Application

  • Firefox 70.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:70.0) Gecko/20100101 Firefox/70.0
  • Support URL: https://support.mozilla.org/1/firefox/70.0.1/Darwin/en-US/

Extensions

  • 1Password extension (desktop app required) 4.7.5.90 (onepassword4@agilebits.com)
  • 1Password X – Password Manager 1.16.2 ({d634138d-c276-4fc8-924b-40a0ea21d284})
  • Amazon.co.uk 1.1 (amazon@search.mozilla.org)
  • Bing 1.0 (bing@search.mozilla.org)
  • Disable HTML5 Autoplay 2018.10.3 (disable-html5-autoplay@afnankhan)
  • DuckDuckGo 1.0 (ddg@search.mozilla.org)
  • eBay 1.0 (ebay@search.mozilla.org)
  • Enhancer for YouTube™ 2.0.98.2 (enhancerforyoutube@maximerf.addons.mozilla.org)
  • Google 1.0 (google@search.mozilla.org)
  • Google Analytics Opt-out Add-on (by Google) 1.0.8 ({6d96bb5e-1175-4ebf-8ab5-5f56f1c79f65})
  • hotfix-update-xpi-intermediate 1.0.6 (hotfix-update-xpi-intermediate@mozilla.com)
  • Malwarebytes Browser Guard 2.1.3 ({242af0bb-db11-4734-b7a0-61cb8a9b20fb})
  • Twitter 1.0 (twitter@search.mozilla.org)
  • uBlock Origin 1.24.2 (uBlock0@raymondhill.net)
  • Wikipedia (en) 1.0 (wikipedia@search.mozilla.org)
  • Decentraleyes 2.0.13 (jid1-BoFifL9Vbdl2zQ@jetpack) (Inactive)
  • Google Analytics Opt-out 0.1.2 ({2f182d41-fd03-4a6d-938d-081419586c37}) (Inactive)
  • Greasemonkey 4.9 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781}) (Inactive)
  • HTTPS Everywhere 2019.11.7 (https-everywhere@eff.org) (Inactive)
  • Privacy Badger 2019.11.18 (jid1-MnnxcxisBPnSXQ@jetpack) (Inactive)
  • SQLite Manager 0.2.7 ({7d2676a5-0546-4e2a-9019-aa9d8345be1e}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x87c0
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVendor:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blacklisted', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'CMSOutputProfile': u'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', u'TileHeight': 1024, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 1024, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 3
  • targetFrameRate: 60
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_disjoint_timer_query EXT_float_blend EXT_frag_depth EXT_shader_texture_lod EXT_sRGB EXT_texture_compression_rgtc EXT_texture_filter_anisotropic OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: Intel Inc. -- Intel(R) UHD Graphics 617
  • webgl1Version: 4.1 INTEL-12.10.14
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl2Extensions: EXT_color_buffer_float EXT_disjoint_timer_query EXT_float_blend EXT_texture_compression_rgtc EXT_texture_filter_anisotropic OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: Intel Inc. -- Intel(R) UHD Graphics 617
  • webgl2Version: 4.1 INTEL-12.10.14
  • webgl2WSIInfo: CGL
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Dinushi Dhananjani
  • Top 25 Contributor
4 solutions 187 answers

hi... I think your cookie is messed up somehow and try to clear cookie

hi... I think your cookie is messed up somehow and try to clear cookie
Was this helpful to you? 0
Quote

Question owner

I've cleared cookies but it makes no difference.

I've cleared cookies but it makes no difference.
Was this helpful to you?
Quote
evhenry
  • Top 25 Contributor
  • Administrator
15 solutions 89 answers

Private uses a separate cookie container (jar if you want) so it could be cookie issue that resetting your cookies isn't resolving because the cookies aren't being distributed properly?

Looking at another post, someone else was talking about image loading issues they were having with facebook that were resolved when using private mode and I wonder if the cookie issue is related, in this case, facebook was adding "www.facebook.com" cookies but not "facebook.com" cookies and manually adding "facebook.com" to the exception list allowed those cookies to be accepted which corrected the behavior:

I think I see the problem. When Firefox prompts you to approve cookies on Facebook, it displays www.facebook.com. However, apparently that is not enough to cover all of the cookies on the site and Firefox is not prompting for the more general domain facebook.com. If I go into the Exceptions dialog and manually create an entry for facebook.com (Allow for Session in my case), then the setting works. Not sure why Firefox isn't prompting for all cookies.??

So maybe try doing that with leica camera forum at least and see if that resolves it? We might be getting closer to a solution in that case.

Let me know what you find out.

Private uses a separate cookie container (jar if you want) so it could be cookie issue that resetting your cookies isn't resolving because the cookies aren't being distributed properly? Looking at another post, [https://support.mozilla.org/bm/questions/934784/ someone else was talking about image loading issues they were having with facebook that were resolved when using private mode] and I wonder if the cookie issue is related, in this case, facebook was adding "www.facebook.com" cookies but not "facebook.com" cookies and manually adding "facebook.com" to the exception list allowed those cookies to be accepted which corrected the behavior: <blockquote> I think I see the problem. When Firefox prompts you to approve cookies on Facebook, it displays www.facebook.com. However, apparently that is not enough to cover all of the cookies on the site and Firefox is not prompting for the more general domain facebook.com. If I go into the Exceptions dialog and manually create an entry for facebook.com (Allow for Session in my case), then the setting works. Not sure why Firefox isn't prompting for all cookies.?? </blockquote> So maybe try doing that with leica camera forum at least and see if that resolves it? We might be getting closer to a solution in that case. Let me know what you find out.
Was this helpful to you?
Quote

Question owner

I added https://www.l-camera-forum.com/ and l-camera-forum.com/ (which then shows in the list as https://l-camera-forum.com/) to the exceptions list as allowed to use cookies, but the forum still doesn't show any images, either linked from elsewhere or posted as attachments.

I added https://www.l-camera-forum.com/ and l-camera-forum.com/ (which then shows in the list as https://l-camera-forum.com/) to the exceptions list as allowed to use cookies, but the forum still doesn't show any images, either linked from elsewhere or posted as attachments.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted.

  • rename/remove cookies.sqlite (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

If clearing cookies didn't help then it is possible that the cookies.sqlite file in the Firefox profile folder that stores the cookies got corrupted. *rename/remove <b>cookies.sqlite</b> (cookies.sqlite.old) and when present delete cookies.sqlite-shm and cookies.sqlite-wal in the Firefox profile folder with Firefox closed in case cookies.sqlite got corrupted. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Folder/Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *https://support.mozilla.org/en-US/kb/Profiles
Was this helpful to you?
Quote

Question owner

I have just tried that but still no images!

I have just tried that but still no images!
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox
Was this helpful to you?
Quote

Question owner

Thanks for the suggestion but I still don't see any images in the threads after forgetting the site.

Thanks for the suggestion but I still don't see any images in the threads after forgetting the site.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

If images are missing then check that you do not block images from some domains.

  • you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily

check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions".


Check "Tools -> Page Info -> Media" for blocked images

  • select the first image and use the cursor Down key to scroll through the list
  • if an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain

You can check this pref on the about:config page.

  • permissions.default.image (1)
  • network.http.sendRefererHeader (2)

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check in the Web Console what content is blocked

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

See also:

You can check the Web Console (Tools -> Web Developer) for messages about blocked content and about the presence of mixed or unsafe content. *https://developer.mozilla.org/en-US/Tools/Web_Console You can check the Network Monitor to see if content is blocked or otherwise fails to load. *https://developer.mozilla.org/en-US/Tools/Network_Monitor If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log. If images are missing then check that you do not block images from some domains. *you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions". ---- Check "Tools -> Page Info -> Media" for blocked images *select the first image and use the cursor Down key to scroll through the list *if an image in the list is grayed and "<i>Block Images from...</i>" has a checkmark then remove this checkmark to unblock images from this domain You can check this pref on the <b>about:config</b> page. *permissions.default.image (1) *network.http.sendRefererHeader (2) <hr> If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content. *make sure your extensions and filters are updated to the latest version *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content. *click the shield icon for more details and possibly disable the protection You can check in the Web Console what content is blocked *"3-bar" menu button or Tools -> Web Developer *https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems See also: *https://support.mozilla.org/en-US/kb/fix-problems-images-not-show *https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently
Was this helpful to you?
Quote

Question owner

Web Console shows these errors: NS_ERROR_FILE_CORRUPTED: root_library.js.c915dd566b4cdca99cad340425bc13ce.js:15

   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_global/root_library.js.c915dd566b4cdca99cad340425bc13ce.js:15
   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_global/root_library.js.c915dd566b4cdca99cad340425bc13ce.js:15

TypeError: ips is undefined root_js_lang_1.js.141f5a70564e1475212c21fa03a5067c.js:1:1

   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_global/root_js_lang_1.js.141f5a70564e1475212c21fa03a5067c.js:1

TypeError: ips is undefined root_framework.js.88bfa9d4ad0e869a15434304c22ae7a9.js:1:1

   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_global/root_framework.js.88bfa9d4ad0e869a15434304c22ae7a9.js:1

TypeError: ips is undefined global_global_core.js.4810300d24d261b3873ebad98433ede3.js:1:40

   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_core/global_global_core.js.4810300d24d261b3873ebad98433ede3.js:1
   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_core/global_global_core.js.4810300d24d261b3873ebad98433ede3.js:1

TypeError: ips is undefined plugins_plugins.js.d15d2cf026e6990e8fdfe0622988deab.js:1:40

   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_core/plugins_plugins.js.d15d2cf026e6990e8fdfe0622988deab.js:1
   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_core/plugins_plugins.js.d15d2cf026e6990e8fdfe0622988deab.js:13

TypeError: ips is undefined root_front.js.40a7330bb3d1cdf1aaed785bd39561a7.js:1:40

   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_global/root_front.js.40a7330bb3d1cdf1aaed785bd39561a7.js:1
   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_global/root_front.js.40a7330bb3d1cdf1aaed785bd39561a7.js:13

TypeError: ips is undefined front_front_comments.js.7b9ebc02aefe372653fd6ff73a39c21f.js:1:40

   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_nbenhadverts/front_front_comments.js.7b9ebc02aefe372653fd6ff73a39c21f.js:1
   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_nbenhadverts/front_front_comments.js.7b9ebc02aefe372653fd6ff73a39c21f.js:1

TypeError: ips is undefined front_front_core.js.0cffddea4c91a8543bf46af7802005b8.js:1:40

   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_nbenhadverts/front_front_core.js.0cffddea4c91a8543bf46af7802005b8.js:1
   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_nbenhadverts/front_front_core.js.0cffddea4c91a8543bf46af7802005b8.js:7

TypeError: ips is undefined front_front_topic.js.f62cc15bf1ee85975c56f6ffb58eb061.js:1:40

   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_forums/front_front_topic.js.f62cc15bf1ee85975c56f6ffb58eb061.js:1
   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_forums/front_front_topic.js.f62cc15bf1ee85975c56f6ffb58eb061.js:14

TypeError: ips is undefined front_front_core.js.00d50fa20597f7414276188fb967ec2c.js:1:40

   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_core/front_front_core.js.00d50fa20597f7414276188fb967ec2c.js:1
   <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_core/front_front_core.js.00d50fa20597f7414276188fb967ec2c.js:2

TypeError: ips is undefined 3274:239:4

   <anonymous> https://www.l-camera-forum.com/topic/205842-i-like-filmopen-thread/page/3274/#comments:239

​Firefox's built in Enhanced Tracking Protection is Off for this site. uBlock Origin and Malwarebytes Browser Guard are both off for this site.

With respect to Page Info, the checkbox to Block Images is unchecked. The images that show in the media pane are page elements and user avatars, but none of the images contained in posts show up there.

I'm using a MacBook Air, with no discrete GPU, so hardware acceleration should not be a problem.

permissions.default.image is set to (1) network.http.sendRefererHeader is set to (2)

From the web console results I'm guessing this has something to do with javascript?

Web Console shows these errors: NS_ERROR_FILE_CORRUPTED: root_library.js.c915dd566b4cdca99cad340425bc13ce.js:15 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_global/root_library.js.c915dd566b4cdca99cad340425bc13ce.js:15 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_global/root_library.js.c915dd566b4cdca99cad340425bc13ce.js:15 TypeError: ips is undefined root_js_lang_1.js.141f5a70564e1475212c21fa03a5067c.js:1:1 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_global/root_js_lang_1.js.141f5a70564e1475212c21fa03a5067c.js:1 TypeError: ips is undefined root_framework.js.88bfa9d4ad0e869a15434304c22ae7a9.js:1:1 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_global/root_framework.js.88bfa9d4ad0e869a15434304c22ae7a9.js:1 TypeError: ips is undefined global_global_core.js.4810300d24d261b3873ebad98433ede3.js:1:40 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_core/global_global_core.js.4810300d24d261b3873ebad98433ede3.js:1 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_core/global_global_core.js.4810300d24d261b3873ebad98433ede3.js:1 TypeError: ips is undefined plugins_plugins.js.d15d2cf026e6990e8fdfe0622988deab.js:1:40 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_core/plugins_plugins.js.d15d2cf026e6990e8fdfe0622988deab.js:1 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_core/plugins_plugins.js.d15d2cf026e6990e8fdfe0622988deab.js:13 TypeError: ips is undefined root_front.js.40a7330bb3d1cdf1aaed785bd39561a7.js:1:40 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_global/root_front.js.40a7330bb3d1cdf1aaed785bd39561a7.js:1 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_global/root_front.js.40a7330bb3d1cdf1aaed785bd39561a7.js:13 TypeError: ips is undefined front_front_comments.js.7b9ebc02aefe372653fd6ff73a39c21f.js:1:40 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_nbenhadverts/front_front_comments.js.7b9ebc02aefe372653fd6ff73a39c21f.js:1 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_nbenhadverts/front_front_comments.js.7b9ebc02aefe372653fd6ff73a39c21f.js:1 TypeError: ips is undefined front_front_core.js.0cffddea4c91a8543bf46af7802005b8.js:1:40 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_nbenhadverts/front_front_core.js.0cffddea4c91a8543bf46af7802005b8.js:1 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_nbenhadverts/front_front_core.js.0cffddea4c91a8543bf46af7802005b8.js:7 TypeError: ips is undefined front_front_topic.js.f62cc15bf1ee85975c56f6ffb58eb061.js:1:40 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_forums/front_front_topic.js.f62cc15bf1ee85975c56f6ffb58eb061.js:1 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_forums/front_front_topic.js.f62cc15bf1ee85975c56f6ffb58eb061.js:14 TypeError: ips is undefined front_front_core.js.00d50fa20597f7414276188fb967ec2c.js:1:40 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_core/front_front_core.js.00d50fa20597f7414276188fb967ec2c.js:1 <anonymous> https://cdn.l-camera-forum.com/uploads/javascript_core/front_front_core.js.00d50fa20597f7414276188fb967ec2c.js:2 TypeError: ips is undefined 3274:239:4 <anonymous> https://www.l-camera-forum.com/topic/205842-i-like-filmopen-thread/page/3274/#comments:239 ​Firefox's built in Enhanced Tracking Protection is Off for this site. uBlock Origin and Malwarebytes Browser Guard are both off for this site. With respect to Page Info, the checkbox to Block Images is unchecked. The images that show in the media pane are page elements and user avatars, but none of the images contained in posts show up there. I'm using a MacBook Air, with no discrete GPU, so hardware acceleration should not be a problem. permissions.default.image is set to (1) network.http.sendRefererHeader is set to (2) From the web console results I'm guessing this has something to do with javascript?
Was this helpful to you?
Quote

Question owner

I think I have the answer! I created a new profile and from it I can log in to flickr.com and see images in my Leica forum. This is with the same extensions that I re-added via Firefox Sync.

I think I have the answer! I created a new profile and from it I can log in to flickr.com and see images in my Leica forum. This is with the same extensions that I re-added via Firefox Sync.
Was this helpful to you?
Quote

Question owner

Blast! After quitting and restarting Firefox the problems are back.

Blast! After quitting and restarting Firefox the problems are back.
Was this helpful to you?
Quote
evhenry
  • Top 25 Contributor
  • Administrator
15 solutions 89 answers

You only have those two extensions too, right? Are you using userChrome.css? Since you tried a new profile and it fixed it (and it works in private mode where add ons are disabled) perhaps disabling those extensions for the page isn't doing enough? Do they have additional settings for privacy protection that might still be enabled?

You only have those two extensions too, right? Are you using userChrome.css? Since you tried a new profile and it fixed it (and it works in private mode where add ons are disabled) perhaps disabling those extensions for the page isn't doing enough? Do they have additional settings for privacy protection that might still be enabled?
Was this helpful to you?
Quote

Chosen Solution

I'm sure you must be right. Installed extensions are: uBlock Origin Malwarebytes Browser Guard 1Password X Enhancer for YouTube Disable HTML5 Autoplay

Only the first two ought to interfere with page elements, but even if disabled for Flickr and the Leica forum, I have problems. Oddly, I can get logged in and see pages normally in a Private window with those extensions active, yet I cannot in safe mode when they ought to be disabled entirely. I made a third profile and this time kept uBlock Origin in non-advanced mode, and did not import all my settings from the other profile's installation. Currently I can log in to Flickr and see images on the Leica forum with all extensions active, and this has survived two quits and restarts. Fingers crossed it lasts! Maybe uBlock Origin is still affecting page content in some way even when disabled for a site.

I'm sure you must be right. Installed extensions are: uBlock Origin Malwarebytes Browser Guard 1Password X Enhancer for YouTube Disable HTML5 Autoplay Only the first two ought to interfere with page elements, but even if disabled for Flickr and the Leica forum, I have problems. Oddly, I can get logged in and see pages normally in a Private window with those extensions active, yet I cannot in safe mode when they ought to be disabled entirely. I made a third profile and this time kept uBlock Origin in non-advanced mode, and did not import all my settings from the other profile's installation. Currently I can log in to Flickr and see images on the Leica forum with all extensions active, and this has survived two quits and restarts. Fingers crossed it lasts! Maybe uBlock Origin is still affecting page content in some way even when disabled for a site.
Was this helpful to you?
Quote
اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.