Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I shut down my Mac, I lose Firefox including extensions and bookmarks and must set it up again when I restart.

  • 3 replies
  • 1 has this problem
  • 29 views
  • آخر ردّ كتبه paul130

more options

I have been using Firefox for years without difficulty with an older MacBook Pro. I recently bought a new MacBook Pro and installed Catalina. I successfully downloaded Firefox 70. But when I shut down my Mac and restart, Firefox is gone and i must set it up again. In the process, I find I have lost extensions and bookmarks. What can i do to make sure this doesn't happen?

Chosen solution

It is possible that you run Firefox from within the DMG (Disk Image) file.

Make sure you install Firefox properly.

Open the Firefox Disk Images file and drag the Firefox application to the Applications folder on your hard drive. You shouldn't double-click the Firefox application to run it from the Disk Images, but instead drag it out of the DMG folder.


Read this answer in context 👍 1

All Replies (3)

more options

I have this problem tool

more options

Chosen Solution

It is possible that you run Firefox from within the DMG (Disk Image) file.

Make sure you install Firefox properly.

Open the Firefox Disk Images file and drag the Firefox application to the Applications folder on your hard drive. You shouldn't double-click the Firefox application to run it from the Disk Images, but instead drag it out of the DMG folder.


more options

I haven't been using Firefox since I first reported the problem, but thanks to the latest comment it appears to be fixed. Thank you.