Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How do I get FireFox not to cache visited pages.

  • 3 replies
  • 2 have this problem
  • 2 views
  • آخر ردّ كتبه cor-el

more options

I need to see the actual page while testing my site, but FireFox frequently shows me a previously viewed version. I can refresh the page and get the correct page, but this is tedious when I have just overhauled the site.

All Replies (3)

more options

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

more options

Does it help to view the site in a private window?

You can turn off caching temporarily if necessary:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste cache*enable and pause while the list is filtered

(3) Double-click the browser.cache.disk.enable preference to switch the value from true to false

(4) Double-click the browser.cache.memory.enable preference to switch the value from true to false

more options

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)