Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

workintexas.com gives error SSL_ERROR_NO_CYPHER_OVERLAP

  • 4 replies
  • 2 have this problem
  • 418 views
  • آخر ردّ كتبه cor-el

more options

When trying to load the website www.workintexas.com, I receive the following error message:

Secure Connection Failed

An error occurred during a connection to www.workintexas.com. Cannot communicate securely with peer: no common encryption algorithm(s). Error code: SSL_ERROR_NO_CYPHER_OVERLAP

This appears to be affecting Firefox on several of my devices: Ubuntu/Linux, maOS, and Android. The error does not appear to be effecting Lynx on Ubuntu, Safari on macOS or Chrome on Android.

I've tried the following troubleshooting steps on Firefox 69.0.2 running on Ubuntu to try to resolve this:

  • Updated software on Ubuntu
  • Restarting computer
  • Cleared History/Cookies/Cache
  • Check to make sure TLS and SSL setting were set to default
  • Checked Network setting in Firefox
  • Tried disabling IPv6
  • Tried accessing with Firefox in Safe Mode

I had previously accessed this website less than two days ago on this same browser.

My instinct says that there's probably something misconfigured on the server - probably with the security certificate - but then why did it work in Lynx, Safari, and Chrome?

Anybody have any ideas what's up?

Chosen solution

The server only supports TLS 1.2 with a few cipher suites with most marked as weak and only TLS_DHE_RSA_WITH_AES_256_GCM_SHA384 as acceptable.

Mozilla decided not to implement the DHE variants:

  • Bug 1084554 - Implement TLS 1.2 DHE AES-GCM cipher suites

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

The server only supports TLS 1.2 with a few cipher suites with most marked as weak and only TLS_DHE_RSA_WITH_AES_256_GCM_SHA384 as acceptable.

Mozilla decided not to implement the DHE variants:

  • Bug 1084554 - Implement TLS 1.2 DHE AES-GCM cipher suites

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

Well that sucks.

I am trying to contact the site admin to see if they are aware/trying to resolve this.

Thanks.

more options

I checked the website again today, and it looks like WorkInTexas added the TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384 Cipher Suite. That seems to have corrected the issue with Firefox. Huzzah!

Out of curiosity, outside of the Bug Tracker or the Help Form, is there some easy to find documentation on this? If not, is there an easy way to volunteer to write this? Despite getting affected/effected mixed up in the original question, I am a decent writer :P

more options

That is a quick response from the website! The website will work in Firefox 49 and later, so user with Firefox 45 (e.g. Mac OS X 10.6) will still be out of luck.

We usually check the server with a website like Qualys (www.ssllabs.com) to see what is wrong if there is a SSL_ERROR_NO_CYPHER_OVERLAP error or other error reported.