Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Reconnecting another device runs forever

  • 5 replies
  • 1 has this problem
  • 7 views
  • آخر ردّ كتبه user224603

more options

I have two PCs one Linux the other Windows 10. I can sign on to my Firefox account on both machines Synch seems to be enabled on the Linuz PC only. When I try to connect Synch to the Windows PC I get the image which is on the first attached Screenshot. Following these direction I sign in to Firefox account on Windows and get the screen displayed in the second attachment. After about ten seconds it switches to the word "Working.." and stays there for hours.

Attached screenshots

Chosen solution

I reset the items in the user agent section. That did the trick, my second PC now seems to synch.

Thanks very much for your help.

Read this answer in context 👍 0

All Replies (5)

more options

Is the browser working as far as everything else?


We need to look at the sync logs.

Note: Do the following for each problem system/profile. And label each as to what system/profile.

Type about:sync-log<enter> in the address bar.

Open the last file created and Copy its contents Now Paste it into this forum.

If the file is too large;


Open a text/word program and load the file. Left-click once. Now <Control> A to highlight everything, then <Control> C to copy it.

Next, have your web browser go to; https://pastebin.com/

Paste <Control> P the content of the file in the window. Note: On the bottom, fill out the boxes as best you can.

Now press Create A New Paste. The page will reload. Copy the new web address, and post it here.

more options
more options

This is likely caused by a broken user agent that identifies you as Firefox/47.0, probably done by an extension.

  • Mozilla/5.0 (masking-agent; rv:47.0) Gecko/20100101 Firefox/47.0

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Thanks for your replies, I restarted Firefox in Safe Mode with all extension disabled and the reconnect action still is working without finishing. Then I disabled hardware acceleration and tried reconnect again, the problem persists. This afternoon I will go through your replies again to see if I can try another remedy you recommended. I will report later.

more options

Chosen Solution

I reset the items in the user agent section. That did the trick, my second PC now seems to synch.

Thanks very much for your help.