Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Addon icons missing after reinstall

  • 5 replies
  • 1 has this problem
  • 564 views
  • آخر ردّ كتبه kris4

more options

I have just reinstalled the newest version of Firefox, and both addons I use (Pinterest Save Button and OneTab) installed but no longer show an icon on the toolbar, I have tried safe mode but no joy.

Chosen solution

An update -- I solved the problem, it turned out my secondary hard drive (where my Windows AppData folders are located) was failing, which kept disconnecting Firefox from my profile data). I have since replaced the drive and reinstalled Firefox, now the plugins work perfectly well.

Read this answer in context 👍 0

All Replies (5)

more options

Hi kris4,

Sorry to hear you are having issues locating your add-ons after the Firefox update.

Have you checked out the Customize Firefox controls, buttons and toolbars article?

To access: Click the '3-bar' menu in your browser - > Customize...

See related thread for reference : Add on icons not showing next to the search bar.

If your icons are still not showing on your toolbar let me know, and I'll help you get this resolved.

more options

Hi,

I tried the suggestions in that thread but there was no change apart from resetting some of my browser options.

The addons are not set to disabled.

The Customise menu has no icons for my addons, so I can't add them from there (see attached).

Please let me know if you have any other ideas, thanks.

more options

Image attached

more options

Did you try to click Restore Defaults ?


You can check for problems with the extensions registry files in the profile folder.

Try to to reset the extensions registry and rename extensions.json (extensionsOLD.json) and rename/remove previously used extensions files like extensions.ini and extensions.sqlite when present and rename/remove compatibility.ini in the Firefox profile folder with Firefox closed.

New files will be created when required.

See "Corrupt extension files":

You can check for possible updates in case of issues.

  • click the cogwheel button (left of the Search bar) on the about:addons page to "Check for updates"

If this didn't help then delete add-ons.json and possibly prefs.js in case there is a problem with preferences.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

Chosen Solution

An update -- I solved the problem, it turned out my secondary hard drive (where my Windows AppData folders are located) was failing, which kept disconnecting Firefox from my profile data). I have since replaced the drive and reinstalled Firefox, now the plugins work perfectly well.