ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

jssor photo slider irregular only when using firefox

  • 2 (ردّان اثنان)
  • 1 has this problem
  • 72 views
  • آخر ردّ كتبه NUMNUM

more options

I have a photo sider (jssor) located here; https://apco-atlantic.org/

The slider performs flawlessly with all browsers except firefox. In firefox it is jumpy and out of sync. I'm at a loss to the problem.

الحل المُختار

Hmm, the manual functions all work smoothly, but there's some kind of timing issue with the transition: there's a flash, the caption slides, but there's a delay with the correct image appearing.

When I look at their transition page, it seems okay (tried "Fade Fly in R" and "Fade out L" which seems similar to yours): https://www.jssor.com/development/tool-slideshow-transition-viewer.html

But your library uses different code from the current release -- for example, $JssorEasing$.$EaseInCubic seems to have changed to $Jease$.$InCubic -- so the new JS file is not a drop-in replacement, you would need to update all the parameters for your slideshow.

Read this answer in context 👍 1

All Replies (2)

more options

الحل المُختار

Hmm, the manual functions all work smoothly, but there's some kind of timing issue with the transition: there's a flash, the caption slides, but there's a delay with the correct image appearing.

When I look at their transition page, it seems okay (tried "Fade Fly in R" and "Fade out L" which seems similar to yours): https://www.jssor.com/development/tool-slideshow-transition-viewer.html

But your library uses different code from the current release -- for example, $JssorEasing$.$EaseInCubic seems to have changed to $Jease$.$InCubic -- so the new JS file is not a drop-in replacement, you would need to update all the parameters for your slideshow.

more options

Thank you very much! While I haven't swapped the code out from production, it works on my test server.