Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Still Not Working!

  • 6 replies
  • 1 has this problem
  • 29 views
  • آخر ردّ كتبه AnnieBody

more options

I gave up on Firefox due to its insistence that I could not stop it forcing updates on me no matter what settings I used in options as well as about: . I went back to IE9. Yes 9, as Microsoft couldn't repair Windows 7 to get a later version installed. Anyhow, after my motherboard became erratic and the replacement meant Win 7 no longer worked at all, I decided it was time to 'upgrade' to Win 10. After a complete reinstall of my software from scratch I realised just how bad Edge is and thought I might see how Firefox was holding up. I thought the sync could be useful and was getting on with it until 68.0.1! Since updating to this version automatically (the settings in options still do not work), it appears it is updating/resetting itself after every reboot. It restores the defaults and behaves as if it has just updated each time. Also after doing this for five times it appears to have broken ADBlock which advises it cannot work any more. I have had to uninstall it to get the tab to stop. So, as my questions were never answered previously, I'll ask again: 1. How do I get Firefox to stop updating itself? Options 'check for updates but let you choose when to install them' clearly still doesn't work as it updates regardless. 2. How do I get to keep my preferences. Having to go through them all each time Firefox updates is a pain. Surely it cannot be too much to create an ini file? 3. How do I convince Firefox not to keep installing version 68.0.1 over itself? 4. As Adblock no longer works in this version (I'm sure they are pleased with this result), what good alternatives are there?

Chosen solution

All Replies (6)

more options

Chosen Solution

Hello,

Here is how to disable updates.

https://winaero.com/blog/disable-updates-firefox-63-above/

more options

There is also; How do you completely turn off update checks in Firefox v64? You can use a policies.json file to disable updates for all users. https://github.com/mozilla/policy-templates/blob/master/README.md

more options

AnnieBody said

Since updating to this version automatically (the settings in options still do not work), it appears it is updating/resetting itself after every reboot. It restores the defaults and behaves as if it has just updated

There are several things that can result in losing your profile.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options
more options
more options

Thanks to all that responded. I know from a previous request that about: config changes were ignored. It appears the fix by Jeremy Sanders is what I was looking for. When software is working I don't see the need to update, it invariably causes problems to resolve issues I don't need fixing. The only software I routinely update is Windows, mainly because it needs it!