Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hyperlinks from any program other than firefox will not open

  • 28 replies
  • 1 has this problem
  • 1576 views
  • آخر ردّ كتبه Yazu

more options

I am having an issue where no hyperlinks will open in firefox. Thunderbird will show the error below, but no other programs such as discord or open office will show any error or response when clicking on a hyperlink. I was looking through the default programs and settings and the advanced areas in those menus and found the pair of protocol below, which I changed and then changed back with no result.

I have just downloaded chrome and tried to open the links into it, with the same results as firefox.

Attached screenshots

Chosen solution

OK, yeah, I've got a thunderstorm coming this way.

If it were me, I would uninstall the latest Windows update and see what happens. If things work out OK I would get the update from the Update Catalog.

Read this answer in context 👍 1

All Replies (20)

more options

Hi BenNR,

In Windows Settings: Try Resetting to the Microsoft recommended defaults. Then set your defaults back again.

more options

That was one of the first things I did. I did it again though, but there were still no results.

more options

Hi BenNR, were links opening in Firefox normally in Firefox 66, this problem just started with Firefox 67 last week?

Firefox 67 changed what happens when you launch an external link. Previously Firefox would send the link to the running profile. Now, Firefox launches the link in your default profile. Something obviously is going wrong after this change.

Do you run a regular release of Firefox or the PortableApps release (Firefox Portable)? For that version, see: https://portableapps.com/node/60315

Profile Manager Page

For regular Firefox, let's see whether we can straighten out the default profile setting.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

This page should list at least one profile and could list many. Each will show links to a pair of folders; please ignore those for now.

The profile that Firefox is currently using will have this:

This is the profile in use and it cannot be deleted.

Anyway, please do not delete anything here -- don't use any Remove buttons.

Do you have another profile named default or default-longnumber listed on this page? If so, you can check whether it is the one you prefer by clicking its Launch profile in new browser button.

If it isn't what you want, simply close that new window.

If it IS what you want, back on the about:profiles page, click the Set as default profile button for that profile so Firefox uses it automatically at the next startup and it is recorded as the profile for external links.

Any progress so far?

more options

Hi BenNR,

It seems that something isn't "latching up" properly in file type & protocol associations.

In Windows Settings -> Apps -> Default Apps -> Set Defaults by App you should have htm, html, http and https set for Firefox (see screenshot).

Did you try setting Chrome as your default browser and see if it works there?

You might have to restart after making these changes, also.

more options

@My_Cheese_Is_Slippin

It seems like I don't have the htm and html protocols. The onle ones I see are the ones for http and https. I have included a screenshot of what I see below

I downloaded chrome and tried to use it, but with no success either.

@jscher2000

I was using the previous version of firefox, and have since updated to try to fix the issue. I suspect that it's not actually an issue with firefox itself, but with my OS, since I have tried to use Chrome and Edge to open these links, but to no sucess.

more options

@jscher200

Sorry, I forgot to include that the issue began last night.

more options

@My_Cheese_Is_Slippin

I apologize, I realize I was in the wrong settings for that. Here is the correct one.

more options

Hi BenNR, it's puzzling that none of your browsers can handle an HTTP or HTTPS URL. These settings are stored in the Windows Registry, but they are complicated to change by hand. Hopefully you can find a method that works to update them.

more options

Hi BenNR,

Looks good to me. Like I said something isn't "latching up".

Try setting your default browser to Edge or IE. Then restart your computer. After it boots up check where links are opening. If they work you can change your protocols (http,https) back to Firefox and see if they work there.

more options

I changed my default browser to Edge, restarted, and the links don't work.

more options

Hi BenNR,

I found this in quite a few places regarding the same issue.

Press the win + r keys together In the run dialogue box copy/paste: regsvr32 urlmon.dll (press enter) You should receive a success message. Restart computer (must be restart not shutdown) Try links now.

If this doesn't work, the suggestions elsewhere require digging around in the registry

more options

Unfortunately didn't work. Where in the registry should I look?

more options

Hi, I'm looking at a post here: https://www.bleepingcomputer.com/forums/t/663211/hyperlinks-not-working/

About half-way down the page they're talking about using command prompt to query the registry before making any changes.

more options

BenNR said

Where in the registry should I look?

In RegEdit, if you drill down to

  • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\https\UserChoice
  • HKEY_CURRENT_USER\Software\Microsoft\Windows\Shell\Associations\UrlAssociations\https\UserChoice

You would normally see this value:

ProgId = FirefoxURL-308046B0AF4A39CB

(That number might vary, but I think it is the identifier for the regular Firefox release, currently version 67 -- in the old days, it just said FirefoxURL)

Then if you drill down to

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\FirefoxURL-308046B0AF4A39CB\shell\open\command

you should find a command line value similar to

(default) = "C:\Program Files\Mozilla Firefox\firefox.exe" -osint -url "%1"

Yours may vary, e.g., C:\Program Files (x86)\...

How does yours look so far?

Modified by jscher2000

more options

@My_Cheese_Is_Slippin

Thank you, I will work on that and see if it helps.

@jscher2000

Mine looks just like you said. Screenshots included below.

more options

BenNR, When I ran that first registry query it returned 'unable to find key or value'. But I'm working fine, so you might disregard that query?

I also found this: https://www.tenforums.com/browsers-email/88652-hyperlinks-not-working.html

Modified by RobertJ

more options

@My_Cheese_Is_Slippin

I got returns from both of them.


HKEY_LOCAL_MACHINE\SOFTWARE\Classes\htmlfile\shell\open\command

   (Default)    REG_SZ    "C:\Program Files\Internet Explorer\IEXPLORE.EXE" %1
   DelegateExecute    REG_SZ    {17FE9752-0B5A-4665-84CD-569794602F5C}


HKEY_CLASSES_ROOT\.html

   (Default)    REG_SZ    htmlfile
   Content Type    REG_SZ    text/html
   PerceivedType    REG_SZ    text

HKEY_CLASSES_ROOT\.html\OpenWithProgids HKEY_CLASSES_ROOT\.html\PersistentHandler

more options

BenNR, Like I said, no return on first query. Second looks like this: HKEY_CLASSES_ROOT\.html

   (Default)    REG_SZ    FirefoxHTML-EE7D006F8EA4B164
   Content Type    REG_SZ    text/html
   PerceivedType    REG_SZ    text

HKEY_CLASSES_ROOT\.html\OpenWithProgids HKEY_CLASSES_ROOT\.html\PersistentHandler

more options

BenNR, Afterthought - I have IE11 turned off in Windows Features. That probably explains why I got no return on the first query.

more options

BenNR, Your HKEY_LOCAL_MACHINE\SOFTWARE\Classes\htmlfile\shell\open\command shows IE as the default. Try setting your default browser to IE and try a link.

  1. 1
  2. 2