X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

منتدى الدعم

enable autoplay videos for new tab

Posted

I tried to enable the browser to play videos in new tabs by itself but it refuses to. I read to change the value of the media.autoplay.enabled but i did a search for it in the about:config window, but it doesn't show that it exists... any help would be grateful!

I tried to enable the browser to play videos in new tabs by itself but it refuses to. I read to change the value of the media.autoplay.enabled but i did a search for it in the about:config window, but it doesn't show that it exists... any help would be grateful!

Chosen solution

In that case, you are looking for the media.block-autoplay-until-in-foreground preference. You want to set that to false.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

Wesley Branton
  • Top 25 Contributor
509 solutions 4491 answers

Those are the old steps. Firefox just recently had that setting added to the Firefox Settings page. It's the Block websites from automatically playing sound option.

You can also allow/block autoplay on a site-by-site basis using the website permissions menu.

More information about the feature can be found in Allow or block media autoplay in Firefox.

Hope this helps.

Those are the old steps. Firefox just recently had that setting added to the Firefox Settings page. It's the '''Block websites from automatically playing sound''' option. You can also allow/block autoplay on a site-by-site basis using the website permissions menu. More information about the feature can be found in [[Allow or block media autoplay in Firefox]]. Hope this helps.
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17087 solutions 154328 answers

The media.autoplay.enabled pref is replaced by an Integer pref named media.autoplay.default.

  • media.autoplay.default = 1 [0:Allowed; 1:Blocked 2:Prompt]

Two other prefs available on the about:config page:

  • media.autoplay.allow-muted
  • media.autoplay.enabled.user-gestures-needed
The media.autoplay.enabled pref is replaced by an Integer pref named media.autoplay.default. *media.autoplay.default = 1 [0:Allowed; 1:Blocked 2:Prompt] Two other prefs available on the <b>about:config</b> page: *media.autoplay.allow-muted *media.autoplay.enabled.user-gestures-needed
Was this helpful to you?
Quote

Question owner

Wesley Branton said

Those are the old steps. Firefox just recently had that setting added to the Firefox Settings page. It's the Block websites from automatically playing sound option. You can also allow/block autoplay on a site-by-site basis using the website permissions menu. More information about the feature can be found in Allow or block media autoplay in Firefox. Hope this helps.

I tried that and unfortunately that didn't work. What it used to do, i would middle click on a video so it would open in a new tab, and then it would autoplay, but now i do the same thing, and it won't play until i click on the new tab.

''Wesley Branton [[#answer-1223071|said]]'' <blockquote> Those are the old steps. Firefox just recently had that setting added to the Firefox Settings page. It's the '''Block websites from automatically playing sound''' option. You can also allow/block autoplay on a site-by-site basis using the website permissions menu. More information about the feature can be found in [[Allow or block media autoplay in Firefox]]. Hope this helps. </blockquote> I tried that and unfortunately that didn't work. What it used to do, i would middle click on a video so it would open in a new tab, and then it would autoplay, but now i do the same thing, and it won't play until i click on the new tab.
Was this helpful to you?
Quote

Question owner

cor-el said

The media.autoplay.enabled pref is replaced by an Integer pref named media.autoplay.default.
  • media.autoplay.default = 1 [0:Allowed; 1:Blocked 2:Prompt]
Two other prefs available on the about:config page:
  • media.autoplay.allow-muted
  • media.autoplay.enabled.user-gestures-needed

looked into all those and still no luck

''cor-el [[#answer-1223073|said]]'' <blockquote> The media.autoplay.enabled pref is replaced by an Integer pref named media.autoplay.default. *media.autoplay.default = 1 [0:Allowed; 1:Blocked 2:Prompt] Two other prefs available on the <b>about:config</b> page: *media.autoplay.allow-muted *media.autoplay.enabled.user-gestures-needed </blockquote> looked into all those and still no luck
Was this helpful to you?
Quote
Wesley Branton
  • Top 25 Contributor
509 solutions 4491 answers

Chosen Solution

In that case, you are looking for the media.block-autoplay-until-in-foreground preference. You want to set that to false.

In that case, you are looking for the <code>media.block-autoplay-until-in-foreground</code> preference. You want to set that to <code>false</code>.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17087 solutions 154328 answers

You have to disable block auto-play and make sure media.autoplay.default = 0 Also make sure media.autoplay.allow-muted = true and media.autoplay.enabled.user-gestures-needed = false That would work if the website allows auto play. If the website doesn't use auto-play then these setting do not have effect as this is only about websites that play automatically and you do not want this.

You have to disable block auto-play and make sure media.autoplay.default = 0 Also make sure media.autoplay.allow-muted = true and media.autoplay.enabled.user-gestures-needed = false That would work if the website allows auto play. If the website doesn't use auto-play then these setting do not have effect as this is only about websites that play automatically and you do not want this.
Was this helpful to you?
Quote

Question owner

Wesley Branton said

In that case, you are looking for the media.block-autoplay-until-in-foreground preference. You want to set that to false.

awesome work! that did it, i appreciate the help very much, Wesley.

''Wesley Branton [[#answer-1223079|said]]'' <blockquote> In that case, you are looking for the <code>media.block-autoplay-until-in-foreground</code> preference. You want to set that to <code>false</code>. </blockquote> awesome work! that did it, i appreciate the help very much, Wesley.
Was this helpful to you?
Quote
اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.