X
Tap here to go to the mobile version of the site.

منتدى الدعم

Messenger and the the Notifications pull-down menu on Facebook are non-functional using Firefox.

Posted

The Messenger page cycles and then goes blank, but with the full top-menu items showing.

When I try the Notifications pull-down it just cycles, and never shows the notifications.

These two FB features work perfectly on Safari.

Is this a Firefox problem, or a FB problem?

The Messenger page cycles and then goes blank, but with the full top-menu items showing. When I try the Notifications pull-down it just cycles, and never shows the notifications. These two FB features work perfectly on Safari. Is this a Firefox problem, or a FB problem?
Quote
FredMcD
  • Top 10 Contributor
4120 solutions 57521 answers

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}
Was this helpful to you? 0
Quote

Question owner

Starting in Safe Mode did not solve the problem.

Starting in Safe Mode did not solve the problem.
Was this helpful to you? 0
Quote
FredMcD
  • Top 10 Contributor
4120 solutions 57521 answers

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.


https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any settings.

Many site issues can be caused by corrupt cookies or cache. '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} ------------- https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right-click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any settings.
Was this helpful to you?
Quote

Question owner

I tried doing the "Remove History For One Site".

While I was successful at removing the history, the same two problems exist.

No solution.

I tried doing the "Remove History For One Site". While I was successful at removing the history, the same two problems exist. No solution.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4120 solutions 57521 answers

Please provide a public link (no password) that we can check out. No Personal Information Please !

Please provide a public link (no password) that we can check out. '''No Personal Information Please ! '''
Was this helpful to you? 0
Quote

Question owner

FredMcD said

Please provide a public link (no password) that we can check out. No Personal Information Please !

A public link to what?

This loss of functionality is all happening when I am signed in to my Facebook account.

I will try to attach two screenshots...one of the pull-down "notifications" menu just cycling, and the other of the essentially blank "messenger" page.

Again, I have cleared out history, cache, rebooted, checked any applicable preferences...and sent "reports" to Facebook (with no reply)...and since everything works perfectly on Safari, it appears that this is somehow connected to Firefox.

''FredMcD [[#answer-1223203|said]]'' <blockquote> Please provide a public link (no password) that we can check out. '''No Personal Information Please ! ''' </blockquote> A public link to what? This loss of functionality is all happening when I am signed in to my Facebook account. I will try to attach two screenshots...one of the pull-down "notifications" menu just cycling, and the other of the essentially blank "messenger" page. Again, I have cleared out history, cache, rebooted, checked any applicable preferences...and sent "reports" to Facebook (with no reply)...and since everything works perfectly on Safari, it appears that this is somehow connected to Firefox.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4120 solutions 57521 answers

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version 66.0.4 May 5, 2019 Fixes add-on certificate issue. 66.0.5 May 7, 2019 Further improvements to re-enable web extensions

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version '''66.0.4''' May 5, 2019 Fixes add-on certificate issue. '''66.0.5''' May 7, 2019 Further improvements to re-enable web extensions
Was this helpful to you? 0
Quote

Question owner

Yes, I am on Firefox 66.0.5.

One of these recent versions is likely where/when the problems began for me.

Yes, I am on Firefox 66.0.5. One of these recent versions is likely where/when the problems began for me.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4120 solutions 57521 answers

I called for more help.

I called for more help.
Was this helpful to you?
Quote

Question owner

Thanks...no change at this end...

Thanks...no change at this end...
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
433 solutions 3851 answers

lpattis said

Starting in Safe Mode did not solve the problem.

Did you read the second part of FredMcD's first post about "Content blocking" (formerly known as "Tracking Protection")  ?

https://support.mozilla.org/en-US/kb/content-blocking

''lpattis [[#answer-1223038|said]]'' <blockquote> Starting in Safe Mode did not solve the problem. </blockquote> Did you read the second part of FredMcD's first post about "Content blocking" (formerly known as "Tracking Protection") ? https://support.mozilla.org/en-US/kb/content-blocking
Was this helpful to you?
Quote

Question owner

McCoy said

lpattis said
Starting in Safe Mode did not solve the problem.

Did you read the second part of FredMcD's first post about "Content blocking" (formerly known as "Tracking Protection")  ?

https://support.mozilla.org/en-US/kb/content-blocking


I'm pretty sure that I was not being limited on Facebook with this...no "shield" icon...and then I went to the "privacy & security" area of the Firefox prefs page and looked things over. It wasn't completely clear how to turn this off completely to test, but it appeared to me that my problems are not arising from that area...I'm not 100% sure on this...any further instructions relating to the specifics on that page would not be unwelcomed!

Thanks.

''McCoy [[#answer-1223370|said]]'' <blockquote> ''lpattis [[#answer-1223038|said]]'' <blockquote> Starting in Safe Mode did not solve the problem. </blockquote> Did you read the second part of FredMcD's first post about "Content blocking" (formerly known as "Tracking Protection") ? https://support.mozilla.org/en-US/kb/content-blocking </blockquote> I'm pretty sure that I was not being limited on Facebook with this...no "shield" icon...and then I went to the "privacy & security" area of the Firefox prefs page and looked things over. It wasn't completely clear how to turn this off completely to test, but it appeared to me that my problems are not arising from that area...I'm not 100% sure on this...any further instructions relating to the specifics on that page would not be unwelcomed! Thanks.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4120 solutions 57521 answers

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Secure''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia
Was this helpful to you?
Quote

Question owner

Thanks, unfortunately no change to the problems by starting my Mac in safe mode (as per the linked instructions).

BTW, the *only* problem I am having is in Facebook, as per my descriptions.

Thanks, unfortunately no change to the problems by starting my Mac in safe mode (as per the linked instructions). BTW, the *only* problem I am having is in Facebook, as per my descriptions.

Modified by lpattis

Was this helpful to you? 0
Quote
jgary 0 solutions 11 answers

I have this same problem with the New Firefox Quantum. ONLY problems in FACEBOOK..

On my Facebook page the bell with the number of Notifications shows numbers as before but I can't open it to see what the notification was, I can't open my messages and friend requests. I can not play videos on Facebook but I checked on Safari and they do run on Facebook there..I'm running Firefox ver 66.0.5 (64-bit) I checked all updates on add ons and plug ins. All up to date..I'm running OSX 10.10. 5 on a Mac

I have this same problem with the New Firefox Quantum. ONLY problems in FACEBOOK.. On my Facebook page the bell with the number of Notifications shows numbers as before but I can't open it to see what the notification was, I can't open my messages and friend requests. I can not play videos on Facebook but I checked on Safari and they do run on Facebook there..I'm running Firefox ver 66.0.5 (64-bit) I checked all updates on add ons and plug ins. All up to date..I'm running OSX 10.10. 5 on a Mac
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4120 solutions 57521 answers

I called for more help.

I called for more help.
Was this helpful to you?
Quote

Question owner

jgary said

I have this same problem with the New Firefox Quantum. ONLY problems in FACEBOOK.. On my Facebook page the bell with the number of Notifications shows numbers as before but I can't open it to see what the notification was, I can't open my messages and friend requests. I can not play videos on Facebook but I checked on Safari and they do run on Facebook there..I'm running Firefox ver 66.0.5 (64-bit) I checked all updates on add ons and plug ins. All up to date..I'm running OSX 10.10. 5 on a Mac

Yes, all three pull-down menus (friend-requests, messages, and notification) simply cycle.

Going to the messages-page itself provides only a blank screen, with the top-menu items intact.

I doubt we're the only ones experiencing this on the latest Firefox "upgrade".

I am on Apple's 10.14.4 OS, MacBook Pro.

''jgary [[#answer-1223502|said]]'' <blockquote> I have this same problem with the New Firefox Quantum. ONLY problems in FACEBOOK.. On my Facebook page the bell with the number of Notifications shows numbers as before but I can't open it to see what the notification was, I can't open my messages and friend requests. I can not play videos on Facebook but I checked on Safari and they do run on Facebook there..I'm running Firefox ver 66.0.5 (64-bit) I checked all updates on add ons and plug ins. All up to date..I'm running OSX 10.10. 5 on a Mac </blockquote> Yes, all three pull-down menus (friend-requests, messages, and notification) simply cycle. Going to the messages-page itself provides only a blank screen, with the top-menu items intact. I doubt we're the only ones experiencing this on the latest Firefox "upgrade". I am on Apple's 10.14.4 OS, MacBook Pro.
Was this helpful to you?
Quote
jgary 0 solutions 11 answers

Has anyone come up with a solution? I've been going crazy with this new Firefox Quantum and Facebook. I wish I never installed it...Take a look at my screen shot of the Notifications for Desktop and mobile. I only see this in Firefox. I can see notifications and messenges and friend requests in Safari. In Safari I can't get the "TURN ON" in Notifications for desktop and mobile. It only shows Mobile....Not desktop. Of course the TURN ON BUTTON DOESN'T WORK IN FIREFOX QUANTUM.

Has anyone come up with a solution? I've been going crazy with this new Firefox Quantum and Facebook. I wish I never installed it...Take a look at my screen shot of the Notifications for Desktop and mobile. I only see this in Firefox. I can see notifications and messenges and friend requests in Safari. In Safari I can't get the "TURN ON" in Notifications for desktop and mobile. It only shows Mobile....Not desktop. Of course the TURN ON BUTTON DOESN'T WORK IN FIREFOX QUANTUM.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
433 solutions 3851 answers

@ ipattis and jgary :

Apologies if this is a rethorical question, but have you checked the settings for notifications in : Preferences => Options => Privacy & Security => under "Permissions"  ?


I'm not sure if this would affect Facebook notifications, but would you do this please (it's worth a try) :

When you're on Facebook (using Firefox), click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Open Pop-up Windows". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.


Another thing to try :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar notifications

Look for the preference dom.webnotifications.enabled

and set its value to true

(and maybe check other preferences as well)

Then close and restart Firefox.

If that doesn't make a difference, then change the values back.

'Hope that helps (fingers crossed .... )


If none of the suggestions work, then I'm all out of ideas (other maybe than to file a bug report) ......

@ ipattis and jgary : Apologies if this is a rethorical question, but have you checked the settings for notifications in : Preferences => Options => Privacy & Security => under "Permissions" ? -------------------------------------------------------------------------------------------- I'm not sure if this would affect Facebook notifications, but would you do this please (it's worth a try) : When you're on Facebook (using Firefox), click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Open Pop-up Windows". Uncheck "Use Default" and check "Allow". Then close and restart Firefox. -------------------------------------------------------------------------------------------- Another thing to try : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar '''notifications''' Look for the preference '''dom.webnotifications.enabled''' and set its value to '''true''' (and maybe check other preferences as well) Then close and restart Firefox. If that doesn't make a difference, then change the values back. 'Hope that helps (fingers crossed .... ) -------------------------------------------------------------------------------------------- If none of the suggestions work, then I'm all out of ideas (other maybe than to file a bug report) ......
Was this helpful to you?
Quote
jgary 0 solutions 11 answers

Thank you very much for the info and troubleshooting. I've done all of that plus check the insane screen shot I posted with this. I'll post it again. It only appears in Facebook on Firefox quantum. in the Notifications settings. It doesn't show up in Safari but in Safari which I never use, all the messenger icons work. Videos play. This is a definite Firefox screw up and poor compatibility with Facebook. Facebook is too busy being Social Justice Warriors. I don't know when an update will come from Firefox or Facebook but with all that supposed Engineering "talent" those companies have this is a BIG screw up....i'm sorry, as I've written before, that I updated to quantum. I've been using Firefox for over 15 years..I even started with Netscape as my browser in 1996. See that green "Turn On" button next to Firefox to allow notifications on this device? it does nothing...I don't even see this in Safari...Keep your eyes out for a solution. These companies are on vacation it seems....Now I have to fight with Verizon because they uped my internet bill by $20. All I have is the internet with them. They kill you anyway then can. My area has FIOS. I was using DSL sincee 1998 and only 2 years ago I went with FIOS as it's offered in my area. Verizon does a bait ans switch . It's cheep at first then it skyrockets. It went from $25 to $90 in two years. each time it went up there was no notification. it' like being in a ball park and you can only buy a beer they sell for $10....Bastards...I'm and Electrical and Avionics Engineer and I've had my personal computer since 1985. I used mainframes at college and wile in the Air Force. I've never seen software so screwed up. Poor quality control....Get back to me if you find anything please..

Thank you very much for the info and troubleshooting. I've done all of that plus check the insane screen shot I posted with this. I'll post it again. It only appears in Facebook on Firefox quantum. in the Notifications settings. It doesn't show up in Safari but in Safari which I never use, all the messenger icons work. Videos play. This is a definite Firefox screw up and poor compatibility with Facebook. Facebook is too busy being Social Justice Warriors. I don't know when an update will come from Firefox or Facebook but with all that supposed Engineering "talent" those companies have this is a BIG screw up....i'm sorry, as I've written before, that I updated to quantum. I've been using Firefox for over 15 years..I even started with Netscape as my browser in 1996. See that green "Turn On" button next to Firefox to allow notifications on this device? it does nothing...I don't even see this in Safari...Keep your eyes out for a solution. These companies are on vacation it seems....Now I have to fight with Verizon because they uped my internet bill by $20. All I have is the internet with them. They kill you anyway then can. My area has FIOS. I was using DSL sincee 1998 and only 2 years ago I went with FIOS as it's offered in my area. Verizon does a bait ans switch . It's cheep at first then it skyrockets. It went from $25 to $90 in two years. each time it went up there was no notification. it' like being in a ball park and you can only buy a beer they sell for $10....Bastards...I'm and Electrical and Avionics Engineer and I've had my personal computer since 1985. I used mainframes at college and wile in the Air Force. I've never seen software so screwed up. Poor quality control....Get back to me if you find anything please..
Was this helpful to you?
Quote
اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.