X
Tap here to go to the mobile version of the site.

منتدى الدعم

Firefox disabled all Add-ons. Attempting to download replacement Add-ons returns "Download failed. Please check your connection." error message.

Posted

On 5/3/19 Firefox suddenly alerted me that it disabled all of my Add-ons stating that "These extensions do not meet current Firefox standards so they have been deactivated."

Immediately below this message, Firefox gives me the option to "Find a Replacement" Add-on.

After going through this process and locating the replacement Add-on, all attempts to download this (or any other Add-on) produce an error message stating "Download failed. Please check your connection."

However, my internet connection is working just fine.

I am running the latest version of Firefox (66.0.3 (64-bit)). And I have tried downloading the Add-on with my anti-virus temporarily disabled (with no success).

Screen captures are attached.

Does anyone know what is causing this issue and how to fix it?

Thanks in advance.

On 5/3/19 Firefox suddenly alerted me that it disabled all of my Add-ons stating that "These extensions do not meet current Firefox standards so they have been deactivated." Immediately below this message, Firefox gives me the option to "Find a Replacement" Add-on. After going through this process and locating the replacement Add-on, all attempts to download this (or any other Add-on) produce an error message stating "Download failed. Please check your connection." However, my internet connection is working just fine. I am running the latest version of Firefox (66.0.3 (64-bit)). And I have tried downloading the Add-on with my anti-virus temporarily disabled (with no success). Screen captures are attached. Does anyone know what is causing this issue and how to fix it? Thanks in advance.
Attached screenshots

Chosen solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

EcoResolve 0 solutions 5 answers

I am using a 32bit version of Window 7pro on a 64bit system and running a 32bit version on Firefox on this system.

Up until today I have had no problems with add0ons and extensions with Firefox, and now its just another trash laden experience.

I've also noticed the new updates chance my settings which I do not feel Firefox should do.

I've never used any Google or Microsoft browser, did use Opera for a while, and probably have used Firefox for over fifteen years.

Perhaps it time to go back to subscribing to a reliable browser like Opera that's not randomly changed by a heard of cats...

I am using a 32bit version of Window 7pro on a 64bit system and running a 32bit version on Firefox on this system. Up until today I have had no problems with add0ons and extensions with Firefox, and now its just another trash laden experience. I've also noticed the new updates chance my settings which I do not feel Firefox should do. I've never used any Google or Microsoft browser, did use Opera for a while, and probably have used Firefox for over fifteen years. Perhaps it time to go back to subscribing to a reliable browser like Opera that's not randomly changed by a heard of cats...
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 157978 answers

There is a hotfix released for the issue about an expired intermediate certificate that caused extensions to get disabled that is currently applied via a shield study and you only get this hotfix when studies are enabled.

See also:


You can temporarily set app.normandy.run_interval_seconds to a lower value (21600 => 10) to see whether that gives the hotfix.

Close and restart Firefox and check about:studies.

  • hotfix-update-xpi-signing-intermediate-bug-1548973
  • hotfix-reset-xpi-verification-timestamp-1548973

Do NOT forget to reset app.normandy.run_interval_seconds once about:studies shows that the hotfix has been applied.

You may have to refresh the about:studies page a few times.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

There is a hotfix released for the issue about an expired intermediate certificate that caused extensions to get disabled that is currently applied via a shield study and you only get this hotfix when studies are enabled. See also: *https://support.mozilla.org/en-US/kb/add-ons-disabled-or-fail-to-install-firefox *https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/ ---- You can temporarily set <b>app.normandy.run_interval_seconds</b> to a lower value (21600 => 10) to see whether that gives the hotfix. Close and restart Firefox and check <b>about:studies</b>. *hotfix-update-xpi-signing-intermediate-bug-1548973 *hotfix-reset-xpi-verification-timestamp-1548973 Do NOT forget to reset <b>app.normandy.run_interval_seconds</b> once <b>about:studies</b> shows that the hotfix has been applied. You may have to refresh the about:studies page a few times. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
Was this helpful to you?
Quote
Avengement 1 solutions 63 answers

jscher2000 said

Hi Smith299, I don't know why that page is blank for you. Another user's checkbox doesn't seem to work, so the setting needed to be changed manually: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste shield and pause while the list is filtered (3) If the app.shield.optoutstudies.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true If this preference indicates that it is Locked, then an external configuration file is overriding your ability to change this setting. That might be something an IT department installed if this is a work PC.

If all else fails:

The study loads an extension. There is an unofficial link to the extension a comment on the Add-ons blog here. I have not tried it myself, but the link matches what I expect it to be:

https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/comment-page-6/#comment-226171


The hotfix extension did absolutely nothing for me after being installed.

The add-on that became disabled during this mess still is with no option to "enable" it.

When I try to reinstall said add-on I'm still receiving a red "check your connection" warning and it does not download...

''jscher2000 [[#answer-1218615|said]]'' <blockquote> Hi Smith299, I don't know why that page is blank for you. Another user's checkbox doesn't seem to work, so the setting needed to be changed manually: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''shield''' and pause while the list is filtered (3) If the '''app.shield.optoutstudies.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true If this preference indicates that it is Locked, then an external configuration file is overriding your ability to change this setting. That might be something an IT department installed if this is a work PC. ---- ''If all else fails:'' The study loads an extension. There is an unofficial link to the extension a comment on the Add-ons blog here. I have not tried it myself, but the link matches what I expect it to be: https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/comment-page-6/#comment-226171 </blockquote> The hotfix extension did absolutely nothing for me after being installed. The add-on that became disabled during this mess still is with no option to "enable" it. When I try to reinstall said add-on I'm still receiving a red "check your connection" warning and it does not download...

Modified by Avengement

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8700 solutions 71111 answers

IloxRD said

On 5/3/19 Firefox suddenly alerted me that it disabled all of my Add-ons stating that "These extensions do not meet current Firefox standards so they have been deactivated."

Hi IloxRD, has this issue been resolved on your Firefox by now? The hotfix to install a new certificate should run fine on Firefox 66, and if studies are enabled, you should have received it within six hours. The certificate should show up here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type cert and Firefox should filter to the Certificates section. Then click the "View Certificates" button. Check the "Authorities" tab to see whether Mozilla is listed with the new certificate. You can compare the attached screenshot.

If the certificate is missing:

Unfortunately, the hotfix was not successful and we will need to provide further steps to install the certificate, or await further updates from the Add-ons team.

If the certificate was installed but installed extensions still show as unverified and/or new extensions can't be installed because they are corrupted:

It sounds as though the hotfix didn't successfully trigger immediate re-verification. To trigger a re-verification sooner than the usual "every 24 hours," you can use this method to clear the time stamp for the last time Firefox last re-verified.

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste xpi- and pause while the list is filtered

(C) Right-click the app.update.lastUpdateTime.xpi-signature-verification preference and click Reset on the context menu -- the numeric value will disappear and the preference will say it is now a "string".

The next time you exit and restart Firefox, the re-verification should be performed within about a minute.

Success?

''IloxRD [[#question-1257901|said]]'' <blockquote> On 5/3/19 Firefox suddenly alerted me that it disabled all of my Add-ons stating that "These extensions do not meet current Firefox standards so they have been deactivated." </blockquote> Hi IloxRD, has this issue been resolved on your Firefox by now? The hotfix to install a new certificate should run fine on Firefox 66, and if studies are enabled, you should have received it within six hours. The certificate should show up here: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''cert'' and Firefox should filter to the '''Certificates''' section. Then click the "View Certificates" button. Check the "Authorities" tab to see whether Mozilla is listed with the new certificate. You can compare the attached screenshot. ''If the certificate is missing:'' Unfortunately, the hotfix was not successful and we will need to provide further steps to install the certificate, or await further updates from the Add-ons team. ''If the certificate was installed but installed extensions still show as unverified and/or new extensions can't be installed because they are corrupted:'' It sounds as though the hotfix didn't successfully trigger immediate re-verification. To trigger a re-verification sooner than the usual "every 24 hours," you can use this method to clear the time stamp for the last time Firefox last re-verified. (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (B) In the search box above the list, type or paste '''xpi-''' and pause while the list is filtered (C) Right-click the '''app.update.lastUpdateTime.xpi-signature-verification''' preference and click Reset on the context menu -- the numeric value will disappear and the preference will say it is now a "string". The next time you exit and restart Firefox, the re-verification should be performed within about a minute. Success?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8700 solutions 71111 answers

EcoResolve said

I've also noticed the new updates chance my settings which I do not feel Firefox should do.

Hi EcoResolve, could you start a new thread about settings changes? As you know, suggestions may be displayed during the new question flow. Keep scrolling down to continue with the form.

https://support.mozilla.org/questions/new/desktop/fix-problems

''EcoResolve [[#answer-1218785|said]]'' <blockquote> I've also noticed the new updates chance my settings which I do not feel Firefox should do. </blockquote> Hi EcoResolve, could you start a new thread about settings changes? As you know, suggestions may be displayed during the new question flow. Keep scrolling down to continue with the form. https://support.mozilla.org/questions/new/desktop/fix-problems
Was this helpful to you?
Quote
Avengement 1 solutions 63 answers

jscher2000 said

IloxRD said
On 5/3/19 Firefox suddenly alerted me that it disabled all of my Add-ons stating that "These extensions do not meet current Firefox standards so they have been deactivated."

Hi IloxRD, has this issue been resolved on your Firefox by now? The hotfix to install a new certificate should run fine on Firefox 66, and if studies are enabled, you should have received it within six hours. The certificate should show up here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type cert and Firefox should filter to the Certificates section. Then click the "View Certificates" button. Check the "Authorities" tab to see whether Mozilla is listed with the new certificate. You can compare the attached screenshot.

If the certificate is missing:

Unfortunately, the hotfix was not successful and we will need to provide further steps to install the certificate, or await further updates from the Add-ons team.

If the certificate was installed but installed extensions still show as unverified and/or new extensions can't be installed because they are corrupted:

It sounds as though the hotfix didn't successfully trigger immediate re-verification. To trigger a re-verification sooner than the usual "every 24 hours," you can use this method to clear the time stamp for the last time Firefox last re-verified.

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste xpi- and pause while the list is filtered

(C) Right-click the app.update.lastUpdateTime.xpi-signature-verification preference and click Reset on the context menu -- the numeric value will disappear and the preference will say it is now a "string".

The next time you exit and restart Firefox, the re-verification should be performed within about a minute.

Success?

Why don't the developers just upload the certificate to a file host so that we can manually download and import it ourselves?

This seems like a rather backward and way more complicated "process" then necessary...

[Profanity removed by moderator. Please read Forum rules and guidelines, thanks.]

''jscher2000 [[#answer-1219374|said]]'' <blockquote> ''IloxRD [[#question-1257901|said]]'' <blockquote> On 5/3/19 Firefox suddenly alerted me that it disabled all of my Add-ons stating that "These extensions do not meet current Firefox standards so they have been deactivated." </blockquote> Hi IloxRD, has this issue been resolved on your Firefox by now? The hotfix to install a new certificate should run fine on Firefox 66, and if studies are enabled, you should have received it within six hours. The certificate should show up here: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''cert'' and Firefox should filter to the '''Certificates''' section. Then click the "View Certificates" button. Check the "Authorities" tab to see whether Mozilla is listed with the new certificate. You can compare the attached screenshot. ''If the certificate is missing:'' Unfortunately, the hotfix was not successful and we will need to provide further steps to install the certificate, or await further updates from the Add-ons team. ''If the certificate was installed but installed extensions still show as unverified and/or new extensions can't be installed because they are corrupted:'' It sounds as though the hotfix didn't successfully trigger immediate re-verification. To trigger a re-verification sooner than the usual "every 24 hours," you can use this method to clear the time stamp for the last time Firefox last re-verified. (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (B) In the search box above the list, type or paste '''xpi-''' and pause while the list is filtered (C) Right-click the '''app.update.lastUpdateTime.xpi-signature-verification''' preference and click Reset on the context menu -- the numeric value will disappear and the preference will say it is now a "string". The next time you exit and restart Firefox, the re-verification should be performed within about a minute. Success? </blockquote> Why <!-- the hell -->don't the developers just upload the certificate to a file host so that we can manually download and import it ourselves? This seems like a rather <!-- ass -->backward and way more complicated "process" then necessary... ''[Profanity removed by moderator. Please read [[Forum rules and guidelines]], thanks.]''

Modified by Chris Ilias

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8700 solutions 71111 answers

Avengement said

Why don't the developers just upload the certificate to a file host so that we can manually download and import it ourselves?

Your guess is as good as mine. At this time, the developers are busy testing Firefox 66.0.4 for release today/tonight. If you do not want to use an unofficial source, please wait.

''Avengement [[#answer-1219458|said]]'' <blockquote> Why don't the developers just upload the certificate to a file host so that we can manually download and import it ourselves? </blockquote> Your guess is as good as mine. At this time, the developers are busy testing Firefox 66.0.4 for release today/tonight. If you do not want to use an unofficial source, please wait.

Modified by jscher2000

Was this helpful to you?
Quote
icemandave 0 solutions 11 answers

Thanks for fixing it so quickly, guys. I really appreciate it. I was able to re-download my themes and u-Block last night.

Thanks for fixing it so quickly, guys. I really appreciate it. I was able to re-download my themes and u-Block last night.
Was this helpful to you?
Quote
Ottomatic 0 solutions 2 answers

Firefox's stupid fake error message blaming me for a "connection" problem when they knew all along that it was their issue and their fault in addition to deleting every one of my add-ons was the final straw. After 17 years with FF I'm done with them. Good luck retaining your dismal 9% browser market share.

Firefox's stupid fake error message blaming me for a "connection" problem when they knew all along that it was their issue and their fault in addition to deleting every one of my add-ons was the final straw. After 17 years with FF I'm done with them. Good luck retaining your dismal 9% browser market share.
Was this helpful to you? 0
Quote
Pj 42 solutions 869 answers

Ottomatic said

Firefox's stupid fake error message blaming me for a "connection" problem when they knew all along that it was their issue and their fault in addition to deleting every one of my add-ons was the final straw. After 17 years with FF I'm done with them. Good luck retaining your dismal 9% browser market share.

There was a Bug-A-Boo with a Certificate Expiration Date dealing with the Add-ons. There's a new FF Version with the main Fix, 66.0.4.

Mozilla Blog Post Update:
A Firefox release has been pushed — version 66.0.4 on Desktop and Android, and version 60.6.2 for ESR. This release repairs the certificate chain to re-enable web extensions, themes, search engines, and language packs that had been disabled (Bug 1549061).
There are remaining issues that we are actively working to resolve, but we wanted to get this fix out before Monday to lessen the impact of disabled add-ons before the start of the week. More information about the remaining issues can be found by clicking on the links to the release notes above.
(May 5, 16:25 EDT)


~Pj

''Ottomatic [[#answer-1219559|said]]'' <blockquote> Firefox's stupid fake error message blaming me for a "connection" problem when they knew all along that it was their issue and their fault in addition to deleting every one of my add-ons was the final straw. After 17 years with FF I'm done with them. Good luck retaining your dismal 9% browser market share. </blockquote> There was a Bug-A-Boo with a Certificate Expiration Date dealing with the Add-ons. There's a new FF Version with the main Fix, '''66.0.4'''. <Br> <Br> [https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/ Mozilla Blog Post Update]: <Br> <B>A Firefox release has been pushed — version 66.0.4 on Desktop and Android, and version 60.6.2 for ESR. This release repairs the certificate chain to re-enable web extensions, themes, search engines, and language packs that had been disabled (Bug 1549061).<Br> There are remaining issues that we are actively working to resolve, but we wanted to get this fix out before Monday to lessen the impact of disabled add-ons before the start of the week. More information about the remaining issues can be found by clicking on the links to the release notes above. <Br> (May 5, 16:25 EDT)</B> ~Pj
Was this helpful to you?
Quote
Avengement 1 solutions 63 answers

Pj said

Ottomatic said
Firefox's stupid fake error message blaming me for a "connection" problem when they knew all along that it was their issue and their fault in addition to deleting every one of my add-ons was the final straw. After 17 years with FF I'm done with them. Good luck retaining your dismal 9% browser market share.

There was a Bug-A-Boo with a Certificate Expiration Date dealing with the Add-ons. There's a new FF Version with the main Fix, 66.0.4.

Mozilla Blog Post Update:
A Firefox release has been pushed — version 66.0.4 on Desktop and Android, and version 60.6.2 for ESR. This release repairs the certificate chain to re-enable web extensions, themes, search engines, and language packs that had been disabled (Bug 1549061).
There are remaining issues that we are actively working to resolve, but we wanted to get this fix out before Monday to lessen the impact of disabled add-ons before the start of the week. More information about the remaining issues can be found by clicking on the links to the release notes above.
(May 5, 16:25 EDT)


~Pj


No one with this problem cares about a new version especially if we were not planning to update to it. What this indicates to anyone with basic logical ability is a forced update similar to what microshaft does with windows.

I'm extremely disappointed that despite manually removing all of the url's from under the hood and unticking the "Query OCSP responder servers to confirm the current validity of certificates" box that this asinine "mistake" still took place and my browser is still calling home to some mozilla server for certificate validation and who knows what else. This is a significant breach of privacy to which mozilla has lost significant trust.

Two days later and there's still no real solution and when asking a very knowledgeable "top 10 contributor" about what url is calling home so that I can forcefully block it via firewall since the firefox options are obviously just for decoration and don't actually function or flat out ignore user input, the answer I received is that he "didn't know".

This is disgusting behavior from mozilla devs and more importantly shows a complete lack of ethics and understanding of the open source community. Firefox is becoming a tire fire resembling chrome more then the principles it was once founded on.

Just make the certificate public so we can import it ourselves. Problem solved and it would have only taken a matter of minutes.

''Pj [[#answer-1219777|said]]'' <blockquote> ''Ottomatic [[#answer-1219559|said]]'' <blockquote> Firefox's stupid fake error message blaming me for a "connection" problem when they knew all along that it was their issue and their fault in addition to deleting every one of my add-ons was the final straw. After 17 years with FF I'm done with them. Good luck retaining your dismal 9% browser market share. </blockquote> There was a Bug-A-Boo with a Certificate Expiration Date dealing with the Add-ons. There's a new FF Version with the main Fix, '''66.0.4'''. <Br> <Br> [https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/ Mozilla Blog Post Update]: <Br> <B>A Firefox release has been pushed — version 66.0.4 on Desktop and Android, and version 60.6.2 for ESR. This release repairs the certificate chain to re-enable web extensions, themes, search engines, and language packs that had been disabled (Bug 1549061).<Br> There are remaining issues that we are actively working to resolve, but we wanted to get this fix out before Monday to lessen the impact of disabled add-ons before the start of the week. More information about the remaining issues can be found by clicking on the links to the release notes above. <Br> (May 5, 16:25 EDT)</B> ~Pj </blockquote> No one with this problem cares about a new version especially if we were not planning to update to it. What this indicates to anyone with basic logical ability is a forced update similar to what microshaft does with windows. I'm extremely disappointed that despite manually removing all of the url's from under the hood and unticking the "Query OCSP responder servers to confirm the current validity of certificates" box that this asinine "mistake" still took place and my browser is still calling home to some mozilla server for certificate validation and who knows what else. This is a significant breach of privacy to which mozilla has lost significant trust. Two days later and there's still no real solution and when asking a very knowledgeable "top 10 contributor" about what url is calling home so that I can forcefully block it via firewall since the firefox options are obviously just for decoration and don't actually function or flat out ignore user input, the answer I received is that he "didn't know". This is disgusting behavior from mozilla devs and more importantly shows a complete lack of ethics and understanding of the open source community. Firefox is becoming a tire fire resembling chrome more then the principles it was once founded on. Just make the certificate public so we can import it ourselves. Problem solved and it would have only taken a matter of minutes.
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
8700 solutions 71111 answers

Avengement said

Just make the certificate public so we can import it ourselves.

See line 1884 of the following source code file for Firefox 66.0.4:

https://dxr.mozilla.org/mozilla-release/source/toolkit/mozapps/extensions/internal/XPIProvider.jsm#1883

The part within (but not including) the quotation marks needs to be saved to a .crt file and then you can import it.

Most such files seem to have a set number of characters per line, but I don't know whether that is critical or you can just import it as one long line. If you try it, let us know.

''Avengement [[#answer-1219843|said]]'' <blockquote> Just make the certificate public so we can import it ourselves. </blockquote> See line 1884 of the following source code file for Firefox 66.0.4: https://dxr.mozilla.org/mozilla-release/source/toolkit/mozapps/extensions/internal/XPIProvider.jsm#1883 The part within (but not including) the quotation marks needs to be saved to a .crt file and then you can import it. Most such files seem to have a set number of characters per line, but I don't know whether that is critical or you can just import it as one long line. If you try it, let us know.
Was this helpful to you?
Quote
Avengement 1 solutions 63 answers

jscher2000 said

Avengement said
Just make the certificate public so we can import it ourselves.

See line 1884 of the following source code file for Firefox 66.0.4:

https://dxr.mozilla.org/mozilla-release/source/toolkit/mozapps/extensions/internal/XPIProvider.jsm#1883

The part within (but not including) the quotation marks needs to be saved to a .crt file and then you can import it.

Most such files seem to have a set number of characters per line, but I don't know whether that is critical or you can just import it as one long line. If you try it, let us know.

I tried importing it as one long line and no dice.

I would section it into seperate lines but I have no idea where the breaks need to be.

''jscher2000 [[#answer-1219847|said]]'' <blockquote> ''Avengement [[#answer-1219843|said]]'' <blockquote> Just make the certificate public so we can import it ourselves. </blockquote> See line 1884 of the following source code file for Firefox 66.0.4: https://dxr.mozilla.org/mozilla-release/source/toolkit/mozapps/extensions/internal/XPIProvider.jsm#1883 The part within (but not including) the quotation marks needs to be saved to a .crt file and then you can import it. Most such files seem to have a set number of characters per line, but I don't know whether that is critical or you can just import it as one long line. If you try it, let us know. </blockquote> I tried importing it as one long line and no dice. I would section it into seperate lines but I have no idea where the breaks need to be.
Was this helpful to you?
Quote
EcoResolve 0 solutions 5 answers

Well I had problems, but after I installed/updated version 66.0.4 (32bit) to my puter Ghostery with all my setting reappeared, as did HTTPS Everywhere, and then as a loyal, paid user of Malwarebytes, I added the Malwarebytes Browser Extension cuz one can never bee too safe in the web-world these days.

Thanks to all who worked on the reasonaly quick effort(s) to corrent unintended problems!

j.p.

Well I had problems, but after I installed/updated version 66.0.4 (32bit) to my puter Ghostery with all my setting reappeared, as did HTTPS Everywhere, and then as a loyal, paid user of Malwarebytes, I added the Malwarebytes Browser Extension cuz one can never bee too safe in the web-world these days. Thanks to all who worked on the reasonaly quick effort(s) to corrent unintended problems! j.p.
Was this helpful to you?
Quote
Avengement 1 solutions 63 answers

EcoResolve said

Well I had problems, but after I installed/updated version 66.0.4 (32bit) to my puter Ghostery with all my setting reappeared, as did HTTPS Everywhere, and then as a loyal, paid user of Malwarebytes, I added the Malwarebytes Browser Extension cuz one can never bee too safe in the web-world these days. Thanks to all who worked on the reasonaly quick effort(s) to corrent unintended problems! j.p.

This problem caused by ineptitude is not at all solved. Updating to a new version is not a proper solution for those of us that always wait for bugs to be worked out of a new browser version before deploying on large scale. I am not a beta tester and quite frankly have no incentive to ever be.



The certificate has still not been made available to be imported and solve the problem with versions that aren't 66.

Why?

''EcoResolve [[#answer-1220126|said]]'' <blockquote> Well I had problems, but after I installed/updated version 66.0.4 (32bit) to my puter Ghostery with all my setting reappeared, as did HTTPS Everywhere, and then as a loyal, paid user of Malwarebytes, I added the Malwarebytes Browser Extension cuz one can never bee too safe in the web-world these days. Thanks to all who worked on the reasonaly quick effort(s) to corrent unintended problems! j.p. </blockquote> This problem caused by ineptitude is not at all solved. Updating to a new version is not a proper solution for those of us that always wait for bugs to be worked out of a new browser version before deploying on large scale. I am not a beta tester and quite frankly have no incentive to ever be. The certificate has still not been made available to be imported and solve the problem with versions that aren't 66. Why?
Was this helpful to you?
Quote
Avengement 1 solutions 63 answers

And of course there's crickets...

And of course there's crickets...
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8700 solutions 71111 answers

Avengement said

And of course there's crickets...

Chirp! Click! The legacy extension for Firefox 52-60 has been submitted to QA. Click! Chirp!

''Avengement [[#answer-1220821|said]]'' <blockquote> And of course there's crickets... </blockquote> Chirp! Click! ''The legacy extension for Firefox 52-60 has been submitted to QA.'' Click! Chirp!
Was this helpful to you?
Quote
اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.