X
Tap here to go to the mobile version of the site.

منتدى الدعم

Firefox disabled all Add-ons. Attempting to download replacement Add-ons returns "Download failed. Please check your connection." error message.

Posted

On 5/3/19 Firefox suddenly alerted me that it disabled all of my Add-ons stating that "These extensions do not meet current Firefox standards so they have been deactivated."

Immediately below this message, Firefox gives me the option to "Find a Replacement" Add-on.

After going through this process and locating the replacement Add-on, all attempts to download this (or any other Add-on) produce an error message stating "Download failed. Please check your connection."

However, my internet connection is working just fine.

I am running the latest version of Firefox (66.0.3 (64-bit)). And I have tried downloading the Add-on with my anti-virus temporarily disabled (with no success).

Screen captures are attached.

Does anyone know what is causing this issue and how to fix it?

Thanks in advance.

On 5/3/19 Firefox suddenly alerted me that it disabled all of my Add-ons stating that "These extensions do not meet current Firefox standards so they have been deactivated." Immediately below this message, Firefox gives me the option to "Find a Replacement" Add-on. After going through this process and locating the replacement Add-on, all attempts to download this (or any other Add-on) produce an error message stating "Download failed. Please check your connection." However, my internet connection is working just fine. I am running the latest version of Firefox (66.0.3 (64-bit)). And I have tried downloading the Add-on with my anti-virus temporarily disabled (with no success). Screen captures are attached. Does anyone know what is causing this issue and how to fix it? Thanks in advance.
Attached screenshots

Chosen solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Hi Avengement, this is not related to updates. A critical Add-on-related certificate expired (which obviously should not happen). As a result, all verifications for that certificate are failing, which prevents the affected extensions from running, updating, or installing.

As noted earlier in this thread, the Add-ons team is working on a fix for this. Official updates are expected to be posted here: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047

Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal.

Hi Avengement, this is not related to updates. A critical Add-on-related certificate expired (which obviously should not happen). As a result, all verifications for that certificate are failing, which prevents the affected extensions from running, updating, or installing. As noted earlier in this thread, the Add-ons team is working on a fix for this. Official updates are expected to be posted here: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal.
Was this helpful to you?
Quote
Lyghtkeepr 0 solutions 2 answers

I also have this problem. They disabled all the add ons without notice. And now, I can't download any add ons at all. They need to fix this ASAP.

'''I also have this problem. They disabled all the add ons without notice. And now, I can't download any add ons at all. They need to fix this ASAP.'''
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Lyghtkeepr said

I also have this problem. They disabled all the add ons without notice. And now, I can't download any add ons at all. They need to fix this ASAP.

The Add-ons team is working on a fix for this. Official updates are expected to be posted here:

https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047

Check out other posts in this thread for more information.

''Lyghtkeepr [[#answer-1218215|said]]'' <blockquote> '''I also have this problem. They disabled all the add ons without notice. And now, I can't download any add ons at all. They need to fix this ASAP.''' </blockquote> The Add-ons team is working on a fix for this. Official updates are expected to be posted here: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 Check out other posts in [https://support.mozilla.org/en-US/questions/1257901?page=2 this thread] for more information.
Was this helpful to you?
Quote
DesertScorpion 0 solutions 1 answers

I can report that the about:config fix of disabling autoupdates did not stop them from being disabled. They were uninstalled as I was typing this comment.


wmbos said

This is a serious problem and Mozilla is famously unresponsive. I guess it is finally time to say goodbye to this crippled browser and move on to one where there is actual support and these kinds of stupid mistakes don't happen. I've wasted too much time over the years to remain a fan of this sad company.

Stop spreading misinformation. This is completely dishonest. They have responded before you even posted here. You clearly didn't bother looking. Rather than jumping ship immediately, helping them fix the problem. This would benefit both you and the community.


Mozilla Add-ons @mozamo said:

We’re investigating an issue with a certificate which may cause your @firefox extensions to stop work working or fail to install. Our team is actively working to fix the issue and we’ll post more information shortly.

caitmuenster (Caitlin Neiman) said:

At about 6:10 PST we received a report that a certificate issue for Firefox is causing add-ons to stop working and add-on installs to fail. Our team is actively working on a fix. We will update as soon as we have more information.

Updates will probably be found @mozamo

I can report that the about:config fix of disabling autoupdates did not stop them from being disabled. They were uninstalled as I was typing this comment. ''wmbos [[#answer-1218110|said]]'' <blockquote> This is a serious problem and Mozilla is famously unresponsive. I guess it is finally time to say goodbye to this crippled browser and move on to one where there is actual support and these kinds of stupid mistakes don't happen. I've wasted too much time over the years to remain a fan of this sad company. </blockquote> Stop spreading misinformation. This is completely dishonest. They have responded before you even posted here. You clearly didn't bother looking. Rather than jumping ship immediately, helping them fix the problem. This would benefit both you and the community. ''Mozilla Add-ons @mozamo [https://twitter.com/mozamo/status/1124513193030586368 said:]'' <blockquote> We’re investigating an issue with a certificate which may cause your @firefox extensions to stop work working or fail to install. Our team is actively working to fix the issue and we’ll post more information shortly. </blockquote> ''caitmuenster (Caitlin Neiman) [https://discourse.mozilla.org/t/39047 said:]'' <blockquote> At about 6:10 PST we received a report that a certificate issue for Firefox is causing add-ons to stop working and add-on installs to fail. Our team is actively working on a fix. We will update as soon as we have more information. </blockquote> ------------- Updates will probably be found [https://twitter.com/mozamo @mozamo]
Was this helpful to you? 0
Quote
janeku 0 solutions 1 answers

Same problemher today, 4th of May 2019. Already posted a question because I did not have any option for signing tothis site except to post new one and make registration with it. For me this security issue is very serious. It may affect lot of bank add-ons and extensions for online e-banking works and other things.

Same problemher today, 4th of May 2019. Already posted a question because I did not have any option for signing tothis site except to post new one and make registration with it. For me this security issue is very serious. It may affect lot of bank add-ons and extensions for online e-banking works and other things.
Was this helpful to you?
Quote
Avengement 1 solutions 63 answers

jscher2000 said

Hi Avengement, this is not related to updates. A critical Add-on-related certificate expired (which obviously should not happen). As a result, all verifications for that certificate are failing, which prevents the affected extensions from running, updating, or installing. As noted earlier in this thread, the Add-ons team is working on a fix for this. Official updates are expected to be posted here: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal.

So what setting is calling home to a mozilla server to verify if the certificate is valid or not?

I should also mention that I have deleted all the URL's in the "about:config" menu as well so this should not be happening on my end.

''jscher2000 [[#answer-1218179|said]]'' <blockquote> Hi Avengement, this is not related to updates. A critical Add-on-related certificate expired (which obviously should not happen). As a result, all verifications for that certificate are failing, which prevents the affected extensions from running, updating, or installing. As noted earlier in this thread, the Add-ons team is working on a fix for this. Official updates are expected to be posted here: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so I understand this option isn't ideal. </blockquote> So what setting is calling home to a mozilla server to verify if the certificate is valid or not? I should also mention that I have deleted all the URL's in the "about:config" menu as well so this should not be happening on my end.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Hi Avengement, I don't know the URL, but the time of the last verification check is stored in this preference:

app.update.lastUpdateTime.xpi-signature-verification

It's a Unix Epoch; this page has a converter: https://www.epochconverter.com/

There was some speculation that updating the date would prevent Firefox from checking, but that didn't work in my test.

Hi Avengement, I don't know the URL, but the time of the last verification check is stored in this preference: app.update.lastUpdateTime.xpi-signature-verification It's a Unix Epoch; this page has a converter: https://www.epochconverter.com/ There was some speculation that updating the date would prevent Firefox from checking, but that didn't work in my test.
Was this helpful to you?
Quote
wmbos 0 solutions 6 answers

Before I was angry, now I am upset: I am having to re-register for, it seems, every site that I used Firefox to access, from social media to banks and credit cards and all my business contacts. EVERYTHING has gone. What the hell is happening and why isn't it fixed already? This is not misinformation. I have no information since no one gets in touch from Firefox to warn about this or explain what is happening. I get better service from my public utilities!

Before I was angry, now I am upset: I am having to re-register for, it seems, every site that I used Firefox to access, from social media to banks and credit cards and all my business contacts. EVERYTHING has gone. What the hell is happening and why isn't it fixed already? This is not misinformation. I have no information since no one gets in touch from Firefox to warn about this or explain what is happening. I get better service from my public utilities!
Was this helpful to you?
Quote
James
  • Moderator
1596 solutions 11246 answers

Mozilla IS informing people as you can see on top of say support.mozilla.org and bugzilla.mozilla.org for example.

Firefox is not a company as it is the name of the web browsers that the company Mozilla makes for desktop and mobile.


from https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047

11:12 p.m. PST: The team is currently testing a fix for this issue. In the meantime, signing of new extensions is disabled until the fix is in place.
Mozilla IS informing people as you can see on top of say support.mozilla.org and bugzilla.mozilla.org for example. Firefox is not a company as it is the name of the web browsers that the company '''Mozilla''' makes for desktop and mobile. from https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 <blockquote>11:12 p.m. PST: The team is currently testing a fix for this issue. In the meantime, signing of new extensions is disabled until the fix is in place.</blockquote>
Was this helpful to you? 0
Quote
Chris Ilias
  • Moderator
354 solutions 1943 answers

Chosen Solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.
Was this helpful to you?
Quote
SteveLamberts 0 solutions 4 answers

Can someone tell Mozilla I am getting fed up with Firefox. I decided on Firefox right at the beginning and selected Firefox due to speed and add-ons. Over time, the browser basic functionality has become worse and worse as more functions were added. Now I can't use it for what I want due to yet another "update". Come on Mozilla!

Can someone tell Mozilla I am getting fed up with Firefox. I decided on Firefox right at the beginning and selected Firefox due to speed and add-ons. Over time, the browser basic functionality has become worse and worse as more functions were added. Now I can't use it for what I want due to yet another "update". Come on Mozilla!
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Hi SteveLamberts, add-ons becoming disabled was not due to an update, but a critical certificate expiring causing many (most?) extensions to fail verification. Obviously that should not happen, but here in support we are helping clean up the mess, not managing the Add-ons team.

In case you missed the reply above yours from Chris Ilias:

Over the next few hours, your Firefox should automatically get a patch for this problem through the "studies" feature. For most users, studies are automatically enabled, but you can check on the Options/Preferences page as follows:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type stud and Firefox should filter to the "Firefox Data Collection and Use" section. Here, make sure you have a check in the box for "Allow Firefox to install and run studies". (First screenshot attached.) If you prefer to turn it back off after the patch comes through, that's fine.

So far, I have received two studies related to this, which you can see if you click the View Firefox studies link next to the above preference (or paste about:studies into the address bar and press Enter to load it). (Second screenshot attached.)

If you receive the patches and your extensions remain disabled, check whether they now show an Enable button.

Hi SteveLamberts, add-ons becoming disabled was not due to an update, but a critical certificate expiring causing many (most?) extensions to fail verification. Obviously that should not happen, but here in support we are helping clean up the mess, not managing the Add-ons team. In case you missed the reply above yours from Chris Ilias: Over the next few hours, your Firefox should automatically get a patch for this problem through the "studies" feature. For most users, studies are automatically enabled, but you can check on the Options/Preferences page as follows: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''stud'' and Firefox should filter to the "Firefox Data Collection and Use" section. Here, make sure you have a check in the box for "Allow Firefox to install and run studies". (First screenshot attached.) If you prefer to turn it back off after the patch comes through, that's fine. So far, I have received two studies related to this, which you can see if you click the '''View Firefox studies''' link next to the above preference (or paste '''about:studies''' into the address bar and press Enter to load it). (Second screenshot attached.) If you receive the patches and your extensions remain disabled, check whether they now show an Enable button.
Was this helpful to you?
Quote
Smith299 0 solutions 7 answers

jscher2000 said

Hi SteveLamberts, add-ons becoming disabled was not due to an update, but a critical certificate expiring causing many (most?) extensions to fail verification. Obviously that should not happen, but here in support we are helping clean up the mess, not managing the Add-ons team. In case you missed the reply above yours from Chris Ilias: Over the next few hours, your Firefox should automatically get a patch for this problem through the "studies" feature.

I've enabled Studies. Is there a way to manually trigger the update to occur right away instead of having to wait up to six hours?

''jscher2000 [[#answer-1218573|said]]'' <blockquote> Hi SteveLamberts, add-ons becoming disabled was not due to an update, but a critical certificate expiring causing many (most?) extensions to fail verification. Obviously that should not happen, but here in support we are helping clean up the mess, not managing the Add-ons team. In case you missed the reply above yours from Chris Ilias: Over the next few hours, your Firefox should automatically get a patch for this problem through the "studies" feature. </blockquote> I've enabled Studies. Is there a way to manually trigger the update to occur right away instead of having to wait up to six hours?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Hi Smith299, I don't know whether this will work, but you could try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste normandy and pause while the list is filtered

(3) Double-click the app.normandy.run_interval_seconds preference to display a dialog where you can edit the default value of 21600 (6 hours) to 300 (5 minutes) and then click OK

I don't know how soon Firefox will get around to checking again. Exiting and re-starting Firefox might help.

If you do shorten that interval, I suggest changing it back later to avoid unnecessary background traffic.

Hi Smith299, I don't know whether this will work, but you could try: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''normandy''' and pause while the list is filtered (3) Double-click the '''app.normandy.run_interval_seconds''' preference to display a dialog where you can edit the default value of 21600 ''(6 hours)'' to 300 ''(5 minutes)'' and then click OK I don't know how soon Firefox will get around to checking again. Exiting and re-starting Firefox might help. If you do shorten that interval, I suggest changing it back later to avoid unnecessary background traffic.
Was this helpful to you?
Quote
Smith299 0 solutions 7 answers

jscher2000 said

Hi Smith299, I don't know whether this will work, but you could try: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste normandy and pause while the list is filtered (3) Double-click the app.normandy.run_interval_seconds preference to display a dialog where you can edit the default value of 21600 (6 hours) to 300 (5 minutes) and then click OK I don't know how soon Firefox will get around to checking again. Exiting and re-starting Firefox might help. If you do shorten that interval, I suggest changing it back later to avoid unnecessary background traffic.

I changed that setting to 300 at 11:58am and it's been about 40 minutes. I then followed the Mozilla blog post suggestion and entered "about:studies" into the address bar.

That brings up a blank page. I checked the add-ons page and all the add-ons are still disabled.

Thanks for the suggestion, it was a reasonable attempt. But it doesn't seem to speed up the Studies update process.

''jscher2000 [[#answer-1218581|said]]'' <blockquote> Hi Smith299, I don't know whether this will work, but you could try: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''normandy''' and pause while the list is filtered (3) Double-click the '''app.normandy.run_interval_seconds''' preference to display a dialog where you can edit the default value of 21600 ''(6 hours)'' to 300 ''(5 minutes)'' and then click OK I don't know how soon Firefox will get around to checking again. Exiting and re-starting Firefox might help. If you do shorten that interval, I suggest changing it back later to avoid unnecessary background traffic. </blockquote> I changed that setting to 300 at 11:58am and it's been about 40 minutes. I then followed the Mozilla blog post suggestion and entered "about:studies" into the address bar. That brings up a blank page. I checked the add-ons page and all the add-ons are still disabled. Thanks for the suggestion, it was a reasonable attempt. But it doesn't seem to speed up the Studies update process.
Was this helpful to you?
Quote
Chandan_Baba 35 solutions 369 answers
Please do a read on ongoing efforts here: https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Hi Smith299, I don't know why that page is blank for you. Another user's checkbox doesn't seem to work, so the setting needed to be changed manually:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste shield and pause while the list is filtered

(3) If the app.shield.optoutstudies.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

If this preference indicates that it is Locked, then an external configuration file is overriding your ability to change this setting. That might be something an IT department installed if this is a work PC.


If all else fails:

The study loads an extension. There is an unofficial link to the extension a comment on the Add-ons blog here. I have not tried it myself, but the link matches what I expect it to be:

https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/comment-page-6/#comment-226171

Hi Smith299, I don't know why that page is blank for you. Another user's checkbox doesn't seem to work, so the setting needed to be changed manually: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''shield''' and pause while the list is filtered (3) If the '''app.shield.optoutstudies.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true If this preference indicates that it is Locked, then an external configuration file is overriding your ability to change this setting. That might be something an IT department installed if this is a work PC. ---- ''If all else fails:'' The study loads an extension. There is an unofficial link to the extension a comment on the Add-ons blog here. I have not tried it myself, but the link matches what I expect it to be: https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/comment-page-6/#comment-226171
Was this helpful to you?
Quote
Smith299 0 solutions 7 answers

jscher2000 said

Hi Smith299, I don't know why that page is blank for you. Another user's checkbox doesn't seem to work, so the setting needed to be changed manually: (3) If the app.shield.optoutstudies.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

If all else fails:

The study loads an extension. There is an unofficial link to the extension a comment on the Add-ons blog here. I have not tried it myself, but the link matches what I expect it to be:

https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/comment-page-6/#comment-226171

That parameter app.shield.optoutstudies.enabled was set to "True".

OTOH that other "all else fails" option did work and instantly re-enabled all add-ons.

Thanks.

Edit:

BTW, I had to disable "Deceptive Content and Dangerous Software Protection" to allow that allegedly Mozilla signed update to install.

Curiously, after that update installed and add-ons were enabled, the "About:Studies" page is still blank.

''jscher2000 [[#answer-1218615|said]]'' <blockquote> Hi Smith299, I don't know why that page is blank for you. Another user's checkbox doesn't seem to work, so the setting needed to be changed manually: (3) If the '''app.shield.optoutstudies.enabled''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true ---- ''If all else fails:'' The study loads an extension. There is an unofficial link to the extension a comment on the Add-ons blog here. I have not tried it myself, but the link matches what I expect it to be: https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/comment-page-6/#comment-226171 </blockquote> That parameter ''app.shield.optoutstudies.enabled'' was set to "True". OTOH that other "all else fails" option did work and instantly re-enabled all add-ons. Thanks. Edit: BTW, I had to disable "Deceptive Content and Dangerous Software Protection" to allow that allegedly Mozilla signed update to install. Curiously, after that update installed and add-ons were enabled, the "About:Studies" page is still blank.

Modified by Smith299

Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
8693 solutions 71056 answers

Smith299 said

OTOH that other "all else fails" option did work and instantly re-enabled all add-ons.

Thank you for the update.

BTW, I had to disable "Deceptive Content and Dangerous Software Protection" to allow that allegedly Mozilla signed update to install.

Hmm, you do need to approve add-on installs from any new site you haven't installed from before. But a global setting change shouldn't be required. That's strange.

Curiously, after that update installed and add-ons were enabled, the "About:Studies" page is still blank.

Makes sense. You bypassed the study by going to get the extension the study was going to deliver. You never got the study.

''Smith299 [[#answer-1218625|said]]'' <blockquote> OTOH that other "all else fails" option did work and instantly re-enabled all add-ons.</blockquote> Thank you for the update. <blockquote> BTW, I had to disable "Deceptive Content and Dangerous Software Protection" to allow that allegedly Mozilla signed update to install.</blockquote> Hmm, you do need to approve add-on installs from any new site you haven't installed from before. But a global setting change shouldn't be required. That's strange. <blockquote> Curiously, after that update installed and add-ons were enabled, the "About:Studies" page is still blank. </blockquote> Makes sense. You bypassed the study by going to get the extension the study was going to deliver. You never got the study.
Was this helpful to you?
Quote
Lyghtkeepr 0 solutions 2 answers

2:40 pm CDT THANKS FOR THE FIX! Looks like my add ons are back and working. Thanks again. Hope this doesn't happen again anytime soon.

Regards.

2:40 pm CDT THANKS FOR THE FIX! Looks like my add ons are back and working. Thanks again. Hope this doesn't happen again anytime soon. Regards.
Was this helpful to you? 1
Quote
اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.