X
Tap here to go to the mobile version of the site.

منتدى الدعم

Why has Firefox just disabled all seven of my add ons?

Posted

Just opened Firefox browser this morning to find all seven of my add ons have been disabled. This includes Evernote, Lasspass password manager, Privacy Badger etc. What's going on?

Just opened Firefox browser this morning to find all seven of my add ons have been disabled. This includes Evernote, Lasspass password manager, Privacy Badger etc. What's going on?

Chosen solution

Anyway. I've fixed it! I just had to reset the "app.update.lastUpdateTime.xpi-signature-verification" setting, and it all came good! Thanks very much for your help. Cheers, Dave.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

Dave-H 2 solutions 59 answers

Same here, all but three of my add-ons are now disabled, including Ad-Block+!

Same here, all but three of my add-ons are now disabled, including Ad-Block+!
tehuti88 0 solutions 12 answers

Same, with Adblock Plus and Trend Micro toolbar. I can't use Firefox until they resolve whatever this is. :(

User on Adblock Plus site is reporting the same issue.

Same, with Adblock Plus and Trend Micro toolbar. I can't use Firefox until they resolve whatever this is. :( User on Adblock Plus site is reporting the same issue.
jscher2000
  • Top 10 Contributor
8775 solutions 71736 answers

I don't think forum volunteers yet know the cause or remedy for this problem. However, know that dozens of people are reporting the same thing in recent hours, so it may be due to a rolling update gone wrong.

I don't think forum volunteers yet know the cause or remedy for this problem. However, know that dozens of people are reporting the same thing in recent hours, so it may be due to a rolling update gone wrong.
jjlongiii 0 solutions 4 answers

I am extremely upset about this verification shit storm. Of all the extensions, Adblocker Plus should be the least of a verification problem for Firefox. It has 500 million downloads, so this makes no sense that FF would have a problem with it. I have nine others that have been disabled, and I've never had a problem with security on any of those either.

I am extremely upset about this verification shit storm. Of all the extensions, Adblocker Plus should be the least of a verification problem for Firefox. It has 500 million downloads, so this makes no sense that FF would have a problem with it. I have nine others that have been disabled, and I've never had a problem with security on any of those either.
jscher2000
  • Top 10 Contributor
8775 solutions 71736 answers

Helpful Reply

Hi jjlongiii, this isn't specific to particular extensions. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.)

The Add-ons team is working on a fix for this. I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.

Hi jjlongiii, this isn't specific to particular extensions. It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.) The Add-ons team is working on a fix for this. I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.
mccartichoke 0 solutions 4 answers

''''I am FURIOUS!!!!!!!!!!!!!!!!!!!!!!!!!!! WTF FF?!?!?! YOU SUMMARILY DISABLED 27 ADD-Ons and left me with 4 that I NEVER use. I have been a loyal FF user for 14 years and feel the knife in my back twisting & exploding. I expect you guys have had a major fuck-up, but regardless, this has already done too much damage to bring me back. FF has been declining in quality the past eight years but this is a black letter day!''''

'''''''''I am FURIOUS!!!!!!!!!!!!!!!!!!!!!!!!!!! WTF FF?!?!?! YOU SUMMARILY DISABLED 27 ADD-Ons and left me with 4 that I NEVER use. I have been a loyal FF user for 14 years and feel the knife in my back twisting & exploding. I expect you guys have had a major fuck-up, but regardless, this has already done too much damage to bring me back. FF has been declining in quality the past eight years but this is a black letter day!'''''''''
jscher2000
  • Top 10 Contributor
8775 solutions 71736 answers

Helpful Reply

Hi mccartichoke, a certificate expired. It definitely shouldn't have happened, but now we're helping pick up the pieces. See: Add-ons disabled or fail to install on Firefox.

Hi mccartichoke, a certificate expired. It definitely shouldn't have happened, but now we're helping pick up the pieces. See: [[Add-ons disabled or fail to install on Firefox]].
mccartichoke 0 solutions 4 answers

Thanks for your timely reply, however no action has occured to repair the problem. I have not 7 add-ons but 31 and their sudden loss leaves me all but paralized. Fortunately, it's nearly my bedtime and I can go to sleep hoping this nightmare will all be over by morning.

I just now checked the box in 'Options' to "Allow FF to... run studies" so I hope to find improved Add-Ons in the morning. Thanks for your help.

Thanks for your timely reply, however no action has occured to repair the problem. I have not 7 add-ons but 31 and their sudden loss leaves me all but paralized. Fortunately, it's nearly my bedtime and I can go to sleep hoping this nightmare will all be over by morning. I just now checked the box in 'Options' to "Allow FF to... run studies" so I hope to find improved Add-Ons in the morning. Thanks for your help.
mccartichoke 0 solutions 4 answers

THANKS FF! My life (and ADD-ONS) have returned this morning!

THANKS FF! My life (and ADD-ONS) have returned this morning!
jscher2000
  • Top 10 Contributor
8775 solutions 71736 answers

texaswedge said

Just opened Firefox browser this morning to find all seven of my add ons have been disabled. This includes Evernote, Lasspass password manager, Privacy Badger etc. What's going on?

Hi texaswedge, has this issue been resolved on your Firefox by now?

It looks like in crush of posts I didn't get back to you personally about the hotfix to install a new certificate. As noted in the following article, it is being delivered through a "study": Add-ons disabled or fail to install on Firefox.

The hotfix to install a new certificate should run fine on Firefox 66, and if studies are enabled, you should have received it within six hours. The certificate should show up here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type cert and Firefox should filter to the Certificates section. Then click the "View Certificates" button. Check the "Authorities" tab to see whether Mozilla is listed with the new certificate. You can compare the attached screenshot.

If the certificate is missing:

Unfortunately, the hotfix was not successful and we will need to provide further steps to install the certificate, or await further updates from the Add-ons team.

If the certificate was installed but installed extensions still show as unverified and/or new extensions can't be installed because they are corrupted:

It sounds as though the hotfix didn't successfully trigger immediate re-verification. To trigger a re-verification sooner than the usual "every 24 hours," you can use this method to clear the time stamp for the last time Firefox last re-verified.

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(B) In the search box above the list, type or paste xpi- and pause while the list is filtered

(C) Right-click the app.update.lastUpdateTime.xpi-signature-verification preference and click Reset on the context menu -- the numeric value will disappear and the preference will say it is now a "string".

The next time you exit and restart Firefox, the re-verification should be performed within about a minute.

Success?

''texaswedge [[#question-1257892|said]]'' <blockquote> Just opened Firefox browser this morning to find all seven of my add ons have been disabled. This includes Evernote, Lasspass password manager, Privacy Badger etc. What's going on? </blockquote> Hi texaswedge, has this issue been resolved on your Firefox by now? It looks like in crush of posts I didn't get back to you personally about the hotfix to install a new certificate. As noted in the following article, it is being delivered through a "study": [[Add-ons disabled or fail to install on Firefox]]. The hotfix to install a new certificate should run fine on Firefox 66, and if studies are enabled, you should have received it within six hours. The certificate should show up here: * Windows: "3-bar" menu button (or Tools menu) > Options * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it In the search box at the top of the page, type ''cert'' and Firefox should filter to the '''Certificates''' section. Then click the "View Certificates" button. Check the "Authorities" tab to see whether Mozilla is listed with the new certificate. You can compare the attached screenshot. ''If the certificate is missing:'' Unfortunately, the hotfix was not successful and we will need to provide further steps to install the certificate, or await further updates from the Add-ons team. ''If the certificate was installed but installed extensions still show as unverified and/or new extensions can't be installed because they are corrupted:'' It sounds as though the hotfix didn't successfully trigger immediate re-verification. To trigger a re-verification sooner than the usual "every 24 hours," you can use this method to clear the time stamp for the last time Firefox last re-verified. (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (B) In the search box above the list, type or paste '''xpi-''' and pause while the list is filtered (C) Right-click the '''app.update.lastUpdateTime.xpi-signature-verification''' preference and click Reset on the context menu -- the numeric value will disappear and the preference will say it is now a "string". The next time you exit and restart Firefox, the re-verification should be performed within about a minute. Success?
Dave-H 2 solutions 59 answers

Is there a fix for Firefox 52.9.1 ESR on my old Windows XP machine? The add-ons are all still working fine, but most of them have error messages saying they're not verified. I tried the previous procedure, but it seems to have made no difference. Thanks, Dave.

Is there a fix for Firefox 52.9.1 ESR on my old Windows XP machine? The add-ons are all still working fine, but most of them have error messages saying they're not verified. I tried the previous procedure, but it seems to have made no difference. Thanks, Dave.
jscher2000
  • Top 10 Contributor
8775 solutions 71736 answers

Dave-H said

Is there a fix for Firefox 52.9.1 ESR on my old Windows XP machine?

The method used by the hotfix extension doesn't work on Firefox 52 ESR. It shows up in Extensions but just sits there doing nothing. You will need to update the certificate manually.

This is an unsupported workaround, but then, Firefox 52 itself is unsupported, so there you go.

See: https://support.mozilla.org/questions/1258165#answer-1218833 -- my reply with Overview (1)(2)(3) and cor-el's after that

''Dave-H [[#answer-1219452|said]]'' <blockquote> Is there a fix for Firefox 52.9.1 ESR on my old Windows XP machine? </blockquote> The method used by the hotfix extension doesn't work on Firefox 52 ESR. It shows up in Extensions but just sits there doing nothing. You will need to update the certificate manually. This is an unsupported workaround, but then, Firefox 52 itself is unsupported, so there you go. See: https://support.mozilla.org/questions/1258165#answer-1218833 -- my reply with Overview (1)(2)(3) and cor-el's after that
Dave-H 2 solutions 59 answers

Thanks, I did all that and it said in the console that the certificate was updated. However, although it's valid (4th April 2015 - 4th April 2025) when I view the "signingca1.addons.mozilla.org" certificate in the viewer, it says at the top of it "could not verify this certificate because the issuer is unknown". As the issuer is Mozilla I don't understand that! My add-ons are still showing as unverified.

Thanks, I did all that and it said in the console that the certificate was updated. However, although it's valid (4th April 2015 - 4th April 2025) when I view the "signingca1.addons.mozilla.org" certificate in the viewer, it says at the top of it "could not verify this certificate because the issuer is unknown". As the issuer is Mozilla I don't understand that! My add-ons are still showing as unverified.
mccartichoke 0 solutions 4 answers

I am not a coder; I do not design add-ons or apps for Firefox, Mozilla, or anyone else. Please do not email me for answers to your questions. I have no answers! It's ALL GREEK TO ME!!!

'''I am not a coder'''; I do not design add-ons or apps for Firefox, Mozilla, or anyone else. Please do not email me for answers to your questions. I have no answers! ''' It's ALL GREEK TO ME!!!'''
Dave-H 2 solutions 59 answers

mccartichoke said

I am not a coder; I do not design add-ons or apps for Firefox, Mozilla, or anyone else. Please do not email me for answers to your questions. I have no answers! It's ALL GREEK TO ME!!!

Sorry, I haven't e-mailed you! My last message was aimed at @jscher2000!

''mccartichoke [[#answer-1219566|said]]'' <blockquote> '''I am not a coder'''; I do not design add-ons or apps for Firefox, Mozilla, or anyone else. Please do not email me for answers to your questions. I have no answers! ''' It's ALL GREEK TO ME!!!''' </blockquote> Sorry, I haven't e-mailed you! My last message was aimed at @jscher2000!
Dave-H 2 solutions 59 answers

Chosen Solution

Anyway. I've fixed it! I just had to reset the "app.update.lastUpdateTime.xpi-signature-verification" setting, and it all came good! Thanks very much for your help. Cheers, Dave.

Anyway. I've fixed it! I just had to reset the "app.update.lastUpdateTime.xpi-signature-verification" setting, and it all came good! Thanks very much for your help. Cheers, Dave.