ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since I had to mess with content blocking yesterday - I can no longer play videos anywhere. Why?

more options

How can I fix Firefox where I can play videos. None play - YouTube, FB feed or news media.

I had to do something with content blocking yesterday - said it had to restarted? Can't remember.

NOW nothing plays. I am pissed.

How can I fix Firefox where I can play videos. None play - YouTube, FB feed or news media. I had to do something with content blocking yesterday - said it had to restarted? Can't remember. NOW nothing plays. I am pissed.

الحل المُختار

You changed a setting on the Options page, and Firefox said it needed to restart? That could be switching between regular mode and automatic private browsing. You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security

On the right side, scroll down to the History section. What do you have here? Either of these will trigger automatic private browsing mode:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"

In that mode, Firefox may block more and some features that require local storage may be broken.

Was that the issue?

Read this answer in context 👍 1

All Replies (1)

more options

الحل المُختار

You changed a setting on the Options page, and Firefox said it needed to restart? That could be switching between regular mode and automatic private browsing. You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security

On the right side, scroll down to the History section. What do you have here? Either of these will trigger automatic private browsing mode:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"

In that mode, Firefox may block more and some features that require local storage may be broken.

Was that the issue?