X
Tap here to go to the mobile version of the site.

منتدى الدعم

Latest version of Firefox changed about:config autoplay settings again?

Posted

A few months ago Firefox updated and autoplay settings were changed around. It took awhile of searching, but certain things in about:config had to be disabled to make it so videos didn't autoplay. After the latest update, videos are auto-playing again.

1. My settings did not revert, they are still the same. 2. The in-menu setting of disallowing sound does nothing, videos are autoplaying with sound on multiple websites.

Does anybody have a fix? This is getting ridiculous how much this keeps changing. I do not want videos, muted or otherwise, to ever autoplay in my browser. Can anyone help me with the autoplay settings? It seems like there are a bunch more in about:config now and I don't know what any of them do.

A few months ago Firefox updated and autoplay settings were changed around. It took awhile of searching, but certain things in about:config had to be disabled to make it so videos didn't autoplay. After the latest update, videos are auto-playing again. 1. My settings did not revert, they are still the same. 2. The in-menu setting of disallowing sound does nothing, videos are autoplaying with sound on multiple websites. Does anybody have a fix? This is getting ridiculous how much this keeps changing. I do not want videos, muted or otherwise, to ever autoplay in my browser. Can anyone help me with the autoplay settings? It seems like there are a bunch more in about:config now and I don't know what any of them do.
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157316 answers

What Firefox settings in about:config did you previously make?

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt]
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

You can look at this extension.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

What Firefox settings in about:config did you previously make? You can look at these prefs on the about:config page to see if these values work for you. *media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt] *media.autoplay.allow-muted = false *media.autoplay.enabled.user-gestures-needed = false For user-gestures-needed you can try false and true to see what works for you. You can look at this extension. *Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/ You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
Was this helpful to you?
Quote

Question owner

Hello! Thank you for the response. I'm familiar with that extension but it always seemed spotty, I stopped using it when Firefox enabled these features in about:Config.

That said, this is what my about:config currently looks like (Filtered by "autoplay") - https://imgur.com/a/lYFPQX1 - and I still get auto-playing videos on specific sites (ESPN, SportingNews come to mind), but it's blocked on YouTube and others. I'm not sure why some of them are slipping through the cracks (I've checked and I have no exceptions set).

I have also recently refreshed Firefox and started from scratch to see if that would help, and it did not.

Any ideas? Again, thanks for taking the time to respond. I know a lot of people ask about this stuff but it seems like the settings have changed a few times

Hello! Thank you for the response. I'm familiar with that extension but it always seemed spotty, I stopped using it when Firefox enabled these features in about:Config. That said, this is what my about:config currently looks like (Filtered by "autoplay") - https://imgur.com/a/lYFPQX1 - and I still get auto-playing videos on specific sites (ESPN, SportingNews come to mind), but it's blocked on YouTube and others. I'm not sure why some of them are slipping through the cracks (I've checked and I have no exceptions set). I have also recently refreshed Firefox and started from scratch to see if that would help, and it did not. Any ideas? Again, thanks for taking the time to respond. I know a lot of people ask about this stuff but it seems like the settings have changed a few times
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157316 answers

I see the block auto-play icon in the location bar meaning that Firefox is detecting media on this web page and I see the shield that Content Blocking is blocking a lot of content.

No auto-play icon present on ESPN, but I'm not seeing any media reported in the Network Monitor and all media seem to show a play button that probably means that only a preview image is shown.

Do you have extensions that could interfere and override Content Blocking?

I see the block auto-play icon in the location bar meaning that Firefox is detecting media on this web page and I see the shield that Content Blocking is blocking a lot of content. *http://www.sportingnews.com/ No auto-play icon present on ESPN, but I'm not seeing any media reported in the Network Monitor and all media seem to show a play button that probably means that only a preview image is shown. Do you have extensions that could interfere and override Content Blocking? *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote
اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.