ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Why am I not able to watch my xfinity tv and movies thru your web browser? I am having to use Google Chrome to access my tv channels/On Demand recorded movies.

  • 15 ردًا
  • 1 has this problem
  • 1564 views
  • آخر ردّ كتبه Chris Ilias

more options

If I set-up Adobe Flash Player to run with Mozilla will that solve the question above? If so, please tell me the steps to take. Thanks.

الحل المُختار

The System Details list shows that you have the Shockwave Flash plugin plugin installed.

  • Shockwave Flash 32.0 r0

You can find a Lego block icon at the left end of the location bar indicating that the web page uses a plugin (Flash) that Firefox might block. You can click this Lego block icon to allow or block the plugin for this web page.

Read this answer in context 👍 1

All Replies (15)

more options

It will only work if what you are trying to use requires Flash Player.

more options

Hi EJPK, do you get a specific error message when you try to access your Xfinity content?

Are any other sites affected?

Some general articles that could be relevant:

more options

Even when I resort to using Chrome, I must activate Flash. So, can you tell me how to set up Adobe Flash for Mozilla?

more options

Hi EJPK, your Firefox reported that Flash is installed.

When you are on the site, look for an icon toward the left end of the address bar that looks like a small light gray Lego block, potentially with a blue "attention" dot on it. This is the icon to activate Flash on the site as described in the last article I linked to in my earlier reply.

more options

الحل المُختار

The System Details list shows that you have the Shockwave Flash plugin plugin installed.

  • Shockwave Flash 32.0 r0

You can find a Lego block icon at the left end of the location bar indicating that the web page uses a plugin (Flash) that Firefox might block. You can click this Lego block icon to allow or block the plugin for this web page.

more options

I am having the same problem, but the responses above do not help me. I recently reinstalled Windows 8.1 on a new hard drive. I then installed Firefox. I can access Comcast TV, but I cannot get live TV to work. I am sure it is because of Flash, as I had a similar problem a couple of years ago on the original drive. However, I have installed Flash and it appears in in the settings that my plugins as activated, but it still will not work. On advice from Comcast, I cleared my cache and cookies in Firefox. Now, when I try to access Xfinity Stream, I get a message from Xfinity: "Lets get your Adobe Flash Player up and running....and Enable Flash. If I do that, I get a screen from Firefox Support: "Why do I have to click to activate plugins?" but there is no way to "enable Flash." I also found a screen "Enabling Flash," that tells me to Click on the Menu...Add-ons...Options...and uncheck the box "Block dangerous and intrusive Flash content." I did all of that to no avail. That was NOT done on my previous drive. I don't know if Flash is actually enabled or not. It appears to be. BTW, if I change the drive back to the original, it still works fine.

Per the instructions above, I cannot see a gray leggo block on the left side of the address bar. The only thing that resembles that is the menu bar on the far right.

Any help Greatly Appreciated!

more options

Hi TexasNative, one place to check on Flash in Firefox is the internal page named about:plugins -- you can type or paste about:plugins in the address bar and press Enter to load it.

Under Shockwave Flash look for

State: Enabled

If you do not see Flash here, make sure you have the Firefox-specific plugin installed: https://get.adobe.com/flashplayer/otherversions/

Assuming your about:plugins page shows State: Enabled, can you trigger the activation icon on Adobe's test page here:

https://helpx.adobe.com/flash-player.html

more options

Hi jscher

I tried to follow your instructions, and the Installed Plugins does show Shockwave Flash as enabled. I then went to helpx....link, but I dd not see how to trigger the "activation" icon on Adobe's test page. I followed the steps under "Enable Flash Player for Firefox" (which I had done previously) and it went to the How "Click to Activate Works," which I went through previously as I described in my previous post. When I access the, Add-ons page in the browser, it shows Flash with the "always activate" selection. If I try to access the live TV now from Xfinity, I still get the screen from Firefox Support: "Why do I have to click to activate plugins?," etc.

Not sure where to go now. Comcast was no help.

more options

On the Adobe help page, check for the address bar icon circled in the attached screenshot, and the black plugin placeholder after you click Check Now. Do any of those show up?

more options

I went to the Adobe help page, and did find the black plugin placeholder (both before and after I clicked on “Check Now”). I clicked on that and checked the box “Remember This Decision”, and then clicked on “Allow. ” I then tried to access Xfinity TV again, and again got the attached screen shot. I then clicked on the icon on the address bar and went through the same routine I just described and tried again. Still get the Enable Flash in browser settings. I do not get a pop-up window, but I do see a very quick flash of a black rectangle in the center, below the message saying to click on "Allow when the pop-up window appears."

I do NOT have “Block pop-up Windows” checked in my Firefox settings.  Sorry if I am being dense.  I know that there must be something that I am not doing correctly.
more options

Hmm, it's possible that Firefox is showing a permission icon for the server that hosts the outer page, but permission is needed for an embedded page from a different server. I think as a temporary workaround, you could try changing your global Flash permission from "Ask to Activate" to "Always Activate." Unfortunately, that allows video ads to run automatically all over the web, so you probably want to turn it off when you're done with Xfinity for the day. At least it's worth a test.

more options

Already tried that. Didn't help. See screenshot.

I did learn that if I go directly to a news network and click on Live TV, I get a pop-up that asks what supplier to use. If I click on Xfinity, the video stream loads and runs fine. However, when a commercial normally comes on I get a screen that says Commercial Break (this is Good). However, after a short time the spinning load/refresh circle starts, and does not stop when the commercial ends. I have to refresh the link to get the video again. Painful!

Another observation: When I first trying to do this with the new drive, I would click on Xfinity and then on the TV icon. The screen with the programs would come up and when I clicked on the program I wanted, it would go to the loading phase and never stop. After messing with it for the past several days, now when I click on the TV icon, I immediately get the "Lets get your Adobe....up and running. And, of course, that is a dead end.

more options

I can't explain it.

In another thread, someone mentioned that the Flash "sandbox" -- a security setting -- will be changed in Firefox 66, so maybe that will help with these problems.

more options

Thank you for all of your effort. I really do not understand why I never had a problem with the other drive after I first activated Flash. As far as I can tell, all of the settings between the two Firefox installations are the same.

Another bit of information. When I try to run Xfinity Stream on IE, it causes IE to crash....every time???

Someone told me that I should install Chrome, that Flash is not needed on that platform. I have resisted that because of a number of issues I have with Chrome (and Google), but maybe I will try it.

I don't think I noted it before, but the Xfinity Stream works fine on my iPad. Go figure.

more options

Hi All, I'm locking this thread. cor-el's post was marked as the solution by the person who asked the original question (EJPK), and since then we've received complaints from the question owner about email notifications for each subsequent post.

Your issue may have similar symptoms, but it is likely a different cause/solution. You should use https://support.mozilla.org/en-US/questions/new where volunteers can get more details about your setup.