X
Tap here to go to the mobile version of the site.

منتدى الدعم

Printing from Firefox set to Portrait but prints in Landscape.

Posted

Every time I print from Firefox, the page prints out in Landscape even though all the settings show it's set to print in Portrait. When I click "Print Preview" it shows a preview of the page in Portrait, the "Portrait" box is checked, scale is "Shrink to Fit". When I click on "Page Setup", the bubble next to "Portrait" is selected in the orientation section. Everything I can see seems to show that the page will print in Portrait, yet when it comes off the printer it's in Landscape. Every single time. This has been going on for at least six months, so it doesn't seem to have anything to do with the version of Firefox as Firefox has updated many times since this began (current version is 65.0.2).

The problem is limited to Firefox. Downloaded PDF's print in Portrait and if I copy/paste a page into Internet Explorer and print from IE, the page will print in Portrait. Which leads me to believe it's not an issue with my printer drivers.

I've tried all of the suggestions I found in the "Fixing printing problems in Firefox" article. Checked Firefox printer settings, reset Firefox print settings and reset all Firefox printer settings. After restarting Firefox, and my laptop, I'm still having the same problem. Firefox will only print in Landscape. Other than uninstalling/reinstalling Firefox, or going to another browser every time I need to print something, I don't know what else to do.

If anyone has any suggestions I would greatly appreciate the help! Thanks!

Every time I print from Firefox, the page prints out in Landscape even though all the settings show it's set to print in Portrait. When I click "Print Preview" it shows a preview of the page in Portrait, the "Portrait" box is checked, scale is "Shrink to Fit". When I click on "Page Setup", the bubble next to "Portrait" is selected in the orientation section. Everything I can see seems to show that the page will print in Portrait, yet when it comes off the printer it's in Landscape. Every single time. This has been going on for at least six months, so it doesn't seem to have anything to do with the version of Firefox as Firefox has updated many times since this began (current version is 65.0.2). The problem is limited to Firefox. Downloaded PDF's print in Portrait and if I copy/paste a page into Internet Explorer and print from IE, the page will print in Portrait. Which leads me to believe it's not an issue with my printer drivers. I've tried all of the suggestions I found in the "Fixing printing problems in Firefox" article. Checked Firefox printer settings, reset Firefox print settings and reset all Firefox printer settings. After restarting Firefox, and my laptop, I'm still having the same problem. Firefox will only print in Landscape. Other than uninstalling/reinstalling Firefox, or going to another browser every time I need to print something, I don't know what else to do. If anyone has any suggestions I would greatly appreciate the help! Thanks!
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

jscher2000
  • Top 10 Contributor
8568 solutions 70054 answers

Helpful Reply

This is a very strange problem!

If you click the Properties button for your printer in the Print dialog (Ctrl+p), does the printer driver itself have "Landscape" selected? (Firefox should be able to override it, but...)

This is a very strange problem! If you click the Properties button for your printer in the Print dialog (Ctrl+p), does the printer driver itself have "Landscape" selected? (Firefox should be able to override it, but...)
Was this helpful to you? 1
Quote

Question owner

Nope, I checked that too. In printer properties the orientation is set as "Portrait". It really doesn't make any sense. Printing from any other program, the orientation prints correctly. The issue is in Firefox only. I'm honestly not sure I'd believe it if someone was describing the problem to me...so I feel really weird asking for help with it! But I've done everything I can think of with troubleshooting and haven't found a fix.

Nope, I checked that too. In printer properties the orientation is set as "Portrait". It really doesn't make any sense. Printing from any other program, the orientation prints correctly. The issue is in Firefox only. I'm honestly not sure I'd believe it if someone was describing the problem to me...so I feel really weird asking for help with it! But I've done everything I can think of with troubleshooting and haven't found a fix.
Was this helpful to you?
Quote
WestEnd
  • Top 25 Contributor
61 solutions 5340 answers

Did you do a Print Preview first?

Did you do a Print Preview first?
Was this helpful to you?
Quote

Question owner

Yes. In Print Preview it shows that it's in Portrait (Portrait is selected and the Print Preview image is in Portrait).

Out of curiosity and for laughs I just tried changing it to Landscape to see if it would print in Portrait. It did, kind of. It printed in Portrait on the paper but was still laid out like it thought it was in Landscape so most of the text got cut off. Something in Firefox seems to have Portrait and Landscape confused. The troubleshooting thing of deleting all the "printer_" lines from my "prefs.js", didn't help (I tried that before posting my question).

Yes. In Print Preview it shows that it's in Portrait (Portrait is selected and the Print Preview image is in Portrait). Out of curiosity and for laughs I just tried changing it to Landscape to see if it would print in Portrait. It did, kind of. It printed in Portrait on the paper but was still laid out like it thought it was in Landscape so most of the text got cut off. Something in Firefox seems to have Portrait and Landscape confused. The troubleshooting thing of deleting all the "printer_" lines from my "prefs.js", didn't help (I tried that before posting my question).
Was this helpful to you?
Quote
SRovinsky 0 solutions 2 answers

Solution Found! I had this problem many versions of Firefox (Nightly) ago, and it recently reappeared. I re-located the solution. Open a new tab in FF, and use "about:config" as an address. Accept the risk of "Here Be Dragons." In the search bar, search for "print". This will bring up all the lines that have "print" in their entry names. Scroll down, and look for lines that are specific to your printer. My lines appear (in Bold!) as print.printer_<Brandname>_<Modelname>_Printer.<option>. The line that was in error was print.printer_<Brandname>_<Modelname>_Printer.print_paper_data. It's an integer, and its value was set to 256. Reset it to a value of 1. Close everything and restart the browser. Now try printing again.

Solution Found! I had this problem many versions of Firefox (Nightly) ago, and it recently reappeared. I re-located the solution. Open a new tab in FF, and use "about:config" as an address. Accept the risk of "Here Be Dragons." In the search bar, search for "print". This will bring up all the lines that have "print" in their entry names. Scroll down, and look for lines that are specific to your printer. My lines appear (in Bold!) as '''print.printer_<Brandname>_<Modelname>_Printer.<option>'''. The line that was in error was '''print.printer_<Brandname>_<Modelname>_Printer.print_paper_data'''. It's an integer, and its value was set to 256. Reset it to a value of 1. Close everything and restart the browser. Now try printing again.
Was this helpful to you? 0
Quote
Lennart 0 solutions 1 answers

It doesn't help me. Also, I get my printouts at a huge scale and much or most of pages aren't printed at all. Any tips & tricks?

It doesn't help me. Also, I get my printouts at a huge scale and much or most of pages aren't printed at all. Any tips & tricks?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8568 solutions 70054 answers

Hi Lennart, are you Windows, Mac, or Linux?

If you check the Page Setup dialog, do you have an extreme scale? Usually it's 100% + Shrink to Fit. You can call that up from the File menu; on Windows, tap the Alt key to activate the File menu if you don't normally show the menu bar.

The problem of missing pages occurs on a lot of websites. It can be caused by certain style rules that Firefox views as creating an "unbreakable" block of context. When you spot that problem in Print Preview, you can use my add-on to make those sections breakable.

https://addons.mozilla.org/firefox/addon/printable-the-print-doctor/

Hi Lennart, are you Windows, Mac, or Linux? If you check the Page Setup dialog, do you have an extreme scale? Usually it's 100% + Shrink to Fit. You can call that up from the File menu; on Windows, tap the Alt key to activate the File menu if you don't normally show the menu bar. The problem of missing pages occurs on a lot of websites. It can be caused by certain style rules that Firefox views as creating an "unbreakable" block of context. When you spot that problem in Print Preview, you can use my add-on to make those sections breakable. https://addons.mozilla.org/firefox/addon/printable-the-print-doctor/
Was this helpful to you?
Quote
اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.