X
Tap here to go to the mobile version of the site.

منتدى الدعم

Notifications blocking not working

Posted

I have Notifications blocking set to all websites. However, I was surprised to come to the website below and have a Notifications permission request pop up. What's the deal?

https://www.tckpublishing.com

Also, related - in Preferences, under Content Blocking, it says:

"Heads up!

                   Blocking cookies and trackers can cause some websites to break. It’s easy to disable blocking for sites you trust. Learn how"

But when I click on the Learn how link, it doesn't tell me how.

When I click on the Manage Exceptions button right next to the Content Blocking heading, I get a pop up that says, "Exceptions - Content Blocking" and "you have disabled content blocking on these websites." Yet there's no way to add any URL provided there.

When I go to a website that I want to not block tracking on, I click on the lock or shield symbol, and click on Permissions and am taken to the pop up and again cannot add this website address.

How am I supposed to set any Permissions if this functionality doesn't actually work?

I have Notifications blocking set to all websites. However, I was surprised to come to the website below and have a Notifications permission request pop up. What's the deal? https://www.tckpublishing.com Also, related - in Preferences, under Content Blocking, it says: "Heads up! Blocking cookies and trackers can cause some websites to break. It’s easy to disable blocking for sites you trust. Learn how" But when I click on the Learn how link, it doesn't tell me how. When I click on the Manage Exceptions button right next to the Content Blocking heading, I get a pop up that says, "Exceptions - Content Blocking" and "you have disabled content blocking on these websites." Yet there's no way to add any URL provided there. When I go to a website that I want to not block tracking on, I click on the lock or shield symbol, and click on Permissions and am taken to the pop up and again cannot add this website address. How am I supposed to set any Permissions if this functionality doesn't actually work?

Chosen solution

cor-el said

There is a checkbox at the bottom of the notification settings page in "Options/Preferences -> Privacy & Security" to block new requests to allow notifications. If this box is checked then Firefox won't ask for permission. Otherwise this should work with the default setting.

After Privacy/Security, it is in the Permissions box. Never had to do it before - or I do not remember.

Thank you for letting me know.

Read this answer in context 0

Additional System Details

Application

  • Firefox 65.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:65.0) Gecko/20100101 Firefox/65.0
  • Support URL: https://support.mozilla.org/1/firefox/65.0.1/Darwin/en-US/

Extensions

  • 1Password extension (desktop app required) 4.7.3.90 (onepassword4@agilebits.com)
  • Adblock Plus - free ad blocker 3.4.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AdBlocker for YouTube™ 0.2.9 (jid1-q4sG8pYhq8KGHs@jetpack)
  • Auto Tab Discard 0.3.1 ({c2c003ee-bd69-42a2-b0e9-6f34222cb046})
  • Blur 7.8.2431 (donottrackplus@abine.com)
  • Disable Autoplay for YouTube™ 0.1.0 ({b414ff62-445b-4713-853e-28e4f76b01b4})
  • Disable HTML5 Autoplay 2018.10.3 (disable-html5-autoplay@afnankhan)
  • Disconnect for Facebook™ 0.1.6 ({02bf35c3-6f86-4eb4-bea8-e70bc294a7dc})
  • Don't track me Google 4.22 (dont-track-me-google@robwu.nl)
  • Dormancy 3.4.3 (jid1-XvLLp3mhOTiPXg@jetpack)
  • F.B Purity - Cleans up Facebook (WX) 27.1.2.0 (fbpElectroWebExt@fbpurity.com)
  • Google Analytics Blocker 1.2.1 ({c7c3483c-0e96-45f4-8772-f84462cdc047})
  • HTTPS Everywhere 2019.1.31 (https-everywhere@eff.org)
  • Keepa - Amazon Price Tracker 3.31 (amptra@keepa.com)
  • Privacy Badger 2019.2.19 (jid1-MnnxcxisBPnSXQ@jetpack)
  • uBlock Origin 1.18.4 (uBlock0@raymondhill.net)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x0166
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 512, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 512, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 8
  • numTotalWindows: 8
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 3
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_texture_compression_rgtc EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
  • webgl1Version: 4.1 INTEL-10.36.22
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_compression_rgtc EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
  • webgl2Version: 4.1 INTEL-10.36.22
  • webgl2WSIInfo: CGL
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
TyDraniu
  • Top 25 Contributor
336 solutions 1893 answers

seacleer said

I have Notifications blocking set to all websites. However, I was surprised to come to the website below and have a Notifications permission request pop up. What's the deal? https://www.tckpublishing.com

This is not a Firefox Notification Doorhanger, but just an element of this particular website.

See Web Push notifications in Firefox.

''seacleer [[#question-1251362|said]]'' <blockquote> I have Notifications blocking set to all websites. However, I was surprised to come to the website below and have a Notifications permission request pop up. What's the deal? https://www.tckpublishing.com </blockquote> This is not a Firefox Notification Doorhanger, but just an element of this particular website. See [[Web Push notifications in Firefox]].

Question owner

And when I go to the link you provide, near the bottom it says:

"You can set Firefox to automatically deny permission without asking. "

This is what I have done, and yet I got asked anyway, when I shouldn't have been.

And when I go to the link you provide, near the bottom it says: "You can set Firefox to automatically deny permission without asking. " This is what I have done, and yet I got asked anyway, when I shouldn't have been.
TyDraniu
  • Top 25 Contributor
336 solutions 1893 answers

This is not a Notification, but a part of this website. You can't really force the website to not have a question anywhere in a text.

You can click Allow or Deny. Nothing will be granted, and this box will dissapear.

This is not a Notification, but a part of this website. You can't really force the website to not have a question anywhere in a text. You can click Allow or Deny. Nothing will be granted, and this box will dissapear.

Helpful Reply

The instructions I cited are specifically about Push Notifications.

The instructions I cited are specifically about Push Notifications.
DevAspirerKlaus 0 solutions 1 answers

"When I go to a website that I want to not block tracking on, I click on the lock or shield symbol, and click on Permissions and am taken to the pop up and again cannot add this website address.

How am I supposed to set any Permissions if this functionality doesn't actually work?" - @seacleer

I totally agree with that. You can only enable/disable when a site ask you to do it. We should be able to add a site to that list whenever we want.

"When I go to a website that I want to not block tracking on, I click on the lock or shield symbol, and click on Permissions and am taken to the pop up and again cannot add this website address. How am I supposed to set any Permissions if this functionality doesn't actually work?" - @seacleer I totally agree with that. You can only enable/disable when a site ask you to do it. We should be able to add a site to that list whenever we want.
CiaoBella1 5 solutions 239 answers

I disabled all notifications, yet I am still being asked. This did not happen prior to recent update to Quantum v 66.0.3, which updated since yesterday.

I went to about:config to disable all. Entered: dom.webnotifications.enabled to change to FALSE. It was already set to false (I changed it yesterday).

Not working. Any suggestions why?

I disabled all notifications, yet I am still being asked. This did not happen prior to recent update to Quantum v 66.0.3, which updated since yesterday. I went to '''about:config''' to disable all. Entered: '''dom.webnotifications.enabled''' to change to FALSE. It was already set to ''false'' (I changed it yesterday). Not working. Any suggestions why?

Modified by CiaoBella1

cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

There is a checkbox at the bottom of the notification settings page in "Options/Preferences -> Privacy & Security" to block new requests to allow notifications. If this box is checked then Firefox won't ask for permission. Otherwise this should work with the default setting.

There is a checkbox at the bottom of the notification settings page in "Options/Preferences -> Privacy & Security" to block new requests to allow notifications. If this box is checked then Firefox won't ask for permission. Otherwise this should work with the default setting.

Modified by cor-el

cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

You can try to create a cookie allow exception with the proper protocol (https:// or http://) to see whether that gives you a permission prompt for the notification.

You can try to create a cookie allow exception with the proper protocol (https:// or http://) to see whether that gives you a permission prompt for the notification.
CiaoBella1 5 solutions 239 answers

Chosen Solution

cor-el said

There is a checkbox at the bottom of the notification settings page in "Options/Preferences -> Privacy & Security" to block new requests to allow notifications. If this box is checked then Firefox won't ask for permission. Otherwise this should work with the default setting.

After Privacy/Security, it is in the Permissions box. Never had to do it before - or I do not remember.

Thank you for letting me know.

''cor-el [[#answer-1213088|said]]'' <blockquote> There is a checkbox at the bottom of the notification settings page in "Options/Preferences -> Privacy & Security" to block new requests to allow notifications. If this box is checked then Firefox won't ask for permission. Otherwise this should work with the default setting. </blockquote> After Privacy/Security, it is in the Permissions box. Never had to do it before - or I do not remember. Thank you for letting me know.

Question owner

The whole point of this thread being created is that checking that box doesn't stop sites from asking permission.

The whole point of this thread being created is that checking that box doesn't stop sites from asking permission.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers
See also: *https://blog.nightly.mozilla.org/2019/04/01/reducing-notification-permission-prompt-spam-in-firefox/
CiaoBella1 5 solutions 239 answers

seacleer said

The whole point of this thread being created is that checking that box doesn't stop sites from asking permission.

You have to go to about:configure. Have you done that? The point should be to stop the sites from asking. That box is not getting at the root of the problem - at least in my opinion.

''seacleer [[#answer-1213132|said]]'' <blockquote> The whole point of this thread being created is that checking that box doesn't stop sites from asking permission. </blockquote> You have to go to about:configure. Have you done that? The point should be to stop the sites from asking. That box is not getting at the root of the problem - at least in my opinion.
CiaoBella1 5 solutions 239 answers
''cor-el [[#answer-1213135|said]]'' <blockquote> See also: *https://blog.nightly.mozilla.org/2019/04/01/reducing-notification-permission-prompt-spam-in-firefox/ </blockquote> Timely article. Thank you for posting.