Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

change menubar language

  • 3 replies
  • 1 has this problem
  • 19 views
  • آخر ردّ كتبه FredMcD

more options

in OS X Mojave my system language is English and I have set English for interface language, still my menu language and menubar language is russian (apparently, because of my physical location). How do I change that once and for good? version 65.0.1

All Replies (3)

more options

I suggest you get the full program in the language you want from; Download Firefox For All languages And Systems {web link}

BTW, are you using any language packs?

more options

Thanks FredMcD, tried this link and downloaded the file for English (US) language. Still the same: menubar and browser menu are still in Russian. I am not aware of any language packs, at least I did not install any deliberately.

Where do I go to remove all Firefox preferences and system files to make a clean install? Maybe some settings files remained in my system that force Russian language?

more options