X
Tap here to go to the mobile version of the site.

منتدى الدعم

Unresponsive script when opening Preferences

Posted

Hello! (FF 65.0.1) I recently tried to access the preferences page but I get an error of "Unresponsive Script" on "resource://gre/modules/Localization.jsm:444"

Starting in Safe Mode solved the issue so I opened FF again and disabled all extensions but not luck. So I tried disabling Hebrew (using Hebrew on my FF) on the languages tab and it solved the issue.

What can I do to keep using Hebrew and to be able to access the preferences?

Thanks!

Hello! (FF 65.0.1) I recently tried to access the preferences page but I get an error of "Unresponsive Script" on "resource://gre/modules/Localization.jsm:444" Starting in Safe Mode solved the issue so I opened FF again and disabled all extensions but not luck. So I tried disabling Hebrew (using Hebrew on my FF) on the languages tab and it solved the issue. What can I do to keep using Hebrew and to be able to access the preferences? Thanks!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

FredMcD
  • Top 10 Contributor
4185 solutions 58421 answers

Try removing Hebrew, restart Firefox. Is the issues gone? Now redownload Hebrew.

Try removing Hebrew, restart Firefox. Is the issues gone? Now redownload Hebrew.

Question owner

Just tried what you said. After redownloading it's back.

Just tried what you said. After redownloading it's back.
FredMcD
  • Top 10 Contributor
4185 solutions 58421 answers

I called for more help.

I called for more help.
McCoy
  • Top 10 Contributor
488 solutions 4493 answers

ido1990 said

Starting in Safe Mode solved the issue so I opened FF again and disabled all extensions but not luck.

Hello ido1990,

May I ask if you have a Hebrew language pack installed  ? The fact that disabling all add-ons makes no difference makes me think that you don't ...... (?)

So I tried disabling Hebrew (using Hebrew on my FF) on the languages tab and it solved the issue.

Probably a dumb question, but do you mean : 3-bar menu => Options => General => under 'Languages' you had set Hebrew as one of the options, and removing it is what solves the problem  ?


Would downloading Firefox in Hebrew be an option for you  ?

If so, you can download from here :

www.mozilla.org/firefox/all/

''ido1990 [[#question-1250553|said]]'' <blockquote> Starting in Safe Mode solved the issue so I opened FF again and disabled all extensions but not luck. </blockquote> Hello ido1990, May I ask if you have a Hebrew language pack installed ? The fact that disabling all add-ons makes no difference makes me think that you don't ...... (?) <blockquote> So I tried disabling Hebrew (using Hebrew on my FF) on the languages tab and it solved the issue. </blockquote> Probably a dumb question, but do you mean : 3-bar menu => Options => General => under 'Languages' you had set Hebrew as one of the options, and removing it is what solves the problem ? --------------------------------------------------------------------------------------------- Would downloading Firefox in Hebrew be an option for you ? If so, you can download from here : www.mozilla.org/firefox/all/
cor-el
  • Top 10 Contributor
  • Moderator
17334 solutions 156713 answers

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

McCoy said

ido1990 said
Starting in Safe Mode solved the issue so I opened FF again and disabled all extensions but not luck.

Hello ido1990,

May I ask if you have a Hebrew language pack installed  ? The fact that disabling all add-ons makes no difference makes me think that you don't ...... (?)

So I tried disabling Hebrew (using Hebrew on my FF) on the languages tab and it solved the issue.

Probably a dumb question, but do you mean : 3-bar menu => Options => General => under 'Languages' you had set Hebrew as one of the options, and removing it is what solves the problem  ?


Would downloading Firefox in Hebrew be an option for you  ?

If so, you can download from here :

www.mozilla.org/firefox/all/

It's on the 3-bar menu => Addons (I hope that's the right translation)=>On the left sidebar "Languages"

My FF is in Hebrew.

''McCoy [[#answer-1198207|said]]'' <blockquote> ''ido1990 [[#question-1250553|said]]'' <blockquote> Starting in Safe Mode solved the issue so I opened FF again and disabled all extensions but not luck. </blockquote> Hello ido1990, May I ask if you have a Hebrew language pack installed ? The fact that disabling all add-ons makes no difference makes me think that you don't ...... (?) <blockquote> So I tried disabling Hebrew (using Hebrew on my FF) on the languages tab and it solved the issue. </blockquote> Probably a dumb question, but do you mean : 3-bar menu => Options => General => under 'Languages' you had set Hebrew as one of the options, and removing it is what solves the problem ? --------------------------------------------------------------------------------------------- Would downloading Firefox in Hebrew be an option for you ? If so, you can download from here : www.mozilla.org/firefox/all/ </blockquote> It's on the 3-bar menu => Addons (I hope that's the right translation)=>On the left sidebar "Languages" My FF is in Hebrew.
McCoy
  • Top 10 Contributor
488 solutions 4493 answers

ido1990 said

It's on the 3-bar menu => Addons (I hope that's the right translation)=>On the left sidebar "Languages" My FF is in Hebrew.

Thank you for clearing that up  ! So, you do have a Hebrew language pack installed, which is causing the problem.

If you have Firefox in Hebrew, then why would you need a Hebrew language pack  ? Could it be that it is a Hebrew dictionary that you need  ?

I'm also not sure what you mean by not being able to access Preferences, as you are able to go to Add-ons =>
Languages .... (?)

(my apologies for inundating you with a bunch of questions)

''ido1990 [[#answer-1198285|said]]'' <blockquote> It's on the 3-bar menu => Addons (I hope that's the right translation)=>On the left sidebar "Languages" My FF is in Hebrew. </blockquote> Thank you for clearing that up ! So, you ''do'' have a Hebrew language pack installed, which is causing the problem. If you have Firefox in Hebrew, then why would you need a Hebrew language pack ? Could it be that it is a Hebrew dictionary that you need ? I'm also not sure what you mean by not being able to access Preferences, as you ''are'' able to go to Add-ons => <BR>Languages .... (?) (my apologies for inundating you with a bunch of questions)

Question owner

I'm not sure, so I keep the lang pack disabled for now and see if anything changes when I start FF next time.

I don't think it's the dictionary because those have different place.

When I open the menu I see "Addons (CTRL+SHIFT+A)" and one under it "Preferences"

I'm not sure, so I keep the lang pack disabled for now and see if anything changes when I start FF next time. I don't think it's the dictionary because those have different place. When I open the menu I see "Addons (CTRL+SHIFT+A)" and one under it "Preferences"
McCoy
  • Top 10 Contributor
488 solutions 4493 answers

ido1990 said

I'm not sure, so I keep the lang pack disabled for now and see if anything changes when I start FF next time.

Might be a good idea. But I am still puzzled about why you would need a Hebrew language pack, when you have Firefox in Hebrew ..... (?)

I don't think it's the dictionary because those have different place.

I was merely wondering if maybe it was a dictionary you needed.

When I open the menu I see "Addons (CTRL+SHIFT+A)" and one under it "Preferences"

Ahh, you use a keyboard shortcut to get to the Add-ons manager. So, it is clicking on 'Options' (called 'Preferences' on Mac) that won't open  ? But with the Hebrew language pack disabled, that problem is
gone .....

As I still don't see why you would need that language pack, I can only suggest to leave that disabled (for now) and see what happens next time you start Firefox, like you said you would.

Will you keep us posted, please  ?

''ido1990 [[#answer-1198289|said]]'' <blockquote> I'm not sure, so I keep the lang pack disabled for now and see if anything changes when I start FF next time. </blockquote> Might be a good idea. But I am still puzzled about why you would need a Hebrew language pack, when you have Firefox in Hebrew ..... (?) <blockquote> I don't think it's the dictionary because those have different place. </blockquote> I was merely wondering if maybe it was a dictionary you needed. <blockquote> When I open the menu I see "Addons (CTRL+SHIFT+A)" and one under it "Preferences" </blockquote> Ahh, you use a keyboard shortcut to get to the Add-ons manager. So, it is clicking on 'Options' (called 'Preferences' on Mac) that won't open ? But with the Hebrew language pack disabled, that problem is <BR>gone ..... As I still don't see why you would need that language pack, I can only suggest to leave that disabled (for now) and see what happens next time you start Firefox, like you said you would. Will you keep us posted, please ?

Question owner

OK, so it's not "Preferences" in the English version? I guess that's my fault. Sorry. So I can't open the Options page but I can open the Addons.

I attached an image of the menu, you'll probably recognize the items by the icons. The only one who makes issues is the third one with the cog wheel.

OK, so it's not "Preferences" in the English version? I guess that's my fault. Sorry. So I can't open the Options page but I can open the Addons. I attached an image of the menu, you'll probably recognize the items by the icons. The only one who makes issues is the third one with the cog wheel.
McCoy
  • Top 10 Contributor
488 solutions 4493 answers

Yes, the gear (cogwheel) icon - in Windows (and you are on Windows) that's 'Options'.

I just thought of something :

You did not install a Hebrew language package (from the addons.mozilla.org page) - you only set Hebrew as one of the languages in Options => General => under 'Languages'.

If (like you say you have) you downloaded Firefox in Hebrew from www.mozilla.org/firefox/all/ that language pack shouldn't even show up in the Add-ons Manager under 'Languages' .....


Can you access Options/Preferences when you type in the address bar about:preferences and press Enter ?

Yes, the gear (cogwheel) icon - in Windows (and you are on Windows) that's 'Options'. I just thought of something : You did not install a Hebrew language package (from the addons.mozilla.org page) - you only set Hebrew as one of the languages in Options => General => under 'Languages'. If (like you say you have) you downloaded Firefox in Hebrew from www.mozilla.org/firefox/all/ that language pack shouldn't even show up in the Add-ons Manager under 'Languages' ..... -------------------------------------------------------------------------------------------- Can you access Options/Preferences when you type in the address bar '''about:preferences''' and press Enter ?

Modified by McCoy

McCoy
  • Top 10 Contributor
488 solutions 4493 answers

The difference between 'Options' and 'Preferences' is explained in this article :

http://kb.mozillazine.org/Menu_differences_in_Windows%2C_Linux%2C_and_Mac

(it's not so much a matter of translation, but more of interpretation)

The difference between 'Options' and 'Preferences' is explained in this article : http://kb.mozillazine.org/Menu_differences_in_Windows%2C_Linux%2C_and_Mac (it's not so much a matter of translation, but more of interpretation)

Modified by McCoy