X
Tap here to go to the mobile version of the site.

منتدى الدعم

Is the light theme broken in version 65?

Posted

After updating to version 65.0 the built-in light theme seems broken. I can activate the theme, but FF only shows the default theme. Dark (and default) theme is functioning as normal.

Update: I read some people have problems with Dark Theme as well after updating to version 65. It seems Windows colour settings now override Firefox theme settings in inactive tabs, menu and title bar.

Any way to fix this?

Would be thankful for advise.

After updating to version 65.0 the built-in light theme seems broken. I can activate the theme, but FF only shows the default theme. Dark (and default) theme is functioning as normal. Update: I read some people have problems with Dark Theme as well after updating to version 65. It seems Windows colour settings now override Firefox theme settings in inactive tabs, menu and title bar. Any way to fix this? Would be thankful for advise.

Modified by gnabbel

Chosen solution

hi, firefox 65 will now follow your systemwide windows 10 personalisation settings when you have set your accent color to be used for titlebars.

https://bugzilla.mozilla.org/show_bug.cgi?id=1504766#c24 describes a workaround for that though

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5287 solutions 23361 answers

Chosen Solution

hi, firefox 65 will now follow your systemwide windows 10 personalisation settings when you have set your accent color to be used for titlebars.

https://bugzilla.mozilla.org/show_bug.cgi?id=1504766#c24 describes a workaround for that though

hi, firefox 65 will now follow your systemwide windows 10 personalisation settings when you have set your accent color to be used for titlebars. https://bugzilla.mozilla.org/show_bug.cgi?id=1504766#c24 describes a workaround for that though
gcosta 0 solutions 11 answers

Hello, I just tested the light theme and it does the same thing as the dark, see screenshot. As you can see, the title bar is blue, and the areas below is the dark theme I want. The only reason the selected tab is also dark, is because I tried making the changes as noted in the bugzilla response in this question, but it only made the selected tab dark. I want the dark theme just like before, and as I said above also, when the firefox window loses focus, the dark theme becomes active, exactly as I want, but the title bar becomes blue once it regains focus. Also, you will not the blue line near the top of the selected, dark tab, so even that selected tab is not good enough. Before, it was all dark. And, yes, that blue line is enough to be disturbing all by itself.

Do you need a screenshot of the dark theme the way I like it, when firefox does not have the focus?

Hello, I just tested the light theme and it does the same thing as the dark, see screenshot. As you can see, the title bar is blue, and the areas below is the dark theme I want. The only reason the selected tab is also dark, is because I tried making the changes as noted in the bugzilla response in this question, but it only made the selected tab dark. I want the dark theme just like before, and as I said above also, when the firefox window loses focus, the dark theme becomes active, exactly as I want, but the title bar becomes blue once it regains focus. Also, you will not the blue line near the top of the selected, dark tab, so even that selected tab is not good enough. Before, it was all dark. And, yes, that blue line is enough to be disturbing all by itself. Do you need a screenshot of the dark theme the way I like it, when firefox does not have the focus?
gcosta 0 solutions 11 answers

Here is the screenshot of my thyeme as it appears for me now

Here is the screenshot of my thyeme as it appears for me now
gcosta 0 solutions 11 answers

Please either return this to the way firefox did it before 65.0 or have the Windows compliant theme be another theme along side the default, light and dark themes. This is really disturbing to me now.

Please either return this to the way firefox did it before 65.0 or have the Windows compliant theme be another theme along side the default, light and dark themes. This is really disturbing to me now.
gcosta 0 solutions 11 answers

Here's another screenshot of the problem themeing not working as it should

Here's another screenshot of the problem themeing not working as it should
stuarttunstall 0 solutions 2 answers

I have the same issue and it is very annoying and a step back for Firefox in my opinion...

I have solved the issue by changing the personalisation setting .. I have gone to "show accent colour" setting and unticked "titlebar"..

Only issue this changes every bar to light but not a real issue..

I will change it back WHEN Firefox gets put right... I HOPE!

Stuart

I have the same issue and it is very annoying and a step back for Firefox in my opinion... I have solved the issue by changing the personalisation setting .. I have gone to "show accent colour" setting and unticked "titlebar".. Only issue this changes every bar to light but not a real issue.. I will change it back WHEN Firefox gets put right... I HOPE! Stuart

Modified by stuarttunstall

jsrobbins 0 solutions 3 answers

Can't FF updates have the option to leave FF visuals as they were before the update? I would like the FF v65 colors to be the same as they were in version 64. Is that such a revolutionary request? With every update I need to waste my time re-adjusting things. Stop the self important "changes".

Can't FF updates have the option to leave FF visuals as they were before the update? I would like the FF v65 colors to be the same as they were in version 64. Is that such a revolutionary request? With every update I need to waste my time re-adjusting things. Stop the self important "changes".

Question owner

A workaround for the problem is changing the setting browser.tabs.drawInTitlebar to FALSE in about:config.

It is described in comment 34 in this bug thread: https://bugzilla.mozilla.org/show_bug.cgi?id=1504766#c34

EDIT: This solution only works if title bar is set to be shown. If not, you have to use the chosen solution above (comment 24 in the bug thread). It works for both cases.

A workaround for the problem is changing the setting '''browser.tabs.drawInTitlebar''' to FALSE in about:config. It is described in comment 34 in this bug thread: https://bugzilla.mozilla.org/show_bug.cgi?id=1504766#c34 EDIT: This solution only works if title bar is set to be shown. If not, you have to use the chosen solution above (comment 24 in the bug thread). It works for both cases.

Modified by gnabbel

mhosker 0 solutions 2 answers

I am also having this issue except with the dark theme! Very frustrating, and so far I have noticed it is not just limited to the titlebar color, it also defaulted my element inspector back to white, when using the dark theme! Luckily I have found settings within the element inspector to manually flick it back to dark.

Either way, a little frustrating having to spend time changing things after an update!

Mike

I am also having this issue except with the dark theme! Very frustrating, and so far I have noticed it is not just limited to the titlebar color, it also defaulted my element inspector back to white, when using the dark theme! Luckily I have found settings within the element inspector to manually flick it back to dark. Either way, a little frustrating having to spend time changing things after an update! Mike