X
Tap here to go to the mobile version of the site.

منتدى الدعم

Disable autoplay media and all annoying notifications permantly!

Posted

Hi all,

After searching and applying several settings, I am still getting those annoying messages, popups and whatsoever. No matter what I do. I always preferred Firefox as my most favorable browser for many, many years, however I noticed that I started using Chrome more and more because of all these little annoyances.

The last few things I tried are:

about:config dom.webnotifications.enabled (false) dom.push.enabled (false) dom.webnotifications.serviceworker.enabled (false) (for notifications)

about:config media.autoplay.allow-muted (false) media.autoplay.default (2) (for autoplay media)

These ones didn't help: media.autoplay.enabled.user-gestures-needed (false) media.autoplay.ask-permission (false)

Though media doesn't autoplay, I do get a notifcation about if I want to play the media or something similar. Sigh.

Also the help page on Firefox doesn't help at all, like this one: https://support.mozilla.org/en-US/kb/block-autoplay For example; I don't have the "For websites that autoplay sound"-option at all there. See screenshot included.

So what I am trying to here (maybe someone can give me the exact config options):

1. Disable permantly the auto-play function for all media and for all websites 2. Disable every single notification type; I don't want to be asked if I want to play media/sound/music, nor do I want to be asked if I want website notifications or any other kind of notification. I don't want to see a single message at all!!

I hope someone can give me the right settings and/or what to change to make this happen permantly. It's driving me nuts....! Seriously. NUTS! :S

Sidenote; I am also experiencing issues with Firefox on my OnePlus 6T. Sometimes when I enter an URL it doesn't load at all, the screen stays white and doesn't do anything. Closing and starting the app doesn't help. The only solution (sometimes) is to close all my tabs (doesn't matter if it's 10, 40 or 99 tabs). If that fails the solution is a reboot of the phone. And no, it's not the internet connection because a) Chrome wouldn't work, b) nor my other apps. I do use Synchronization between my accounts. The OnePlus 6T was a fresh installation from a couple of weeks ago. Before that (and on my other phone) I had this issue also....

Maybe someone can shed some light as well on the Android issue??

Thank you in advance!

Regards

Hi all, After searching and applying several settings, I am still getting those annoying messages, popups and whatsoever. No matter what I do. I always preferred Firefox as my most favorable browser for many, many years, however I noticed that I started using Chrome more and more because of all these little annoyances. The last few things I tried are: about:config dom.webnotifications.enabled (false) dom.push.enabled (false) dom.webnotifications.serviceworker.enabled (false) (for notifications) about:config media.autoplay.allow-muted (false) media.autoplay.default (2) (for autoplay media) These ones didn't help: media.autoplay.enabled.user-gestures-needed (false) media.autoplay.ask-permission (false) Though media doesn't autoplay, I do get a notifcation about if I want to play the media or something similar. Sigh. Also the help page on Firefox doesn't help at all, like this one: https://support.mozilla.org/en-US/kb/block-autoplay For example; I don't have the "For websites that autoplay sound"-option at all there. See screenshot included. So what I am trying to here (maybe someone can give me the exact config options): 1. Disable permantly the auto-play function for all media and for all websites 2. Disable every single notification type; I don't want to be asked if I want to play media/sound/music, nor do I want to be asked if I want website notifications or any other kind of notification. I don't want to see a single message at all!! I hope someone can give me the right settings and/or what to change to make this happen permantly. It's driving me nuts....! Seriously. NUTS! :S Sidenote; I am also experiencing issues with Firefox on my OnePlus 6T. Sometimes when I enter an URL it doesn't load at all, the screen stays white and doesn't do anything. Closing and starting the app doesn't help. The only solution (sometimes) is to close all my tabs (doesn't matter if it's 10, 40 or 99 tabs). If that fails the solution is a reboot of the phone. And no, it's not the internet connection because a) Chrome wouldn't work, b) nor my other apps. I do use Synchronization between my accounts. The OnePlus 6T was a fresh installation from a couple of weeks ago. Before that (and on my other phone) I had this issue also.... Maybe someone can shed some light as well on the Android issue?? Thank you in advance! Regards
Attached screenshots

Additional System Details

Installed Plug-ins

Just one extension! New Tab Override. Nothing else or it has been disabled / removed.

Two general (?) plugins: - OpenH264-videocodec, aangeboden door Cisco Systems, Inc. - Widevine Content Decryption Module, aangeboden door Google Inc.

But again, I think the above 2 plugins are basic / included ones.

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

WestEnd
  • Top 25 Contributor
60 solutions 5379 answers

That screen shot has nothing to do with autoplay I looked at mine EN that is and there is nothing there stating autoplay disable. And some sites you can't disable autoplay as that is their control now the Browser to control unless the site permits it. And notifications comes from the site or cookies that are used to track. The Browser by itself doesn't do that.

That screen shot has nothing to do with autoplay I looked at mine EN that is and there is nothing there stating autoplay disable. And some sites you can't disable autoplay as that is their control now the Browser to control unless the site permits it. And notifications comes from the site or cookies that are used to track. The Browser by itself doesn't do that.

Question owner

Removed by Moderator. Please refrain from insulting our volunteer contributors who are trying to help you.

<!--#idiot--> ''Removed by Moderator. Please refrain from insulting our volunteer contributors who are trying to help you.

Modified by Noah_SUMO

cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157870 answers

Try this extension for disabling autoplay.

What kind of notifications do you get?

Did you also check the notification permission in "Page Info -> Permissions" ?


You can see all registered service workers on these pages: about:serviceworkers and about:debugging#workers You can check WebSockets via this page: about:networking#websockets See also serviceworker.txt in the profile folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Try this extension for disabling autoplay. *Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/ What kind of notifications do you get? Did you also check the notification permission in "Page Info -> Permissions" ? ---- You can see all registered service workers on these pages: <b>about:serviceworkers</b> and <b>about:debugging#workers</b> You can check WebSockets via this page: <b>about:networking#websockets</b> See also serviceworker.txt in the profile folder. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox