X
Tap here to go to the mobile version of the site.

منتدى الدعم

forms and autofill saves every name I type into it. Can this be stopped

Posted

I use industry specific program called resnexus for managing my bed and breakfast. Every time I search for a guest in the resnexus tab, it adds them to my saved addresses under "Forms and Autofill". I have already created 2 form fills and don't want Firefox to automatically add new items. I want to keep autofill turned on as I do lots of online petitions. Any suggestions?

I use industry specific program called resnexus for managing my bed and breakfast. Every time I search for a guest in the resnexus tab, it adds them to my saved addresses under "Forms and Autofill". I have already created 2 form fills and don't want Firefox to automatically add new items. I want to keep autofill turned on as I do lots of online petitions. Any suggestions?

Chosen solution

Did you check the settings in Options/Preferences for Forms & Autofill and history  ?

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history" -> "Remember form and search history"

You can use these steps to remove saved items from an autocomplete drop-down list.

  1. click the (empty) input field on the web page to open the drop-down list
  2. highlight an entry in the drop-down list with cursor Down key
    do not click the mouse or press the Enter key
  3. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry

Note that hovering with the mouse no longer works.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17538 solutions 158577 answers

Chosen Solution

Did you check the settings in Options/Preferences for Forms & Autofill and history  ?

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history" -> "Remember form and search history"

You can use these steps to remove saved items from an autocomplete drop-down list.

  1. click the (empty) input field on the web page to open the drop-down list
  2. highlight an entry in the drop-down list with cursor Down key
    do not click the mouse or press the Enter key
  3. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry

Note that hovering with the mouse no longer works.

Did you check the settings in Options/Preferences for Forms & Autofill and history ? *Options/Preferences -> Privacy & Security<br>Firefox will: "Use custom settings for history" -> "Remember form and search history" ---- You can use these steps to remove saved items from an autocomplete drop-down list. #click the (empty) input field on the web page to open the drop-down list #highlight an entry in the drop-down list with cursor Down key<br>do not click the mouse or press the Enter key #press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry Note that hovering with the mouse no longer works.

Question owner

Yes I had it set to Remember form and search history. I turned it off, exited and restarted Firefox and that fixed the problem. Thank you

12/17: The problem is back, I did not change any settings and the privacy settings box for "Remember search and form history" is still unchecked. Firefox continues to save every name I type as a saved address. Any other ideas on how to turn this off?

Yes I had it set to Remember form and search history. I turned it off, exited and restarted Firefox and that fixed the problem. Thank you 12/17: The problem is back, I did not change any settings and the privacy settings box for "Remember search and form history" is still unchecked. Firefox continues to save every name I type as a saved address. Any other ideas on how to turn this off?

Modified by Glenno

McCoy
  • Top 10 Contributor
545 solutions 5141 answers

Glenno said

Yes I had it set to Remember form and search history. I turned it off, exited and restarted Firefox and that fixed the problem. Thank you

Would you be so kind as to mark cor-el's post as Chosen Solution ? ('Solved the problem' button to the right)

Thank you in advance  !

''Glenno [[#answer-1181709|said]]'' <blockquote> Yes I had it set to Remember form and search history. I turned it off, exited and restarted Firefox and that fixed the problem. Thank you </blockquote> Would you be so kind as to mark cor-el's post as Chosen Solution ? ('Solved the problem' button to the right) Thank you in advance !

Question owner

12/17: The problem is back, I did not change any settings and the privacy settings box for "Remember search and form history" is still unchecked. Firefox continues to save every name I type as a saved address. Any other ideas on how to turn this off? Anytime I type any name into any form in any website, Firefox adds it to my saved addresses. Shouldn't this be a option and not an automated thing?

12/17: The problem is back, I did not change any settings and the privacy settings box for "Remember search and form history" is still unchecked. Firefox continues to save every name I type as a saved address. Any other ideas on how to turn this off? Anytime I type any name into any form in any website, Firefox adds it to my saved addresses. Shouldn't this be a option and not an automated thing?
cor-el
  • Top 10 Contributor
  • Moderator
17538 solutions 158577 answers

If this only happens with addresses then this is likely the settings under Forms & Autofill. When this feature is enabled then Firefox will save addresses automatically. You can inspect and edit and remove stored addresses, but as long as this feature is enabled addresses will be stored. There is no block exception possible as far as I know.

If this only happens with addresses then this is likely the settings under Forms & Autofill. When this feature is enabled then Firefox will save addresses automatically. You can inspect and edit and remove stored addresses, but as long as this feature is enabled addresses will be stored. There is no block exception possible as far as I know. *https://support.mozilla.org/en-US/kb/automatically-fill-address-and-credit-cards

Helpful Reply

Thank you Cor-el, but even when I had it turned off it was saving names and addresses of people that I searched for in my cloud database.. It would be nice if firefox had an option to "ask before saving" or a "don't add new addresses" setting. I will have to delete the new addresses daily until it is fixed or, I may use another browser just for this and keep firefox for everything else.

Thank you Cor-el, but even when I had it turned off it was saving names and addresses of people that I searched for in my cloud database.. It would be nice if firefox had an option to "ask before saving" or a "don't add new addresses" setting. I will have to delete the new addresses daily until it is fixed or, I may use another browser just for this and keep firefox for everything else.
cor-el
  • Top 10 Contributor
  • Moderator
17538 solutions 158577 answers

Do these addresses show if you click "Saved Addresses" in "Options/Preferences -> Forms & Autofill" ?

Do these addresses show if you click "Saved Addresses" in "Options/Preferences -> Forms & Autofill" ?

Question owner

Yes, normally I have 2 saved address (one for personal and one for work).

Yes, normally I have 2 saved address (one for personal and one for work).
Steve Veach 0 solutions 10 answers

This person is exactly correct. In order for this forms filling feature to be taken seriously, there needs to be a way to allow form filling, but disallow new entries from being saved. Firefox automatically creating endless entries is not useful and more so, keeps me from using the feature entirely.

Most users I would imagine are going to have 1 - 3 entries for their personal information they want saved for forms use and that's all.

This person is exactly correct. In order for this forms filling feature to be taken seriously, there needs to be a way to allow form filling, but disallow ''new'' entries from being saved. Firefox automatically creating endless entries is not useful and more so, keeps me from using the feature entirely. Most users I would imagine are going to have 1 - 3 entries for their personal information they want saved for forms use and that's all.
ispcolohost 0 solutions 1 answers

I feel like something has changed in perhaps the past few months. The current Firefox (MacOS for me) has simply a check box for "Autofill addresses". If it's on, it not only auto fills, but now stores every single thing you're entering in forms; it's quite obnoxious given it presents you with the choice at form submit time of either "update existing address" or store new, you cannot choose no Firefox, don't store the f'ing form I just filled since it has no relevance.

I've had to turn the checkbox off since any given day will see my addresses increase by several, making the feature completely useless. There was some period of time where I feel like it used to have more granular options where you could store, or pre-create, addresses you'd like to use for autofill, but otherwise never prompt or auto store anything new.

I feel like something has changed in perhaps the past few months. The current Firefox (MacOS for me) has simply a check box for "Autofill addresses". If it's on, it not only auto fills, but now stores every single thing you're entering in forms; it's quite obnoxious given it presents you with the choice at form submit time of either "update existing address" or store new, you cannot choose no Firefox, don't store the f'ing form I just filled since it has no relevance. I've had to turn the checkbox off since any given day will see my addresses increase by several, making the feature completely useless. There was some period of time where I feel like it used to have more granular options where you could store, or pre-create, addresses you'd like to use for autofill, but otherwise never prompt or auto store anything new.

Question owner

I switched to chrome (reluctantly). If Firefox can fix this I'd be back in a jiffy

I switched to chrome (reluctantly). If Firefox can fix this I'd be back in a jiffy