X
Tap here to go to the mobile version of the site.

منتدى الدعم

This thread was closed and archived. Please ask a new question if you need help.

How do you completely turn off update checks in Firefox 64?

Posted

I just updated to Firefox version 64 and noticed that you can no longer turn off update checks.

The only available options are "Automatically install updates" and "Check for updates but let you choose to install them".

I administer a public access computer lab and don't want "A new version is available!" popups to appear while our patrons are using our computers.

Is there a way to turn off update checking in this version of Firefox? Perhaps in about:config?

I just updated to Firefox version 64 and noticed that you can no longer turn off update checks. The only available options are "Automatically install updates" and "Check for updates but let you choose to install them". I administer a public access computer lab and don't want "A new version is available!" popups to appear while our patrons are using our computers. Is there a way to turn off update checking in this version of Firefox? Perhaps in about:config?
Attached screenshots

Chosen solution

You can use a policies.json file to disable updates for all users.

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.80 Safari/537.36

More Information

jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

This change was made in Firefox 63. There is no longer a built-in setting to disable update checks. However, you can decline to install an update immediately when you set "Check for updates but let you choose to install them" (it snoozes for 12-24 hours).

This change was made in Firefox 63. There is no longer a built-in setting to disable update checks. However, you can decline to install an update immediately when you set "Check for updates but let you choose to install them" (it snoozes for 12-24 hours).

Question owner

jscher2000 said

This change was made in Firefox 63.

Ah, never noticed it before. Maybe it won't be a problem after all.

jscher2000 said

However, you can decline to install an update immediately when you set "Check for updates but let you choose to install them" (it snoozes for 12-24 hours).

Do you know if there's a way to increase the snooze time?

''jscher2000 [[#answer-1180601|said]]'' <blockquote> This change was made in Firefox 63. </blockquote> Ah, never noticed it before. Maybe it won't be a problem after all. ''jscher2000 [[#answer-1180601|said]]'' <blockquote> However, you can decline to install an update immediately when you set "Check for updates but let you choose to install them" (it snoozes for 12-24 hours). </blockquote> Do you know if there's a way to increase the snooze time?
jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

Helpful Reply

This preference may be related to the snooze time; I haven't researched it in detail:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste app.up and pause while the list is filtered

These correspond to the Options page settings:

  • app.update.auto => False = Check & choose
  • app.update.service.enabled => corresponds to the background service

These mention intervals, but I'm not sure what they do:

  • app.update.interval => default of 43200 seconds is 12 hours
  • app.update.download.backgroundInterval

There are other preferences that mention time and wait.

This preference may be related to the snooze time; I haven't researched it in detail: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''app.up''' and pause while the list is filtered These correspond to the Options page settings: * '''app.update.auto''' => False = Check & choose * '''app.update.service.enabled''' => corresponds to the background service These mention intervals, but I'm not sure what they do: * '''app.update.interval''' => default of 43200 seconds is 12 hours * '''app.update.download.backgroundInterval''' There are other preferences that mention time and wait.
williamodom 0 solutions 3 answers

Interested to see if anyone has made the above solution work or found another one. It's annoying to have the update notice pop up every day; I prefer to check for updates at my convenience, don't need to be constantly reminded.

Interested to see if anyone has made the above solution work or found another one. It's annoying to have the update notice pop up every day; I prefer to check for updates at my convenience, don't need to be constantly reminded.
NUMNUM 1 solutions 7 answers

I need to shut this off too as my intranet workstations shouldnt be trying to update.

I need to shut this off too as my intranet workstations shouldnt be trying to update.
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

Chosen Solution

You can use a policies.json file to disable updates for all users.

You can use a policies.json file to disable updates for all users. *https://github.com/mozilla/policy-templates/blob/master/README.md

Question owner

cor-el said

You can use a policies.json file to disable updates for all users.

Looks like that works. Thanks!

This website also mentions how you can install Firefox group policy settings (only works if you have Windows Pro). You can also disable updates that way.

''cor-el [[#answer-1195330|said]]'' <blockquote> You can use a policies.json file to disable updates for all users. *https://github.com/mozilla/policy-templates/blob/master/README.md </blockquote> Looks like that works. Thanks! This website also mentions how you can install Firefox group policy settings (only works if you have Windows Pro). You can also disable updates that way.
Pham 0 solutions 1 answers

Helpful Reply

Neither solution worked for me. I tried setting app.update.interval to 10 days. No effect.

I also tried implementing the policies.json fix. Perhaps I don't understand exactly how to do it?

GitHub says: "On Windows, create a directory called distribution where the EXE is located and place the file there."

Translation...? Does it mean the firefox.exe EXE? So, on my computer (Windows 7 Pro) I'd create a direcory called "distribution" within: C:\Program Files (x86)\Mozilla Firefox

Correct?

Within the "distribution" directory, I create a file named "policies.json" that contains the following text:

{

 "policies": {
   "DisableAppUpdate": true
 }

}

Correct?

Have I got that all straight?

I'd really like to turn off this Firefox update nag. I prefer to set my own schedule for updating software and find the daily nag annoying.

Neither solution worked for me. I tried setting app.update.interval to 10 days. No effect. I also tried implementing the policies.json fix. Perhaps I don't understand exactly how to do it? GitHub says: "On Windows, create a directory called distribution where the EXE is located and place the file there." Translation...? Does it mean the firefox.exe EXE? So, on my computer (Windows 7 Pro) I'd create a direcory called "distribution" within: C:\Program Files (x86)\Mozilla Firefox Correct? Within the "distribution" directory, I create a file named "policies.json" that contains the following text: { "policies": { "DisableAppUpdate": true } } Correct? Have I got that all straight? I'd really like to turn off this Firefox update nag. I prefer to set my own schedule for updating software and find the daily nag annoying.
cor-el
  • Top 10 Contributor
  • Moderator
17539 solutions 158588 answers

The "C:\Program Files (x86)\Mozilla Firefox" location of the Firefox program folder you posted is for a 32 bit Firefox version. See Help -> About Firefox

  • (64-bit Firefox) "C:\Program Files\Mozilla Firefox\distribution\policies.json"
  • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\distribution\policies.json"

You can check the Browser Console for error messages.

The "C:\Program Files (x86)\Mozilla Firefox" location of the Firefox program folder you posted is for a 32 bit Firefox version. See Help -> About Firefox *(64-bit Firefox) "C:\Program Files\Mozilla Firefox\distribution\policies.json" *(32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\distribution\policies.json" You can check the Browser Console for error messages. *https://developer.mozilla.org/en-US/Tools/Browser_Console
Pj 42 solutions 869 answers

cor-el said

The "C:\Program Files (x86)\Mozilla Firefox" location of the Firefox program folder ... is for a 32 bit Firefox version. See Help -> About Firefox
  • (64-bit Firefox) "C:\Program Files\Mozilla Firefox\distribution\policies.json"
  • (32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\distribution\policies.json"

But my 64-Bit FF is in the x86 Folder. At some point, when I grabbed FF 64-Bit, it must have kept installing FF in my x86 Folder.


~Pj (FF 66.0.2)

''cor-el [[#answer-1198302|said]]'' <blockquote> The "C:\Program Files (x86)\Mozilla Firefox" location of the Firefox program folder ... is for a 32 bit Firefox version. See Help -> About Firefox *(64-bit Firefox) "C:\Program Files\Mozilla Firefox\distribution\policies.json" *(32-bit Firefox) "C:\Program Files (x86)\Mozilla Firefox\distribution\policies.json" </blockquote> But my 64-Bit FF is in the '''x86''' Folder. At some point, when I grabbed FF 64-Bit, it must have kept installing FF in my '''x86''' Folder. ~Pj (FF '''66.0.2''')
jscher2000
  • Top 10 Contributor
8773 solutions 71729 answers

Back when Firefox 56.0.1 changed the default for 64-bit Windows from 32-bit to 64-bit, the updater kept the existing program folder. So it's normal for older installations to be in the (x86) folder.

(This is why Office may go haywire and stop being able to open links during a clean reinstall on Windows, because the path to firefox.exe changes.)

Back when Firefox 56.0.1 changed the default for 64-bit Windows from 32-bit to 64-bit, the updater kept the existing program folder. So it's normal for older installations to be in the (x86) folder. (This is why Office may go haywire and stop being able to open links during a clean reinstall on Windows, because the path to firefox.exe changes.)
NUMNUM 1 solutions 7 answers

kistenmaker said

Or, as a friend of mine suggested, simply delete the updater.exe. Without it the browser won't be able to update, no matter how hard it tries.

Great solution. In my instance I renamed that file _updater.exe and is no longer accessed.

Thank you.

''kistenmaker [[#answer-1211069|said]]'' <blockquote>Or, as a friend of mine suggested, simply delete the updater.exe. Without it the browser won't be able to update, no matter how hard it tries. </blockquote> Great solution. In my instance I renamed that file _updater.exe and is no longer accessed. Thank you.