Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Allowing websites to choose fonts always results in broken font.

  • 5 replies
  • 1 has this problem
  • 101 views
  • آخر ردّ كتبه ZestyCrab

more options

Allowing websites to choose their own fonts always results in borked text. Considering some websites don't look as good when I set a font for Firefox, I'd like a way to fix this particular setting so I can leave it on.

Attached screenshots

Chosen solution

I have found a solution to this problem for anyone who is looking in the future.

Go to your windows search and type "View Advanced Windows Settings"

Under the Advanced tab, click on "Settings..."

Enable "Smooth edges of screen fonts"

Read this answer in context 👍 1

All Replies (5)

more options

What font is used on pages where this happens?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector.

Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab in the right panel of the Inspector.

more options

On this particular page? Open Sans. Attaching a screenshot.

more options

I'm noticing my screenshots aren't showing how bad the font is as it appears to me. Here's a picture.

Note how boxy everything looks and straight lines appear particularly dark.

more options

Also, it does this in the steam interface as well, so I'm wondering if there's something outside of Firefox that can be fixed?

more options

Chosen Solution

I have found a solution to this problem for anyone who is looking in the future.

Go to your windows search and type "View Advanced Windows Settings"

Under the Advanced tab, click on "Settings..."

Enable "Smooth edges of screen fonts"