X
Tap here to go to the mobile version of the site.

منتدى الدعم

[SOLVED]Firefox won't play any video from this domain

Posted

This problem is driving me crazy! It was working until few days ago.

I can't watch any videos from this website/domain: http://redeglobo.globo.com/videos/ Things I've tried: - private browsing - safe mode - new profile/refresh - portable version - uninstall/reinstall - older versions - uninstalled kaspersky/windows defender is disabled - HOSTS file is clean(Windows 7 x64)

The thing is, the ads load but not the video content. If the ad is long, an error message appears while the audio is still playing in the background. Another computer in the same network plays them fine. All other browsers can play these videos, this problem only happens in Firefox. I've tested a virtual machine in this same computer and then it works. Is there anything else I can do to try to fix this?

Firefox console shows these errors: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://vodstreaming02a.video.globo.com/r90_720/v7/e8/93/1e/7164945_1e25dd21ab308227e9961ad4c2a44399a4dc60ff/7164945-manifest.ism/7164945-manifest-audio_por_1=128025-video_por=1967000.m3u8?hls_client_manifest_version=4. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing).

[error][hlsjs: unrecoverable network fatal error.] Object { evt: "hlsError", data: {…} } player.min.js:1:1237298

[error][player_error] Object { description: "hls error: type: networkError, details: levelLoadError, response: {\"code\":0,\"text\":\"\"}", level: "FATAL", origin: "hls", scope: "playback", raw: {…}, code: "hls:networkError_levelLoadError", UI: {…} } player.min.js:1:1237298

This problem is driving me crazy! It was working until few days ago. I can't watch any videos from this website/domain: http://redeglobo.globo.com/videos/ Things I've tried: - private browsing - safe mode - new profile/refresh - portable version - uninstall/reinstall - older versions - uninstalled kaspersky/windows defender is disabled - HOSTS file is clean(Windows 7 x64) The thing is, the ads load but not the video content. If the ad is long, an error message appears while the audio is still playing in the background. Another computer in the same network plays them fine. All other browsers can play these videos, this problem only happens in Firefox. I've tested a virtual machine in this same computer and then it works. Is there anything else I can do to try to fix this? Firefox console shows these errors: Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://vodstreaming02a.video.globo.com/r90_720/v7/e8/93/1e/7164945_1e25dd21ab308227e9961ad4c2a44399a4dc60ff/7164945-manifest.ism/7164945-manifest-audio_por_1=128025-video_por=1967000.m3u8?hls_client_manifest_version=4. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing). [error][hlsjs: unrecoverable network fatal error.] Object { evt: "hlsError", data: {…} } player.min.js:1:1237298 [error][player_error] Object { description: "hls error: type: networkError, details: levelLoadError, response: {\"code\":0,\"text\":\"\"}", level: "FATAL", origin: "hls", scope: "playback", raw: {…}, code: "hls:networkError_levelLoadError", UI: {…} } player.min.js:1:1237298
Attached screenshots

Modified by anitoad

Chosen solution

Well, look at that. Actually the problem persists but now I know where it comes from. Videos started playing again when my PC clock changed automatically to 1 hour earlier. I tried to change time zone with an addon but the website gets the time from the system clock. I suspect it's related to daylight savings. Thanks anyway, I now know it's probably not a Firefox issue.

Read this answer in context 0
Quote
FredMcD
  • Top 10 Contributor
3820 solutions 53017 answers
I had no problem with the short clips. The large one I tried wanted me to login. The clips are streamed, by the way, https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues https://support.mozilla.org/en-US/kb/html5-audio-and-video-firefox
Was this helpful to you? 0
Quote

Question owner

Thanks for your answer. I know, it works anywhere else but I'd really want to understand why it doesn't work in my computer even after reinstalling it and that happens only in that specific domain. I've tried more things like installing ffdshow, xvid, new graphics card drivers but nothing works! This is very frustrating.

Thanks for your answer. I know, it works anywhere else but I'd ''really'' want to understand why it doesn't work in my computer even after reinstalling it and that happens only in that specific domain. I've tried more things like installing ffdshow, xvid, new graphics card drivers but nothing works! This is very frustrating.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3820 solutions 53017 answers

I called for more help.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

I called for more help. Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. * '''Cookies; ''' [https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored Delete cookies to remove the information websites have stored on your computer] {web link} * '''Cache; ''' [https://support.mozilla.org/en-US/kb/how-clear-firefox-cache How to clear the Firefox cache] {web link} If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}
Was this helpful to you?
Quote

Question owner

Yes, I've tried all that including deleting my profile folder.

It all looks like it's something external but I don't know what I'm missing.

Yes, I've tried all that including deleting my profile folder. It all looks like it's something external but I don't know what I'm missing.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16721 solutions 151175 answers

Try to enable third-party cookies temporarily as a test to see if that has effect. If this works then create a cookie "Allow for Session" exception for involved domains. See the Storage Inspector (Tools -> Web Developer) for details about cookies.

Try to enable third-party cookies temporarily as a test to see if that has effect. If this works then create a cookie "Allow for Session" exception for involved domains. See the Storage Inspector (Tools -> Web Developer) for details about cookies.
Was this helpful to you?
Quote

Question owner

Cookies were allowed but I created an exception just in case and it's still happening.

I keep getting these hls errors: hlsjs: non-fatal error occurred (x4 times)

and the last one: hlsjs: unrecoverable network fatal error

Those errors don't appear in the other pc.

Cookies were allowed but I created an exception just in case and it's still happening. I keep getting these hls errors: hlsjs: non-fatal error occurred (x4 times) and the last one: hlsjs: unrecoverable network fatal error Those errors don't appear in the other pc.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16721 solutions 151175 answers

What security software do you have?

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

What security software do you have? Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10
Was this helpful to you?
Quote

Question owner

It doesn't work, I've tried all that already. My other pc can't play those videos in windows safe mode too.

It doesn't work, I've tried all that already. My other pc can't play those videos in windows safe mode too.
Was this helpful to you?
Quote

Question owner

Somehow it's working again, maybe the website devs changed something.

Somehow it's working again, maybe the website devs changed something.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3820 solutions 53017 answers

Wait a few days. If the problem is gone,

Please flag your last post as Solved Problem so others will know.

Wait a few days. If the problem is gone, Please flag your last post as '''Solved Problem''' so others will know.
Was this helpful to you?
Quote

Chosen Solution

Well, look at that. Actually the problem persists but now I know where it comes from. Videos started playing again when my PC clock changed automatically to 1 hour earlier. I tried to change time zone with an addon but the website gets the time from the system clock. I suspect it's related to daylight savings. Thanks anyway, I now know it's probably not a Firefox issue.

Well, look at that. Actually the problem persists but now I know where it comes from. Videos started playing again when my PC clock changed automatically to 1 hour earlier. I tried to change time zone with an addon but the website gets the time from the system clock. I suspect it's related to daylight savings. Thanks anyway, I now know it's probably not a Firefox issue.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3820 solutions 53017 answers

Thanks for letting us know.

Thanks for letting us know.
Was this helpful to you?
Quote
اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.