X
Tap here to go to the mobile version of the site.

منتدى الدعم

Another solution waiting for a problem ... How can one suppress the option for "Container Tabs?"

Posted

And to add insult to injury, it appears where "Open Link in New Window" used to be. I don't use tabbed browsing. Period. I like to hover over the taskbar and let Windows tell me that browser window's URL.

If it can't be suppressed -- because each Firefox user doesn't really know _their_ own preferences -- why not place the "Container Tabs" right-click entry, below "Open Link in New Private Window"? Then users desiring to use such *new* functionality, will learn (muscle-memory don'cha know) it as they go.

Every time y'all force me after an update to figure out how to resume using Firefox in the matter to which I'm accustomed, I move one step closer to shifting to Chrome entirely. (I still use Firefox to access YouTube, because up until several days ago, I was able to download content with a Firefox add-on.)

BTW. I tried to upload a screenshot of the image. The progress icon has been turning for minutes ... It might work on Chrome, but the image upload functionality is broken with version 63.0.1 (x64).

Your "Pocket" ... your "Bookshelf" icon ... etc. ... I wish y'all would let me suppress the display the meg@Kewl new stuff, which I never use.

And to add insult to injury, it appears where "Open Link in New Window" used to be. I don't use tabbed browsing. Period. I like to hover over the taskbar and let Windows tell me that browser window's URL. If it can't be suppressed -- because each Firefox user doesn't really know _their_ own preferences -- why not place the "Container Tabs" right-click entry, below "Open Link in New Private Window"? Then users desiring to use such *new* functionality, will learn (muscle-memory don'cha know) it as they go. Every time y'all force me after an update to figure out how to resume using Firefox in the matter to which I'm accustomed, I move one step closer to shifting to Chrome entirely. (I still use Firefox to access YouTube, because up until several days ago, I was able to download content with a Firefox add-on.) BTW. I tried to upload a screenshot of the image. The progress icon has been turning for minutes ... It might work on Chrome, but the image upload functionality is broken with version 63.0.1 (x64). Your "Pocket" ... your "Bookshelf" icon ... etc. ... I wish y'all would let me suppress the display the meg@Kewl new stuff, which I never use.
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

Hello DisgustedWithNeedlessJunk,

Would you try this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

privacy.userContext.enabled

And make sure its value is set to false

If you had to change the value, then close and restart Firefox.

'Hope that works for you .....


Separate issue :

Your system details show that you need to update your Adobe Flash Player - you're running a very, very old version, which can cause problems. Would you please uninstall your current version and install the latest version, which is 31.0.0.122

Uninstaller : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

https://get.adobe.com/flashplayer/

Note : some 'extras' may be offered in the download.

Hello DisgustedWithNeedlessJunk, Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''privacy.userContext.enabled''' And make sure its value is set to '''false''' If you had to change the value, then close and restart Firefox. 'Hope that works for you ..... ---------------------------------------------------------------------------------------------- Separate issue : Your system details show that you need to update your Adobe Flash Player - you're running a very, very old version, which can cause problems. Would you please uninstall your current version and install the latest version, which is '''31.0.0.122''' Uninstaller : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html https://get.adobe.com/flashplayer/ Note : some 'extras' may be offered in the download.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

DisgustedWithNeedlessJunk said

I don't use tabbed browsing. Period.

Maybe you would be interested in my "I Hate Tabs" add-on: https://addons.mozilla.org/firefox/addon/i-hate-tabs-sdi-for-firefox/

Your "Pocket" ... your "Bookshelf" icon ... etc. ... I wish y'all would let me suppress the display the meg@Kewl new stuff, which I never use.

Did you already find the methods to remove those items?

  • Icons in the "Page Actions" area inside/at the right end of the address bar: right-click > Remove from Address Bar
  • Toolbar buttons on the main toolbar: right-click > Remove from Toolbar

Although the combined "Library" dialog is shown by default, there are separate "Bookmarks menu" and "History" icons available in the Customize panel. See: Customize Firefox controls, buttons and toolbars.

''DisgustedWithNeedlessJunk [[#question-1239251|said]]'' <blockquote> I don't use tabbed browsing. Period. </blockquote> Maybe you would be interested in my "I Hate Tabs" add-on: https://addons.mozilla.org/firefox/addon/i-hate-tabs-sdi-for-firefox/ <blockquote> Your "Pocket" ... your "Bookshelf" icon ... etc. ... I wish y'all would let me suppress the display the meg@Kewl new stuff, which I never use. </blockquote> Did you already find the methods to remove those items? * Icons in the "Page Actions" area inside/at the right end of the address bar: right-click > Remove from Address Bar * Toolbar buttons on the main toolbar: right-click > Remove from Toolbar Although the combined "Library" dialog is shown by default, there are separate "Bookmarks menu" and "History" icons available in the Customize panel. See: [[Customize Firefox controls, buttons and toolbars]].

Question owner

McCoy said

Would you try this please : Type in the address bar about:config and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : privacy.userContext.enabled And make sure its value is set to false If you had to change the value, then close and restart Firefox. 'Hope that works for you .....

Regrettably, this won't permanently fix the problem. It works as long as the browser instance is not closed/restarted. Running the browser with elevated privileges (Run as administrator) and performing the edit similarly will not fix the problem. The next browser session has the same right-click behavior.

McCoy said

Separate issue : Your system details show that you need to update your Adobe Flash Player - you're running a very, very old version, which can cause problems.

It only causes problems if it's run <g>. It's been years since I've had occasion to invoke the Firefox Flash Player plug-in. That said I uninstalled it. Thanks for the head's up!

''McCoy [[#answer-1169539|said]]'' <blockquote> Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''privacy.userContext.enabled''' And make sure its value is set to '''false''' If you had to change the value, then close and restart Firefox. 'Hope that works for you ..... </blockquote> Regrettably, this won't permanently fix the problem. It works as long as the browser instance is '''''not''''' closed/restarted. Running the browser with elevated privileges (Run as administrator) and performing the edit similarly will not fix the problem. The next browser session has the same right-click behavior. ''McCoy [[#answer-1169539|said]]'' <blockquote> Separate issue : Your system details show that you need to update your Adobe Flash Player - you're running a very, very old version, which can cause problems. </blockquote> It only causes problems if it's run <g>. It's been years since I've had occasion to invoke the Firefox Flash Player plug-in. That said I uninstalled it. Thanks for the head's up!

Question owner

jscher2000 said

Maybe you would be interested in my "I Hate Tabs" add-on: https://addons.mozilla.org/firefox/addon/i-hate-tabs-sdi-for-firefox/

Thanks for the suggestion! It is now installed. As a backstop don'cha know. My muscle memory takes me ... errr .. took me ... directly to "Open in New Window"

To use a German saying, 'I'm one who always wants to have an extra sausage grilled for me.' Can you, @jscherr2000, figure out a way to get rid of both Tab selections in the right-click context menu ("Open Link in New Tab" and "Open Link in New Container Tab")? As a name for this new functionality -- should you elect to continue down the no-tab path -- I'd like to suggest: "Seriously. I Hate Eff-ing Tabs!"<g>

Did you already find the methods to remove those <other> items

Yeah, I got those taken care of. It's just the presumption by the Firefox development team that's frustrating. "If you build it, they will come," works for baseball movies like Field of Dreams ... but not for many of the whacky 'improvements' that us users are forced into figuring out how to suppress. New often does not equal better!

''jscher2000 [[#answer-1169543|said]]'' <blockquote> Maybe you would be interested in my "I Hate Tabs" add-on: https://addons.mozilla.org/firefox/addon/i-hate-tabs-sdi-for-firefox/ </blockquote> Thanks for the suggestion! It is now installed. As a backstop don'cha know. My muscle memory takes me ... errr .. took me ... directly to "Open in New Window" To use a German saying, 'I'm one who always wants to have an extra sausage grilled for me.' Can you, '''@jscherr2000''', figure out a way to get rid of both Tab selections in the right-click context menu ("Open Link in New Tab" and "Open Link in New Container Tab")? As a name for this new functionality -- should you elect to continue down the no-tab path -- I'd like to suggest: "Seriously. I Hate Eff-ing Tabs!"<g> <blockquote> Did you already find the methods to remove those <''other''> items </blockquote> Yeah, I got those taken care of. It's just the presumption by the Firefox development team that's frustrating. "If you build it, they will come," works for baseball movies like ''Field of Dreams'' ... but not for many of the whacky 'improvements' that us users are forced into figuring out how to suppress. New often '''''does not''''' equal better!
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

If you do not want to use containers then you can disable this feature by setting this pref to false on the about:config page.

  • privacy.userContext.enabled = false
If you do not want to use containers then you can disable this feature by setting this pref to false on the <b>about:config</b> page. *privacy.userContext.enabled = false

Question owner

cor-el said

If you do not want to use containers then you can disable this feature by setting this pref to false on the about:config page.
  • privacy.userContext.enabled = false

As I responded to @McCoy above, who already provided this answer, I attempted this both as a named user, and using "Run as Administrator". The change does not survive a restart. Period.

I'm happy to provide logging information if y'all tell me what to record. But the change described will not stick; and I see no especial option for saving the change to about:config. Normally ending the browser session -- after changing the setting, then navigating to DuckDuckGo -- and subsequently restarting the browser (both user- and admin-access) show the right-click menu always reverts to its initial appearance.

''cor-el [[#answer-1169664|said]]'' <blockquote> If you do not want to use containers then you can disable this feature by setting this pref to false on the <b>about:config</b> page. *privacy.userContext.enabled = false </blockquote> As I responded to '''@McCoy''' above, who already provided this answer, I attempted this both as a named user, and using "Run as Administrator". The change does not survive a restart. Period. I'm happy to provide logging information if y'all tell me what to record. But the change described will not stick; and I see no especial option for saving the change to about:config. Normally ending the browser session -- after changing the setting, then navigating to DuckDuckGo -- and subsequently restarting the browser (both user- and admin-access) show the right-click menu always reverts to its initial appearance.
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

You can try to use a user.js file in the Firefox profile folder to force a specific state of this pref.

user_pref("privacy.userContext.enabled", false);

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

You can try to use a user.js file in the Firefox profile folder to force a specific state of this pref. <pre><nowiki>user_pref("privacy.userContext.enabled", false);</nowiki></pre> *http://kb.mozillazine.org/user.js_file You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox
cor-el
  • Top 10 Contributor
  • Moderator
17521 solutions 158427 answers

You can also use code in userChrome.css to hide this context menu item.

Add code to the userChrome.css file below the default @namespace line.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */

#context-openlinkincontainertab { display:none !important; }

It is not that difficult to create userChrome.css if you have never used it.

The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder.

You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name chrome in this folder (name is all lowercase). In the chrome folder you need to create a text file with the name userChrome.css (name is case sensitive). In this userChrome.css text file you paste the text posted.

In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named userChrome.css.txt. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as".

You need to close and restart Firefox when you create or modify the userChrome.css file.

You can also use code in userChrome.css to hide this context menu item. Add code to the <b>userChrome.css</b> file below the default @namespace line. *http://kb.mozillazine.org/userChrome.css <hr> <pre><nowiki>@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); /* only needed once */ #context-openlinkincontainertab { display:none !important; } </nowiki></pre> ---- It is not that difficult to create userChrome.css if you have never used it. The first step is to open the "Help -> Troubleshooting Information" page and find the button to access the profile folder. *https://support.mozilla.org/en-US/kb/use-troubleshooting-information-page-fix-firefox You can find this button under the "Application Basics" section as "Profile Folder -> Open Folder". If you click this button then you open the profile folder in the Windows File Explorer. You need to create a folder with the name <u>chrome</u> in this folder (name is all lowercase). In the <b>chrome</b> folder you need to create a text file with the name <u>userChrome.css</u> (name is case sensitive). In this userChrome.css text file you paste the text posted. In Windows saving the file is usually the only time things get more complicated because Windows can silently add a .txt file extension and you end up with a file named <i>userChrome.css.txt</i>. To avoid this you need to make sure to select "All files" in the dialog to save the file in the text editor using "Save File as". You need to close and restart Firefox when you create or modify the userChrome.css file.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

DisgustedWithNeedlessJunk said

McCoy said
Would you try this please : Type in the address bar about:config and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : privacy.userContext.enabled And make sure its value is set to false If you had to change the value, then close and restart Firefox. 'Hope that works for you .....
Regrettably, this won't permanently fix the problem. It works as long as the browser instance is not closed/restarted.

This preference is false by default in Firefox 63. If it gets turned back to true at startup, there are a few possible explanations for that:

(1) Do you have any add-ons that might be turning it on?

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions containers or private tabs? Anything you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

(2) Do you have a user.js file in your profile?

There is a section of the following article about the optional user.js file that Firefox uses to override your previous session preferences at startup: How to fix preferences that won't save.

(3) Do you have any Autoconfig files modifying your Firefox preferences at startup?

This is much less common, but just in case, these articles explain how those are set up:

''DisgustedWithNeedlessJunk [[#answer-1169635|said]]'' <blockquote> ''McCoy [[#answer-1169539|said]]'' <blockquote> Would you try this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''privacy.userContext.enabled''' And make sure its value is set to '''false''' If you had to change the value, then close and restart Firefox. 'Hope that works for you ..... </blockquote> Regrettably, this won't permanently fix the problem. It works as long as the browser instance is '''''not''''' closed/restarted.</blockquote> This preference is '''false''' by default in Firefox 63. If it gets turned back to true at startup, there are a few possible explanations for that: (1) Do you have any add-ons that might be turning it on? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions containers or private tabs? Anything you just do not remember installing or why? If in doubt, disable (or remove). Any improvement? (2) Do you have a user.js file in your profile? There is a section of the following article about the optional user.js file that Firefox uses to override your previous session preferences at startup: [[How to fix preferences that won't save]]. (3) Do you have any Autoconfig files modifying your Firefox preferences at startup? This is much less common, but just in case, these articles explain how those are set up: * [[Customizing Firefox Using AutoConfig]] * http://kb.mozillazine.org/Locking_preferences