X
Tap here to go to the mobile version of the site.

منتدى الدعم

Firefox always asking to answer puzzles on Recaptcha

Posted

I've installed the latest version of Firefox. Firefox Quantum 63 x64 and ReCaptchas don't work properly. It has been installed on a fresh Windows 10 Pro and Firefox it's at the same time a fresh install like I'm showing on the video at the end of this post. No firewall, no antivirus, no addons, nothing that should stop Firefox from automatically do the ReCaptcha. But every time you click on I'm not a Robot it always prompts you to do a puzzle.

Please Firefox, fix this issue. It is pretty frustrating to have to answer every time a puzzle that are ridiculously annoying or having to switch to Google Chrome to use those kind of pages that ask you to answer a ReCaptcha.

However, if there is anyone that has a solution, please share it with me or all of us. Because I've been trying to find an answer and haven't find one that works. So I will appreciate a good fix for it.

Thanks in advance to the community and hopefully Firefox finds a fix because for what I've read it's a persistent issue with other older versions too.

https://www.youtube.com/watch?v=8naCIATQXjY

I've installed the latest version of Firefox. Firefox Quantum 63 x64 and ReCaptchas don't work properly. It has been installed on a fresh Windows 10 Pro and Firefox it's at the same time a fresh install like I'm showing on the video at the end of this post. No firewall, no antivirus, no addons, nothing that should stop Firefox from automatically do the ReCaptcha. But every time you click on I'm not a Robot it always prompts you to do a puzzle. Please Firefox, fix this issue. It is pretty frustrating to have to answer every time a puzzle that are ridiculously annoying or having to switch to Google Chrome to use those kind of pages that ask you to answer a ReCaptcha. However, if there is anyone that has a solution, please share it with me or all of us. Because I've been trying to find an answer and haven't find one that works. So I will appreciate a good fix for it. Thanks in advance to the community and hopefully Firefox finds a fix because for what I've read it's a persistent issue with other older versions too. https://www.youtube.com/watch?v=8naCIATQXjY

Chosen solution

jscher2000

After doing some more testing, you were right. I tested with Chrome fresh installed and tried to go to ReCaptcha Demo as I showed on the video and did the same test. A puzzle showed up. I did try to do it and then re-open the site but the same happened a puzzle showed up.

Then I tried what you suggested. I logged in on my Chrome with my Google account. Tried again and tadaaaa !!! Didn't ask for a puzzle. It checked the box and allowed me to go forward.

Then I tried the same thing with my Firefox. Logged in with my Google account. And tested again. Tadaaaa !!! Didn't ask for puzzle.

So then I was wondering.... why does Firefox ask me every single time on my PC? So my guess is that I'm using Multi-Account Container. And I'm using my Google account on a separate container.

I haven't test it yet with out a container. But I believe that is my issue. Will come back with more answers. But I think I'm going on the good track thanks to you guys answers. I would have not think about these solutions.

Thanks !!!

Will answer tomorrow with what I find out.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

I'm confused by your video. You went to the ReCAPTCHA demo page and clicked the box indicating you are not a robot, and the page asked you to solved a CAPTCHA. I think that's the point of that page, to demonstrate how it works.

After you pass a CAPTCHA on a normal site, Google would set a cookie so that it recognizes you and accepts your word that you are not a robot the next time. If that is not happening on yours, is it possible you are blocking or clearing cookies, either through Firefox settings, or use of private windows (cookies are flushed automatically when the last private window is closed), or add-ons?

I'm confused by your video. You went to the ReCAPTCHA demo page and clicked the box indicating you are not a robot, and the page asked you to solved a CAPTCHA. I think that's the point of that page, to demonstrate how it works. After you pass a CAPTCHA on a normal site, Google would set a cookie so that it recognizes you and accepts your word that you are not a robot the next time. If that is not happening on yours, is it possible you are blocking or clearing cookies, either through Firefox settings, or use of private windows (cookies are flushed automatically when the last private window is closed), or add-ons?

Question owner

Firefox is fresh installed. So there are no addons or anything that flushes cookies. However, doesn't matter if I solve the puzzle, if I go back to the same page it still asking to do a puzzle, doesn't matter how many times I try and solve the puzzle, it will always keep asking to solve a new one.

It doesn't happen with Chrome. With Chrome from the 1st try doesn't ask for any puzzle and allows me to go forward with the submit button. Does not matter how many times I reload the page but chrome doesn't ask me for a puzzle. Even tho if I clean cookies (I've also tested it).

The idea of recaptcha isn't to make you do the puzzle. You have to do the puzzle if it thinks you are a "robot". Something is in Firefox that makes recaptcha think you aren't a person and that's why it makes you do the puzzle. So that's why I'm asking.. if there is anything on about:config that needs to be changed. Because that issue doesn't happen with Google Chrome. And I wouldn't like to switch to Chrome again. But it is pretty annoying having to solve every time the puzzle from recaptcha with Firefox.

Firefox is fresh installed. So there are no addons or anything that flushes cookies. However, doesn't matter if I solve the puzzle, if I go back to the same page it still asking to do a puzzle, doesn't matter how many times I try and solve the puzzle, it will always keep asking to solve a new one. It doesn't happen with Chrome. With Chrome from the 1st try doesn't ask for any puzzle and allows me to go forward with the submit button. Does not matter how many times I reload the page but chrome doesn't ask me for a puzzle. Even tho if I clean cookies (I've also tested it). The idea of recaptcha isn't to make you do the puzzle. You have to do the puzzle if it thinks you are a "robot". Something is in Firefox that makes recaptcha think you aren't a person and that's why it makes you do the puzzle. So that's why I'm asking.. if there is anything on about:config that needs to be changed. Because that issue doesn't happen with Google Chrome. And I wouldn't like to switch to Chrome again. But it is pretty annoying having to solve every time the puzzle from recaptcha with Firefox.

Modified by zios007

jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Your post was made from Firefox 60 (if the user agent string was accurate). Is this problem only in Firefox 63 or also in Firefox 60?

The only site where I see reCAPTCHA regularly is GoDaddy's whois search (https://www.godaddy.com/whois). Today it is not keeping track of my having previously solved the puzzle. This might be due to a change between Firefox 62 and 63, but I noticed that if I am logged into my Google account, then I just have to check the box. I wonder if there has been a change on Google's end with reCAPTCHA.

That works the other way, too. If I am not logged into my Google account in Chrome (through the website or the browser), I get the challenge over and over.

Maybe in Chrome you entered your Google account credentials somewhere before testing? It's not an option to log Firefox into your Google account automatically; you would need to log in through Google's website.

Your post was made from Firefox 60 (if the user agent string was accurate). Is this problem only in Firefox 63 or also in Firefox 60? The only site where I see reCAPTCHA regularly is GoDaddy's whois search ([https://www.godaddy.com/whois]). Today it is not keeping track of my having previously solved the puzzle. This might be due to a change between Firefox 62 and 63, but I noticed that if I am logged into my Google account, then I just have to check the box. I wonder if there has been a change on Google's end with reCAPTCHA. That works the other way, too. If I am not logged into my Google account in Chrome (through the website or the browser), I get the challenge over and over. Maybe in Chrome you entered your Google account credentials somewhere before testing? It's not an option to log Firefox into your Google account automatically; you would need to log in through Google's website.
cor-el
  • Top 10 Contributor
  • Moderator
17519 solutions 158412 answers

This might also be related to the third-party cookie settings. Firefox 63 comes with a new Content Blocking section that includes third-party cookies that might affect this. You can try to create a (third-party) cookie allow exception for the recaptcha domain.

This might also be related to the third-party cookie settings. Firefox 63 comes with a new Content Blocking section that includes third-party cookies that might affect this. You can try to create a (third-party) cookie allow exception for the recaptcha domain.

Question owner

cor-el said

This might also be related to the third-party cookie settings. Firefox 63 comes with a new Content Blocking section that includes third-party cookies that might affect this. You can try to create a (third-party) cookie allow exception for the recaptcha domain.

I will try doing that.

''cor-el [[#answer-1167932|said]]'' <blockquote> This might also be related to the third-party cookie settings. Firefox 63 comes with a new Content Blocking section that includes third-party cookies that might affect this. You can try to create a (third-party) cookie allow exception for the recaptcha domain. </blockquote> I will try doing that.

Question owner

jscher2000 said

Your post was made from Firefox 60 (if the user agent string was accurate). Is this problem only in Firefox 63 or also in Firefox 60? The only site where I see reCAPTCHA regularly is GoDaddy's whois search (https://www.godaddy.com/whois). Today it is not keeping track of my having previously solved the puzzle. This might be due to a change between Firefox 62 and 63, but I noticed that if I am logged into my Google account, then I just have to check the box. I wonder if there has been a change on Google's end with reCAPTCHA. That works the other way, too. If I am not logged into my Google account in Chrome (through the website or the browser), I get the challenge over and over. Maybe in Chrome you entered your Google account credentials somewhere before testing? It's not an option to log Firefox into your Google account automatically; you would need to log in through Google's website.

I'm not sure if I've been logged in with my Google account on my Firefox. On my test on the VM to record the video I wasn't. But I'm pretty sure that in my computer or my laptop I'm logged in with Google all the time and have the same issue. But will make sure and will get back with an answer.

And the Firefox version is Firefox Quantum 63 as you can see in the following image.

I surf many websites that has ReCaptchas... and I'm hating it since I moved to Firefox recently.

''jscher2000 [[#answer-1167921|said]]'' <blockquote> Your post was made from Firefox 60 (if the user agent string was accurate). Is this problem only in Firefox 63 or also in Firefox 60? The only site where I see reCAPTCHA regularly is GoDaddy's whois search ([https://www.godaddy.com/whois]). Today it is not keeping track of my having previously solved the puzzle. This might be due to a change between Firefox 62 and 63, but I noticed that if I am logged into my Google account, then I just have to check the box. I wonder if there has been a change on Google's end with reCAPTCHA. That works the other way, too. If I am not logged into my Google account in Chrome (through the website or the browser), I get the challenge over and over. Maybe in Chrome you entered your Google account credentials somewhere before testing? It's not an option to log Firefox into your Google account automatically; you would need to log in through Google's website. </blockquote> I'm not sure if I've been logged in with my Google account on my Firefox. On my test on the VM to record the video I wasn't. But I'm pretty sure that in my computer or my laptop I'm logged in with Google all the time and have the same issue. But will make sure and will get back with an answer. And the Firefox version is Firefox Quantum 63 as you can see in the following image. I surf many websites that has ReCaptchas... and I'm hating it since I moved to Firefox recently.

Modified by zios007

Chosen Solution

jscher2000

After doing some more testing, you were right. I tested with Chrome fresh installed and tried to go to ReCaptcha Demo as I showed on the video and did the same test. A puzzle showed up. I did try to do it and then re-open the site but the same happened a puzzle showed up.

Then I tried what you suggested. I logged in on my Chrome with my Google account. Tried again and tadaaaa !!! Didn't ask for a puzzle. It checked the box and allowed me to go forward.

Then I tried the same thing with my Firefox. Logged in with my Google account. And tested again. Tadaaaa !!! Didn't ask for puzzle.

So then I was wondering.... why does Firefox ask me every single time on my PC? So my guess is that I'm using Multi-Account Container. And I'm using my Google account on a separate container.

I haven't test it yet with out a container. But I believe that is my issue. Will come back with more answers. But I think I'm going on the good track thanks to you guys answers. I would have not think about these solutions.

Thanks !!!

Will answer tomorrow with what I find out.

''jscher2000'' After doing some more testing, you were right. I tested with Chrome fresh installed and tried to go to ReCaptcha Demo as I showed on the video and did the same test. A puzzle showed up. I did try to do it and then re-open the site but the same happened a puzzle showed up. Then I tried what you suggested. I logged in on my Chrome with my Google account. Tried again and tadaaaa !!! Didn't ask for a puzzle. It checked the box and allowed me to go forward. Then I tried the same thing with my Firefox. Logged in with my Google account. And tested again. Tadaaaa !!! Didn't ask for puzzle. So then I was wondering.... why does Firefox ask me every single time on my PC? So my guess is that I'm using Multi-Account Container. And I'm using my Google account on a separate container. I haven't test it yet with out a container. But I believe that is my issue. Will come back with more answers. But I think I'm going on the good track thanks to you guys answers. I would have not think about these solutions. Thanks !!! Will answer tomorrow with what I find out.

Modified by zios007

Question owner

Well I wasn't able to wait until tomorrow.

I took out my Google Account of sandboxing with Multi-Account Containers and that worked. Dah!

I'm stupid haha Didn't think about it.

Didn't realized that my cookies were contained on that specified container and my surfing outside of that specific container wasn't able to read my cookies.

Yeap... I wasn't too smart lol

Thanks for the help. That made my day.

Well I wasn't able to wait until tomorrow. I took out my Google Account of sandboxing with Multi-Account Containers and that worked. Dah! I'm stupid haha Didn't think about it. Didn't realized that my cookies were contained on that specified container and my surfing outside of that specific container wasn't able to read my cookies. Yeap... I wasn't too smart lol Thanks for the help. That made my day.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Thank you for the additional testing. I hadn't realized that the reCAPTCHA wouldn't get the cookies from the container. I assumed because it runs in a frame, reCAPTCHA would be in the container. But apparently it's the other way around. That kind of makes sense because that API call would link your visit to whatever site it is with your Google cookie, which is what we want to avoid.

I guess if you find yourself having to fill these really often, you could create a second Google account just for "outside the container" use. If that doesn't totally confuse the extension.

Thank you for the additional testing. I hadn't realized that the reCAPTCHA ''wouldn't'' get the cookies from the container. I assumed because it runs in a frame, reCAPTCHA would be in the container. But apparently it's the other way around. That kind of makes sense because that API call would link your visit to whatever site it is with your Google cookie, which is what we want to avoid. I guess if you find yourself having to fill these really often, you could create a second Google account just for "outside the container" use. If that doesn't totally confuse the extension.

Modified by jscher2000

Question owner

jscher2000 said

Thank you for the additional testing. I hadn't realized that the reCAPTCHA wouldn't get the cookies from the container. I assumed because it runs in a frame, reCAPTCHA would be in the container. But apparently it's the other way around. That kind of makes sense because that API call would link your visit to whatever site it is with your Google cookie, which is what we want to avoid. I guess if you find yourself having to fill these really often, you could create a second Google account just for "outside the container" use. If that doesn't totally confuse the extension.

I may do that. I may create another Google Account just to have that capability and not having my personal Google Account shared with my normal surfing. Great idea, thanks for sharing.

''jscher2000 [[#answer-1167967|said]]'' <blockquote> Thank you for the additional testing. I hadn't realized that the reCAPTCHA ''wouldn't'' get the cookies from the container. I assumed because it runs in a frame, reCAPTCHA would be in the container. But apparently it's the other way around. That kind of makes sense because that API call would link your visit to whatever site it is with your Google cookie, which is what we want to avoid. I guess if you find yourself having to fill these really often, you could create a second Google account just for "outside the container" use. If that doesn't totally confuse the extension. </blockquote> I may do that. I may create another Google Account just to have that capability and not having my personal Google Account shared with my normal surfing. Great idea, thanks for sharing.