ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I need Firefox 52.9.0esr.dmg

  • 2 (ردّان اثنان)
  • 1 has this problem
  • 1678 views
  • آخر ردّ كتبه McCoy

more options

I work with a program called Synergy sports technology. This software requires Microsoft silver light which is not compatible with safari and Mojave on the Mac.

الحل المُختار

Hello Coachdefoe,

The above mentioned link leads to the ESR 60.0 version   -   in this case you will need :

https://ftp.mozilla.org/pub/firefox/releases/52.9.0esr/mac/

Also see :

https://discussions.apple.com/message/33934025?replyId=33934630#33934630

(scroll down to : " Be careful not to update it to 60.* ESR ")

Read this answer in context 👍 0

All Replies (2)

more options

Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

more options

الحل المُختار

Hello Coachdefoe,

The above mentioned link leads to the ESR 60.0 version   -   in this case you will need :

https://ftp.mozilla.org/pub/firefox/releases/52.9.0esr/mac/

Also see :

https://discussions.apple.com/message/33934025?replyId=33934630#33934630

(scroll down to : " Be careful not to update it to 60.* ESR ")