Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

website https://www.mlb.com/standings was recently updated. Firefox cannot display it but Microsoft Edge displays it fine. My version of Firefox is up-to-date

  • 7 replies
  • 0 have this problem
  • 100 views
  • آخر ردّ كتبه vogt1

more options

please fix

Chosen solution

I added https://www.mlb.com/standings to uBlock Origin Whitelist then restarted Firefox. Now the page loads properly. Thanks for your help!

Read this answer in context 👍 0

All Replies (7)

more options

How much of the page can you see? When I unblock most everything and disable tracking protection, there are lots and lots of stats (screenshot example attached).

If a site is generally known to work in Firefox, these are some suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Tracking Protection feature and extensions that counter ads and tracking may break websites that weren't built to operate normally without the blocked components.

Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: What happened to Tracking Protection?.

Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Hello vogt1,

The site displays just fine for me .....

You can try these steps in case of issues with web pages : Reload the page : Hold down the Shift key and left-click the Reload button or press 'Ctrl + F5' or press 'Ctrl + Shift + R'

Another thing to try :

Clear the Cache and remove the Cookies from websites that cause problems via the 3-bar menu (or Tools) : => Options / Preferences :
"Remove the Cookies" from websites that cause problems :
• Options/Preferences => Privacy & Security => Cookies and Site Data => Manage Data
"Clear the Cache":
• Options / Preferences => Privacy & Security => Cookies and Site Data => Clear Data =>
Cached Web Content : Clear


If the above doesn't help, then let's try Firefox in Safe Mode, to see if maybe one of your extensions (if you have any) could be causing this :

If Firefox is not running : Hold down the Shift key when starting Firefox.

If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Any difference  ?

more options

Looks like jscher2000 and I posted at the same time ......

more options

McCoy said

Looks like jscher2000 and I posted at the same time ......

At least we are on the same page!

more options

Clearing my MLB cookies didn't help, but starting Firefox in safe mode did allow the page to load. How do I determine what is causing the problem. I do use uBlock Origin. I am not willing to give that up, if that is causing the problem.

more options

uBlock Origin has a toolbar button to let you make site-specific exceptions. You could see whether that helps with MLB (you might need to reload the page between changes).

more options

Chosen Solution

I added https://www.mlb.com/standings to uBlock Origin Whitelist then restarted Firefox. Now the page loads properly. Thanks for your help!