ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is non responsive when it opens.

  • 16 ردًا
  • 1 has this problem
  • 54 views
  • آخر ردّ كتبه cor-el

more options

Firefox was running slowly, so I closed Firefox and re-booted the computer. When I tried to re-initialize Firefox, only the very top portion, above the solid line, came up, and Firefox was immediately not responsive, and it would close only via the Windows "not responsive" window or the Task Master, not via the "x" in the upper right. I tried to initialize several times, re-booted, and tried again. I have also tried uninstalling and re-installing Firefox, with the same result. Is there any way that I can get Firefox back?

Note: I'm using Google Chrome now, because Firefox won't work at all.

All Replies (16)

more options

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

I tried to start Firefox in safe mode, then I started windows in safe mode and attempted to start Firefox in safe mode. In both cases, I got the same result as before; Firefox didn't display the complete screen and was not responsive.

more options

Hello,

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

more options

When Firefox attempts to start, the Menu button is one of the few parts of the Firefox screen that shows, but Firefox is not responsive at that point, so it does not respond to the menu button.

more options

see if your firewall or anti-virus blocks or restricts Firefox without informing you.

Modified by FFus3r

more options

Use one of these to close Firefox if you are currently doing that by clicking the close X on the Firefox title bar.

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit

It is possible that your firewall or other security software blocks or restricts Firefox without informing you, possibly after detecting changes (update) to the Firefox application. Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access for Firefox and the plugin-container process and the updater process. See:

more options

If the above does not help,

Let’s do a full clean re-install;

Download Firefox For All languages And Systems {web link}

Save the file. Then Close Firefox.

Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Mac: Open the "Applications" folder. https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

Linux: Check your user manual. If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it. See Install Firefox on Linux; https://support.mozilla.org/en-US/kb/install-firefox-linux

If you downloaded and installed the binary package from the Firefox download page, simply remove the folder Firefox in your home directory. http://www.mozilla.org/firefox#desktop ++++++++++++++++++++++++++++ Look for, and remove any Mozilla or Firefox program folders. Do not remove the Mozilla Thunderbird folder if there is one.

Do Not remove any profile folders.

After rebooting the computer, run a registry scanner if you have one. Then run the installer. +++++++++++++++++++++++++++ If there is a problem, start your Computer in safe mode and try again.

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode This shows how to Start all Computers in Safe Mode; Free Online Encyclopedia

more options

I deleted the Mozilla and Firefox folders in both Program Files and Program Files (x86), re-booted, and used the installation on the site linked above. The results were the same, only the very top lines appeared on the screen and Firefox was immediately not responsive. I then deleted the Mozilla and Firefox folders again and re-booted in safe mode and again attempted the installation, again with the same result. I just attempted to start Firefox, and it invited me to send a crash report, but the import screen in the crash report became non-responsive. I am attaching an image of the Firefox screen that will come up in safe mode.

more options

tools > options > general > performance

and check the box next to Use recommended performance settings.

more options

As you may see if you enlarge the image that I attached, the menu bar does not show, so there is no way that I can access "tools". Now, when I attempt to initiate Firefox, I get only the small box with a choice between "safe mode" and "refresh". If I choose "safe mode", it comes up as shown in the image. If I choose "refresh", the box goes away and nothing else happens.

more options

about:preferences

more options

When the Firefox screen comes up, such as it does, it is immediately not responsive. I cannot access anything that is normally on the Firefox screen. There is no way that I can get to "about". As you may note from prior correspondence, There seems to be something that is not removed in the "uninstall" process nor by means of deleting folders that is preventing Firefox from installing properly. Incidentally I have done a virus scan on the computer with McAfee Anti-Virus Plus, and it reported that no threats were detected.

more options

see this page:

and remove firefox from whitelisted softwares in your security software and added it again.

more options

If you are still having problems,

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

more options

I have tried removing and adding Firefox in the McAfee firewall, and Firefox still comes up not responsive.

When Firefox comes up in safe mode, any click on the screen brings up a message that Firefox is not responding (just as when it's not in safe mode), so there is no opportunity to attempt to choose any website, secure or otherwise.

I was able, as far as I can tell, to submit a crash report, into which I added my email address and a brief explanation of my problem. Perhaps there is something in the report that will allow somebody to figure out what's going on.

more options

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.


https://support.kaspersky.com/viruses/utility