ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox for Android doesn't load webassembly

  • 19 ردًا
  • 2 have this problem
  • 312 views
  • آخر ردّ كتبه Jaap

more options

I'm programming a webassembly site (http://ictz.net) with .Net Core & Blazor.net.

It does load in Firefox for Windows not in Firefox for Android, on my mobile phone & tablet.

It does in other browsers for Android.

Attached screenshots

Modified by Jaap

الحل المُختار

This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758

Let's wait, what devs say about it.

Read this answer in context 👍 1

All Replies (19)

more options

Hi

This does not sound like an issue with Firefox for Android, but more like a web development query. I would recomend asking about this issue at https://stackoverflow.com/.

more options

You think?

Why?

more options

Blazor works in Firefox for Windows. Blazor works in other mobile browsers

Blazor doesn't work in Firefox for Android.

That's why I come here first.

"Sounds like"? Well, it sounds like a Firefox for Android problem to me. But hey, that's me. And I'm #nobody.

more options

But then again, if no 'Firefoxer' is listening here, I wasted my time here.

more options

Oh, and one more thing: where it works and where it doesn't work was stated in my initial post here.

I really don't like to repeat myself.

more options

"Sounds like" ... With no further explanation whatsoever.

Yeah right!

more options

Hi

I have seen similar issues to this in the past causing errors due to the site and not Firefox for Android. The experts at Stackoverflow should be able to help you with this.

more options

Similar issues? Really?

Why don't I believe you ...

https://www.google.com/search?q=firefox+android+webassembly+loading

Okay, this is a waste of my time.

more options

Just Remember this: "webassembly" & "firefox for android"

Hell, see if I care.

more options

Hi

I am not sugguesting that Firefox for Android has a problem with WebAssemby, but it might be a per site issue that needs to be rectified.

more options

I AM suggesting that it (ffa) has a problem with webassembly.

That's why I posted the issue here, and _not_ on stackoverflow.

Found _any_ similar issues already? Or does it still sounds like a website problem to you?

Do you actually have any clue why I posted it here? Any experience with webassembly?

more options

FYI:

It's not my code.

Perhaps it's the .Net Core Blazor webassembly compiler OR Firefox for Android has a problem with (compiled) Blazor webassembly. And there isn't such a thing as Blazor webassembly, Blazor websassembly = webassembly. Compiled binary code which runs in _all_ browsers.

The site runs in Firefox for Windows. And that's the _only_ reason I first posted a message about it here. You could think the webassembly engines would be the same. At least, that's is what I'm thinking.

At last, it could even be a problem with the platform it runs on (Ubuntu) or the webserver I'm using (Kestrel), but still, it runs perfectly in Firefox for Windows. Alas, my question here.

It's great if you try to help, but if you do not understand my question it's not very helpful.

And that's why "sounds like" & "similar issues" aren't helpful at all.

more options

Just installed Firefox Focus (Android) and guess what ..

It runs in Firefox Focus.

Sounds like a Firefox (for Android) problem to me.

Hello? Anyone?

more options

Screenshot (Firefox Focus)

more options

الحل المُختار

This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758

Let's wait, what devs say about it.

more options

TyDraniu said

This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758 Let's wait, what devs say about it.

Thank you!

I thought the devs were monitoring this forum as well, didn't yet know about 'bugzilla'.

more options

TyDraniu said

This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758 Let's wait, what devs say about it.

FYI: The site works in Firefox Focus (Android) as well. Just not in Firefox for Android.

I've uploaded another screenshot with the Focus result, see above.

Modified by Jaap

more options
FYI: The site works in Firefox Focus (Android) as well. Just not in Firefox for Android.

I know, but this is a chromium/blink engine.

I thought the devs were monitoring this forum as well

No, not really.

more options

TyDraniu said

This is the issue for me, I filled a bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1489758 Let's wait, what devs say about it.

Thank you so much for your answer TyDraniu, and for posting it at Bugzilla. Somebody else encountered the same problem, just 4 days ago, and Firefox devs at Bugzilla are picking it up.

Thanks again.