X
Tap here to go to the mobile version of the site.

منتدى الدعم

FireFox won't update because it says I'm using XP ... I AM NOT Using XP, I am using Win7. Why does FireFox not recognize my correct OS?

Posted

Fire Fox is saying that I'm using XP so it doesn't update. However, I am NOT using XP, I AM using Win7 Professional.

Fire Fox is saying that I'm using XP so it doesn't update. However, I am NOT using XP, I AM using Win7 Professional.

Chosen solution

hi ParSix2000, please check that you haven't set firefox to run in windows xp compatibility mode - more details in: https://support.mozilla.org/en-US/questions/1232291

afterwards you could also download a fresh version of firefox from https://www.mozilla.org/firefox/all/ in order to switch from the esr update channel to regular release builds.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 18.11.20055
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.9
  • A plugin to detect whether the Adobe Creative Cloud is installed on this machine.v_2_0_0_0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.181.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 30.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.8.198
  • 5.1.50907.0
  • VLC media player Web Plugin
  • WildTangent Games App V2 Presence Detector
  • NPWLPG

Application

  • Firefox 52.9.0
  • User Agent: Mozilla/5.0 (Windows NT 5.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
  • Support URL: https://support.mozilla.org/1/firefox/52.9.0/WINNT/en-US/

Extensions

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.10 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 630
  • adapterDescription2:
  • adapterDeviceID: 0x0fc2
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterSubsysID: 27501462
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22164
  • driverDate: 5-27-2015
  • driverDate2:
  • driverVersion: 9.18.13.5306
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'blacklisted', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'#BLOCKLIST_FEATURE_FAILURE_DL_BLACKLIST_g37', u'type': u'env'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'ApzWheelInput': 1, u'ApzTouchInput': 1, u'AzureFallbackCanvasBackend': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • supportsHardwareH264: Yes; Using D3D9 API
  • webgl2Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 630 Direct3D11 vs_5_0 ps_5_0)
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 630 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
philipp
  • Top 25 Contributor
  • Moderator
5324 solutions 23509 answers

Chosen Solution

hi ParSix2000, please check that you haven't set firefox to run in windows xp compatibility mode - more details in: https://support.mozilla.org/en-US/questions/1232291

afterwards you could also download a fresh version of firefox from https://www.mozilla.org/firefox/all/ in order to switch from the esr update channel to regular release builds.

hi ParSix2000, please check that you haven't set firefox to run in windows xp compatibility mode - more details in: https://support.mozilla.org/en-US/questions/1232291 afterwards you could also download a fresh version of firefox from https://www.mozilla.org/firefox/all/ in order to switch from the esr update channel to regular release builds.

Question owner

THANK YOU ... I did have settings set for XP. Changed it to Win 7 and got the updates. Thank you again for your help.

THANK YOU ... I did have settings set for XP. Changed it to Win 7 and got the updates. Thank you again for your help.