X
Tap here to go to the mobile version of the site.

منتدى الدعم

Anything cilicked in Get Add-ons in TB60 opens in Firefox

Posted

Last night I decided to change from TB52.9.1 to 60. Mostly no problem, other than a frantic search, eventually successful, to find a version of Theme Font & Size Changer that works in it. But I have one problem.

If I open the Add-ons manager and go to Get Add-ons, anything I click on and any search I try to do opens in Firefox instead of Thunderbird's own browser - which means I have to search for extensions and themes in Firefox and then try to download them as xpi files to install manually in Thunderbird as if they were externally hosted rather than just being able to install them directly from the add-on page in Thunderbird. This is ... aggravating. This didn't happen in TB52, and I'm not aware of having changed any settings at all other than related to my attempts to get the TB display font size up to what it been again.

Is there some configuration setting I need to change to get Thunderbird opening links from the Get Add-ons page in its own browser again, or is this a known bug? Any help appreciated.

Last night I decided to change from TB52.9.1 to 60. Mostly no problem, other than a frantic search, eventually successful, to find a version of Theme Font & Size Changer that works in it. But I have one problem. If I open the Add-ons manager and go to Get Add-ons, anything I click on and any search I try to do opens in Firefox instead of Thunderbird's own browser - which means I have to search for extensions and themes in Firefox and then try to download them as xpi files to install manually in Thunderbird as if they were externally hosted rather than just being able to install them directly from the add-on page in Thunderbird. This is ... aggravating. This didn't happen in TB52, and I'm not aware of having changed any settings at all other than related to my attempts to get the TB display font size up to what it been again. Is there some configuration setting I need to change to get Thunderbird opening links from the Get Add-ons page in its own browser again, or is this a known bug? Any help appreciated.
Quote
Matt
  • Top 10 Contributor
  • Moderator
2983 solutions 20228 answers

I have filed a bug as I can reprodice your experience. I am guessing there is probably already one there, but I can not find it. So watch this link for either comment or closure as a duplicate. https://bugzilla.mozilla.org/show_bug.cgi?id=1482780

Note my slight variation on your experience. I get an allow for installs on the top of the addon tab.

I have filed a bug as I can reprodice your experience. I am guessing there is probably already one there, but I can not find it. So watch this link for either comment or closure as a duplicate. https://bugzilla.mozilla.org/show_bug.cgi?id=1482780 Note my slight variation on your experience. I get an allow for installs on the top of the addon tab.
Was this helpful to you?
Quote

Question owner

Thanks for creating the bug.

I get nothing like an Allow banner across the Get Add-ons page of the Add-ons Manager tab. Anything I click on in the Get Add-ons page, like one of the featured add-ons that should take me to its page, or the Browse all add-ons link, simply causes that page to open in Firefox.

If I search from the box at the top of the Extensions page, the results do open in another tab in Thunderbird, and I can install from the buttons by the results, with a banner at the top saying it has been blocked but letting me click to allow it (which as you say is odd default behaviour given it is the official Thunderbird add-ons site). But if I click on one of the search results to see its page, not just the abbreviated bit in the search results, that page again opens in Firefox, and it is very irritating to find myself sent off to my browser to read the add-on page, but then have to come back to Thunderbird to click the install link in the search results to actually install it or look at the next search result. Something is messed up making lots of links open in Firefox instead of in tabs of the Thunderbird browser.

Making it worse when I'm sent off to Firefox is that in that I don't appear to be able to filter to show only add-ons rated to work in TB60+, unlike in Thunderbird where I can. It's all a bit of a mess.

Thanks for creating the bug. I get nothing like an Allow banner across the Get Add-ons page of the Add-ons Manager tab. Anything I click on in the Get Add-ons page, like one of the featured add-ons that should take me to its page, or the Browse all add-ons link, simply causes that page to open in Firefox. If I search from the box at the top of the Extensions page, the results do open in another tab in Thunderbird, and I can install from the buttons by the results, with a banner at the top saying it has been blocked but letting me click to allow it (which as you say is odd default behaviour given it is the official Thunderbird add-ons site). But if I click on one of the search results to see its page, not just the abbreviated bit in the search results, that page again opens in Firefox, and it is very irritating to find myself sent off to my browser to read the add-on page, but then have to come back to Thunderbird to click the install link in the search results to actually install it or look at the next search result. Something is messed up making lots of links open in Firefox instead of in tabs of the Thunderbird browser. Making it worse when I'm sent off to Firefox is that in that I don't appear to be able to filter to show only add-ons rated to work in TB60+, unlike in Thunderbird where I can. It's all a bit of a mess.
Was this helpful to you?
Quote
اطرح سؤالا

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.