Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Is this "critical update" JUST about security or does it make half of the add-ons useless again?

  • 2 replies
  • 1 has this problem
  • 55 views
  • آخر ردّ كتبه guymark

more options

Each time I update firefox, it seems useful add-ons like adblockers etc suddently are no longer compatible. No warning, no "undo" option - just "this doesn't work anymore".

There doesn't seem to be any way of working out how much damage each update causes - can you not give SOME guidance to help us work out whether we need to download - and for example if we need to export out password list with an add-on before you make sure it will never work again.

Just think the odd "Update Info" with a little blurb about what is involved and what is likely to stop working would be very helpful. As it is, it seems that if you need to use add-ons, people are increasingly suggesting Chrome.

Pity, I have been with FF for years - but it does seem other browsers don't seem to have the same amount of issues with add-ons suddenly failing after an update.

Chosen solution

If you have add-ons running in 59, they will run in later versions of Firefox. That's a major advantage to the new add-on system, updates won't break add-ons. You should always remain fully up to date. Te current version is 61.0.2, so please update ASAP

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

If you have add-ons running in 59, they will run in later versions of Firefox. That's a major advantage to the new add-on system, updates won't break add-ons. You should always remain fully up to date. Te current version is 61.0.2, so please update ASAP

more options

Thank you for that, that's really helpful :)